LED Streifen an Raspberry PI spinnt?

  • Hallo Leute,

    ich habe mir folgende Artikel dazu gekauft:

    https://www.amazon.de/Fernbedienung-IR-Empf%C3%A4nger-DC-Netzteil-Beleuchtung-Dekoration/dp/B07F41HCLC/ref=as_li_ss_tl?ie=UTF8&linkCode=sl1&tag=dordnungde-21&linkId=e7d580c4d9b1d63e41c1b23c78b72bc4&language=de_DE (Affiliate-Link)

    https://www.amazon.de/gp/product/B00MWMEIF2/ref=as_li_ss_tl?ie=UTF8&linkCode=sl1&tag=dordnungde-21&linkId=7e7b142525e85fbc053ebecf617c2acc (Affiliate-Link)

    https://www.amazon.de/Elegoo-Steckbr%C3%BCcken-Breadboard-Jumperkabel-Wiederverwendbare-Farbig/dp/B06XBHXWBD/ref=as_li_ss_tl?ie=UTF8&linkCode=sl1&tag=dordnungde-21&linkId=c79a75a0cb6096e95f77ca7faf7e5154&language=de_DE (Affiliate-Link)

    https://www.amazon.de/gp/product/B01FUSPK74/ref=as_li_ss_tl?ie=UTF8&linkCode=sl1&tag=dordnungde-21&linkId=e7c3c60210c07cd39e08a99adcb453f2 (Affiliate-Link)

    https://www.amazon.de/dp/B00SSXS7G0/ref=as_li_ss_tl?ie=UTF8&linkCode=sl1&tag=dordnungde-21&linkId=b3487fb9d371bdd0fe60481a600fc6c2 (Affiliate-Link)

    https://www.amazon.de/gp/product/B00TMCDSXS/ref=as_li_ss_tl?ie=UTF8&linkCode=sl1&tag=dordnungde-21&linkId=825fbd3ab3d3d86e6d6e07a5633cd5cc (Affiliate-Link)

    https://www.amazon.de/ABOX-Raspberry-Ultimatives-Starterkit-aus-Schaltnetzteil/dp/B07DDCRFP6/ref=sr_1_fkmr1_2?__mk_de_DE=%C3%85M%C3%85%C5%BD%C3%95%C3%91&keywords=raspberry+pi+3+model+b%2B+geh%C3%A4use+abox&qid=1564243575&s=gateway&sr=8-2-fkmr1 (Affiliate-Link)

    Nun habe ich auf dem PI das neue Raspian Buster installiert. Das ganze ich habe verkabelt. Nun möchte den Aufbau testen und habe das Problem, dass der Strip überhaut nicht leuchtet. (Der Aufbau ist auf den Bildern zu sehen). Das ganze ist 1beim PI bei der GPIO auf dem Ground-Pin(6) und dem Pin-17 angeschlossen. Im Strip habe ich die Farbe und ein Stromkabel angeschlossen. Wenn ich jetzt den Ground-Pin entferne leuchtet der Streifen weis bzw. wenn ich den Mosfet entferne leuchtet er dann rot, aber lässt sich dann nicht ein und auschalten. Nun wie löse ich das dies wieder funktioniert. Auf Raspian Jessie ging dies, aber bei Buster nicht...

    LG Platofan23

  • Hallo Platofan23, willkommen im Forum!

    Ich sehe keinen Fehler in Deiner Schaltung - aber das was Du beschreibst scheint eigenartig:

    Weiß dürfte er nur leuchten, wenn Du alle 3 Pins auf GND hängst und den schwarzen auf +. - kann es sein, dass Du auf einer der beiden LED Stripe seiten einen "Kurzschluss" hast?

    Die Farbgebung am LED Streifen ist etwas eigenartig. Rot, Grün und Blau ist gut - aber so wie es auf den Amazon Bildern aussieht ist schwarz die gemeinsame Anode (also +12V anschließen). Schwarz ist normalerweise die Farbe für Ground...

    Schließe doch mal den Schwarzen auf +12V und den roten auf GND - leuchtet der LED Streifen wie erwartet rot?

    Ich würde übrigens auch empfehlen passende Farben zu verwenden - schwarz für GND und rot für +12V - das hilft ungemein - auch beim Helfen...

    ...wenn Software nicht so hard-ware ;) ...

    Freue mich über jeden like :thumbup:

  • Also wenn ich den PI weglasse leuchtet der Streifen in den Farben, wie er soll. Er ist das Kabel vom Groundpin, wo alles wieder ausgeht. Dazu wird der Mosfet und der PI ziemlich warm. Das witzige ist auch, dass es ja bei Raspian Jessie noch funktionierte. Es fing an, dass ich grün nicht steuern konnte und dann ging nichts mehr. Vielleicht hole ich mir einfach neue Mosfets bzw, andere und versuche es dann einfach nochmal. Auch der Streifen leuchtet am eigentlichen Controller normal und funktioniert...

  • Also, wenn der PI warm wird dann wird es gefährlich! Einmal ein Fehler beim Anschluss und die GPIOs oder sogar der ganze PI ist hinüber :angel:

    FETs sind bezüglich ESD (Elektrostatische Entladung) ziemlich empfindlich. Ich verwende daher lieber Transistoren, wo möglich. Bei größeren Strömen kommt man aber um FETs nicht herum.

    Am besten du testest Deine Schaltung ohne PI. Gate des FET auf + => LED müsste leuchten, Auf GND => LED aus.

    Besser wäre es, Du simulierst den GPIO mit einem Spannungsteiler (10K und 3K3 bei 12V: ¨3V am 3K3).

    Du kannst den FET auch sehr schnell killen, wenn am Gate die Spannung zu niedrig wird oder der Laststrom zu hoch - er fängt dann an nicht mehr schön zu schalten und verheizt Energie. Das macht er nicht lange, vor allem ohne Kühlkörper - und das war's dann...

    ...wenn Software nicht so hard-ware ;) ...

    Freue mich über jeden like :thumbup:

  • die 3,3V vom PI schalten nicht viele Mosfets! 1. möglicher Fehler.

    die 3mA die man den PI GPIO maximal belasten sollte reicht selten um einen Mosfet schnell zu schalten, 2. möglicher Fehler.


    Ohne Schaltbild und Daten verweigere ich weitere Aussagen, man kann nicht mal eben so am PI rumbasteln, einer bleibt immer auf der Strecke, der PI oder das Bastelprojekt.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Für seinen ersten Beitrag hat Platofan23 das ziemlich gut gemacht. Alle Komponenten verlinkt und die Fotos so gemacht, dass die Schaltung nachvollziehbar ist. Der IRLZ34N schaltet bei 3V UGS gut 5A (Fig. 3). Ein FET braucht nahezu keinen Gatestrom - lediglich ein wenig zum Laden/Entladen des Gates was aber erst bei höheren Schaltfrequenzen zum Tragen kommt. Ein FET funktioniert diesbezüglich anders als ein Transistor.

    ...wenn Software nicht so hard-ware ;) ...

    Freue mich über jeden like :thumbup:

  • Also, wenn der PI warm wird dann wird es gefährlich! Einmal ein Fehler beim Anschluss und die GPIOs oder sogar der ganze PI ist hinüber :angel:

    FETs sind bezüglich ESD (Elektrostatische Entladung) ziemlich empfindlich. Ich verwende daher lieber Transistoren, wo möglich. Bei größeren Strömen kommt man aber um FETs nicht herum.

    Am besten du testest Deine Schaltung ohne PI. Gate des FET auf + => LED müsste leuchten, Auf GND => LED aus.

    Besser wäre es, Du simulierst den GPIO mit einem Spannungsteiler (10K und 3K3 bei 12V: ¨3V am 3K3).

    Du kannst den FET auch sehr schnell killen, wenn am Gate die Spannung zu niedrig wird oder der Laststrom zu hoch - er fängt dann an nicht mehr schön zu schalten und verheizt Energie. Das macht er nicht lange, vor allem ohne Kühlkörper - und das war's dann...

    Das testen habe ich gemacht und der streifen leuchtet so und der mosfet wurde auch schon heiß. Also sind diese wahrscheinlich hinüber und ich werde es dann erstmal mit einem tausch probieren. Nur mit dem RPI will es nicht. Stecker vom rpi pin drinne = licht aus. Sonst flimmert es weiß nzw. in den Farben der Mosfets wie gerade das Kabel vom minus pol draußen ist. Der läuft bisher noch normal nur das er sehr warm wurde. Das ganze habe ich auch nach diesem Video gemacht https://www.youtube.com/watch?v=kP6HTepodJI. Ich kenne zwar den spannungsteiler, aber wie soll ihn mir dann so aufbauen?


    die 3,3V vom PI schalten nicht viele Mosfets! 1. möglicher Fehler.

    die 3mA die man den PI GPIO maximal belasten sollte reicht selten um einen Mosfet schnell zu schalten, 2. möglicher Fehler.


    Ohne Schaltbild und Daten verweigere ich weitere Aussagen, man kann nicht mal eben so am PI rumbasteln, einer bleibt immer auf der Strecke, der PI oder das Bastelprojekt.

    Falls das hilft kann ich das video mit den link zur webseite verlinken. https://www.youtube.com/watch?v=kP6HTepodJI dort wurde eins zu eins dasselbe gemacht. nur ich scheine iwie zu doof dafür zu sein:helpnew::helpnew:

  • das ziemlich gut gemacht

    hast Recht nur bin ich nicht allen Links gefolgt.

    Man kann es zukünftig auch besser machen, Schaltbild gehört in meinen Augen dazu.

    Falls das hilft kann ich das video

    ich bin nicht so die Videogeneration ausser zum relaxen auf der Couch, aber da will ich keine Schaltungen sehen die nur mit Glück funktionieren.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • hast Recht nur bin ich nicht allen Links gefolgt.

    Man kann es zukünftig auch besser machen, Schaltbild gehört in meinen Augen dazu.

    ich bin nicht so die Videogeneration ausser zum relaxen auf der Couch, aber da will ich keine Schaltungen sehen die nur mit Glück funktionieren.

    hier dazu nochmal mit schaltbild https://mattionline.de/raspberry-pi-led-strip-steuern/. mein rpi ist momentan mit nichts dran bei 90 grad ist das normal und was kann ich da tun?

  • Im Ernst? 90°C - wo genau und mit was hast Du das gemessen? 90°C ist ziemlich viel - da müsste ja schon die Übertemperatur Abschaltung des Raspberry ansprechen. Der Raspberry fährt in diesem Fall die Tatkfrequenz deutlich runter. Ich fürchte, dass ein kleiner (Verdrahtungs?) Fehler dazu geführt hat, dass Dein Rasperry nun einige seiner Fähigkeiten gegen eine neue eingetauscht hat: Heizen!

    Generell würde ich (Dir) empfehlen zu überlegen, ob man die Aufgabe, die der Raspberry zu erfüllen hat nicht einfach mit einem Arduino umsetzen könnte. Die Verwendung eines Arduino hat viele Vorteile - einen kennst Du nun - er ist deutlich günstiger. Außerdem ist er robuster als die GPIOs des Raspberry...

    ...wenn Software nicht so hard-ware ;) ...

    Freue mich über jeden like :thumbup:

  • Im Ernst? 90°C - wo genau und mit was hast Du das gemessen? 90°C ist ziemlich viel - da müsste ja schon die Übertemperatur Abschaltung des Raspberry ansprechen. Der Raspberry fährt in diesem Fall die Tatkfrequenz deutlich runter. Ich fürchte, dass ein kleiner (Verdrahtungs?) Fehler dazu geführt hat, dass Dein Rasperry nun einige seiner Fähigkeiten gegen eine neue eingetauscht hat: Heizen!

    Generell würde ich (Dir) empfehlen zu überlegen, ob man die Aufgabe, die der Raspberry zu erfüllen hat nicht einfach mit einem Arduino umsetzen könnte. Die Verwendung eines Arduino hat viele Vorteile - einen kennst Du nun - er ist deutlich günstiger. Außerdem ist er robuster als die GPIOs des Raspberry...

    hallo. tut mir leid für die späte antwort. bin spontan nochmal in den urlaub gefahren. die temperatur habe ich über /opt/vc/bin/vcgencmd measure_temp ausgeben lassen. vielleicht werde ich es ja mal so machen, wie du es mir empfohlen hast

  • vielleicht werde ich es ja mal so machen, wie du es mir empfohlen hast

    vielleicht erstellst du auch mal ein Schaltbild wie du es verkabelt hast, bzw. erkennst den Unterschied Verdrahtung Schaltplan :P

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • mein rpi ist momentan mit nichts dran bei 90 grad

    Falls du mit "nichts dran" den PI ohne Schaltung meinst im Leerlauf dann klingt das eher nach einem Defekt der Hardware.


    Auch wenn Buster ein paar Grad wärmer wird als Stretch, ich bekomme meinen auch ohne aktive Kühlung nicht über 80°C da er ab 70 stark zurück fährt und kurz vor 80 meistens aufhängt. Das erreiche ich aber auch nur beim Kompilieren oder mit Dutzenden offenen Browserfenstern wenn er unter Vollast läuft.


    Wie Jar bereits schreibt, ohne ein Schaltbild der Schaltung ist es schwer nachzuvollziehen was du gemacht hast, das zeichnen dauert 5 Minuten.


    Hast du die Spannung am GPIO schonmal gemessen oder verlässt du dich nur darauf was ankommen sollte?

  • ich glaube, dass die pins die benutzten pins im eimer sind und dadurch die wärme entsteht, aber ich habe es jetzt nochmal mit den anderen pins gemacht, wobei es einwandfrei funktioniert...

  • [...] Ein FET braucht nahezu keinen Gatestrom - lediglich ein wenig zum Laden/Entladen des Gates was aber erst bei höheren Schaltfrequenzen zum Tragen kommt. Ein FET funktioniert diesbezüglich anders als ein Transistor.

    Kannst du das erklären? Ich dachte der Strom zum Laden des Gate ist zwar sehr kurz vorhanden, aber extrem hoch.

  • Ich dachte der Strom zum Laden des Gate ist zwar sehr kurz vorhanden, aber extrem hoch

    stimmt ja auch, VeryPrivat schreibt ja nichts falsches aber zieht wohl falsche Schlüsse

    Ein FET braucht nahezu keinen Gatestrom - lediglich ein wenig zum Laden/Entladen des Gates was aber erst bei höheren Schaltfrequenzen zum Tragen kommt.

    erkläre nahezu keinen Gatestrom, definiere höhere Schaltfrequenz.


    Es ist doch egal ob ein dicker Kondensator einmal umgeladen werden muss für den Umladestrom, schlimmer natürlich wenn er öfter umgeladen wird.


    Rechnen wir doch mal Gatekapazität 1nF (bis dahin habe ich dicke MOSFETs schon locker gefunden). Einschaltimpuls aus dem PI sagen wir mal geschätzt 100ns von 0V auf 3,3V da komme ich auf 33mA Umladestrom, ist der Impuls kürzer entsprechend höher. Das muss der GPIO nicht mitmachen, erst Recht nicht dauerhaft.


    Nur weil MOSFET am Gate statisch keinen Strom brauchen heisst das noch lange nix.

    Am Schlimmsten die MOSFET die die dicksten Ströme schalten können haben auch die dickste Gatekapzität! und somit wird der Umladestrom hoch oder man begrenzt ihn was zum durchfahren des linearen Bereichs führt und schon ist es vorbei mit der Schaltleistung, denn 15A oder 100A gelten nur bei Rds ON im mOhm Bereich aber nicht bei langsamen durchfahren, das killt recht schnell den MOSFET, also entweder schnell umladen mit heftig Umladestrom oder begrenzer Umladestrom, dann dauerts halt länger, aber dann darf nur ein Bruchteil des maximalen FET-Strom fliessen, der muss ja dann die Verlustleistung verdauen.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Danke jar für die Erläuterungen. Ich bin ehrlich gesagt bei dem Schaltungsaufbau und der Beschreibung noch von einer statischen Ansteuerung ausgegangen, sodass eine allfällige Gatekapazität nahezu keinen Einfluss hat. Solange wir das Schaltsignal nicht im Detail kennen, müssen wir ohnehin mutmaßen.

    Was ich jedenfalls eigenartig finde ist, dass ein ändern der verwendeten GPIOs eine Verbesserung bzgl. der Erwärmung bewirkt.

    Aber ich vermute mal es könnte sein, dass diese GPIOs heizen, wenn sie einen gewisses Schaltsignal ausgeben - diese Beschaltung sollte jedenfalls keinen Einfluss haben.

    ...wenn Software nicht so hard-ware ;) ...

    Freue mich über jeden like :thumbup:

  • Was ich jedenfalls eigenartig finde

    ich finde das nicht eigenartig, sinnloses Gebastel am PI ohne Ahnung und noch schlimmer ohne Schaltplan wird am PI gerne mit Port TOD bestraft, das andere Ports nun eine gewisse Zeit funktionieren ändert ja an der Tatsache nichts das die auf Grund mangelhafter Beschaltung auch irgendwann sterben. Das Spiel kann man so lange treiben bis alle Port getötet sind, deswegen wird die Anschaltung auch nicht richtiger. Mit einem neuen PI beginnt das von vorne.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)