RasPi4 und Problem mit OWFS

  • Hallo,

    Hier die Abfragen beim RasPi4 mit neu erstelltem Buster:

    Code
    ls -la /etc/apt/trusted.gpg
    -rw-r--r-- 1 root root 2452 Sep 26 02:09 /etc/apt/trusted.gpg
    Code
    cat /etc/apt/sources.list
    deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
    #deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
    Code
    cat /etc/apt/listchanges.conf
    [apt]
    frontend=pager
    which=news
    email_address=root
    email_format=text
    confirm=false
    headers=false
    reverse=false
    save_seen=/var/lib/apt/listchanges.db
    Code
     cat /etc/apt/sources.list.d/raspi.list
    deb http://archive.raspberrypi.org/debian/ buster main
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
    #deb-src http://archive.raspberrypi.org/debian/ buster main

    Die Angaben mit RasPi3 folgen.

    Soll ich sie vom laufenden System, also mit Stretch und ioBroker usw. machen? Das ginge schnell.

    Oder mit der SD aus dem RasPi4 mit Buster und sonst nichts weiter? Dann müsste ich etwas umbauen, sprich dauert einen Moment.

    Viele Grüße
    DocAdams

    1x RaspberryPi 2, 1x RaspberryPi 3, 1x OpenELEC, 1x RaspberryPi 4 mit ioBroker ,

  • Oder mit der SD aus dem RasPi4 mit Buster und sonst nichts weiter?

    Mit der SD aus dem PI4, nach dem Du im PI 3 ein:

    Code
    sudo apt-get update

    gemacht hast.


    EDIT:


    Welchen Kernel benutzt Du mit PI4 bzw. welchen mit dem PI3:

    Code
    uname -a

    ?


    Beinhaltet die config.txt Eintragungen, die nur den PI4 betreffen:

    Code
    tail -n 20 /boot/config.txt

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited 2 times, last by rpi444 ().

  • RasPi4:


    RasPi3 mit Stretch:

    Die Angaben mit dem RasPi3 und der Buster-SD kommen später

    Viele Grüße
    DocAdams

    1x RaspberryPi 2, 1x RaspberryPi 3, 1x OpenELEC, 1x RaspberryPi 4 mit ioBroker ,

  • Hm, ich bekomme die Buster-SD vom RasPi4 nicht mehr zum Laufen im RasPi3.

    Das einzige, was ich seither gemacht habe ist ein Upgrade im RasPi4.


    Ob er überhaupt startet, weiß ich nicht, ich habe kein HDMI-Kabel...

    Die LEDs leuchten scheinbar wie immer. Aber Kitty findet keinen Kontakt und in der FritzBox taucht der RasPi auch nicht auf...

    Viele Grüße
    DocAdams

    1x RaspberryPi 2, 1x RaspberryPi 3, 1x OpenELEC, 1x RaspberryPi 4 mit ioBroker ,

  • Hm, ich bekomme die Buster-SD vom RasPi4 nicht mehr zum Laufen im RasPi3.

    Das einzige, was ich seither gemacht habe ist ein Upgrade im RasPi4.

    Dann schau mal auf deinem PI4 nach, was updatet worden ist, mit z. B.:

    Code
    tail -n 50 /var/log/apt/term.log


    EDIT:


    Evtl. liegt es am EEPROM-bootloader des PI4.


    Versuch mal im PI3, nach dem Du im PI4, dessen update-service-unit deaktiviert hast:

    Code
     sudo systemctl stop rpi-eeprom-update
    sudo systemctl disable rpi-eeprom-update


    Ist der Eintrag "dwc_otg.lpm_enable=0" in der /boot/cmdline.txt bzw. die Datei "/boot/bootcode.bin" noch vorhanden?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Sorry, lange Pause. Wenn aber Enkelchen komme, ist FamilyFist ;)


    Um sicher zu gehen, dass ich nichts falsch gemacht habe, werde ich noch mal neu beginnen und alles dokumentieren. Mal sehen, wie weit ich komme.


    Als Erstes lade ich das Buster-lite-Installationsimage vom 29.9.19 auf die SD.

    Image wird vom RasPi4 erkannt.

    Ich stecke es ohne weitere Aktionen in den RasPi3.

    Im RsPi3

    Ich denke, das war fehlerfrei.

    in der /etc/owfs.conf

    server: usb = all
    server: port = 127.0.0.1:4304

    angepasst. Danach

    Code
    sudo systemctl restart owserver

    Der Adapter mit den angeschlossenen Sensoren wird erkannt. Im RasPi3 alles bestens.


    ... und im Raspi4 der DS9490R ebenfalls mit den angeschlossenen Sensoren erkannt.


    Ich sichere das erst mal.

    Im nächsten Post beatworte ich deine Fragen aus #40

    Viele Grüße
    DocAdams

    1x RaspberryPi 2, 1x RaspberryPi 3, 1x OpenELEC, 1x RaspberryPi 4 mit ioBroker ,

    Edited once, last by docadams ().

  • Ich hatte vorhin vergessen zu sagen, es klappt echt nicht, OWSF aud eine Buster-SD im RasPi 4 zu installieren. Ich hatte es vorher noch mal probiert.


    Die folgenden Abfragen stammen vom RasPi3 mit aktuellem Stretch:

    Code
    ls -la /etc/apt/trusted.gpg
    -rw-r--r-- 1 root root 4630 Jan 28  2019 /etc/apt/trusted.gpg
    Code
    cat /etc/apt/sources.list
    deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
    #deb-src http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi
    Code
    cat /etc/apt/listchanges.conf
    [apt]
    frontend=pager
    confirm=false
    email_address=root
    save_seen=/var/lib/apt/listchanges.db
    which=news
    Code
    cat /etc/apt/sources.list.d/raspi.list
    deb http://archive.raspberrypi.org/debian/ stretch main ui
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
    #deb-src http://archive.raspberrypi.org/debian/ stretch main ui

    Viele Grüße
    DocAdams

    1x RaspberryPi 2, 1x RaspberryPi 3, 1x OpenELEC, 1x RaspberryPi 4 mit ioBroker ,

  • Die folgenden Abfragen stammen vom RasPi4 mit ursprünglichem nicht aktualisiertem Buster. Außerdem habe ich inzwischen in raspi-config die de_DE.UTF8 UTF-8 eingespielt und das Update in Raspi-config eingespielt. Die Sensoren werden trotzdem erkannt ;)

    Code
    ls -la /etc/apt/trusted.gpg
    -rw-r--r-- 1 root root 2452 Sep 26 02:09 /etc/apt/trusted.gpg
    Code
    cat /etc/apt/sources.list
    deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
    #deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
    Code
    cat /etc/apt/listchanges.conf
    [apt]
    frontend=pager
    which=news
    email_address=root
    email_format=text
    confirm=false
    headers=false
    reverse=false
    save_seen=/var/lib/apt/listchanges.db
    Code
    cat /etc/apt/sources.list.d/raspi.list
    deb http://archive.raspberrypi.org/debian/ buster main
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
    #deb-src http://archive.raspberrypi.org/debian/ buster main

    Als (hoffentlich) letzte Aktion führe ich erstlals auf Buster ein Upgrade durch. Wenn dann OWFS immer noch korrekt läuft, habe ich meine Lösung gefunden.

    Viele Grüße
    DocAdams

    1x RaspberryPi 2, 1x RaspberryPi 3, 1x OpenELEC, 1x RaspberryPi 4 mit ioBroker ,

  • Hallo,

    ich bin relativer Newbi was den RasPi angeht.

    Mein Eindruck ist, dass OWFS Funktionalität bereits in Buster auf RasPi 4 integriert ist.

    Wenn das OneWire Interface (über einen GPIO - ohne I2C oder USB Adapter) per config aktiviert wird, dann erscheinen die angeschlossenen OneWire Devices angeblich als Files - wie im OWFS.

    Vielleicht ist das der Grund, warum die Installation des "echten" OWFS auf dem RasPi 4 fehlschlägt?

  • Mein Eindruck ist, dass OWFS Funktionalität bereits in Buster auf RasPi 4 integriert ist.

    Nein

    dann erscheinen die angeschlossenen OneWire Devices angeblich als Files

    Nicht nur angeblich, sondern 100%ig, aber das hat nichts mit dem OWFS zu tun. Es ist typisch für Linux, alles, auch Hardware, als Dateien auszugeben. Daher der von Linuxern gepräte Satz: "Everything is a file" bzw. "Alles ist eine Datei".

  • Hallo,

    ich habe leider auf den akt. Raspi 4b( raspberrypi 5.4.79-v7l+) das gleiche Problem (Server läuft nicht, HTTP geht nicht).

    Angeblich started owserver, aber ich kann nicht via http://raspi:2121 die Testseite öffnen.

    Ich sehe zwar eine Warning - aber keinen Fehler...

    Ideen?

    Edited once, last by craspi ().

  • Hallo,

    bei manuellen Start via OWFS bekomme ich die Sensoren jetzt in ioBroker ans laufen. OWServer läuft weiterhin nicht - bin etwas ratlos. Evtl. hilft es andere das via OWFS (/mnt/onewire) zum Laufen zu bekommen...