Direkte Verbindung via LAN-Kabel mit Buster noch moeglich?

  • Hallo zusammen,


    bisher habe ich die Raspis oft mit einem Ethernet-Kabel direkt mit dem PC verbunden. Jetzt habe ich einen Raspi 3 mit Buster aufgesetzt und kriege es nicht mehr hin :wallbash:


    Auf dem Raspi ist eine statische IP eingestellt (mit dem LAN-Manager), beim PC ebenso. Wechsel des Ethernetkabels hat nichts gebracht, Wechsel von Windows auf Linux beim PC auch nicht. Ein zweiter PC bringt ebenfalls keine Verbindung zustande. Die Wahrscheinlichkeit dass es am Raspi liegt ist also SEHR hoch.


    Wenn PC und Pi im LAN haengen laeuft es und im Internet ist zu dieser Frage nichts zu finden.


    Hat einer von euch das schon mal probiert?

  • Die Wahrscheinlichkeit dass es am Raspi liegt ist also SEHR hoch.

    Hier auch ein PI3 mit buster und die direkte Kabelverbindung funktioniert ohne Probleme:

    Code
    pi@raspberrypi:~ $ route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.178.1   0.0.0.0         UG    303    0        0 wlan0
    192.168.177.0   0.0.0.0         255.255.255.0   U     0      0        0 eth0
    192.168.178.0   0.0.0.0         255.255.255.0   U     303    0        0 wlan0

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Danke, gut zu wissen!

    Denn Zuhause schlummert auch ein PI 3B+ mit Buster, der aber von Anfang an mit WLAN läuft.

    Aber falls ich da ein LAN Kabel anschließe und es geht nicht, dann weiß ich jetzt warum und was zu tun ist.

  • Ich hab's jetzt rausgefunden: unbedingt "Automatically detect missing Options" rausnehmen, dann geht es...

    :thumbup:Sagst Du bitte noch wo man diese Option rausnehemn muss? Die ist mir noch nie untergekommen.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • das ist schon sehr speziell:

    • statische IP an PC und Raspi und
    • direkt-Verbindung zwischen Raspi und PC mit LAB-Kabel

    ich habe Notebook und Raspi (Edit: RPi 3B+) über WLAN am Internet,

    dynamische IP (=default) an Raspi und Notebook

    der Raspi bekommt automatisch die IP: 169.254.108.58

    wenn er, am Notebook mit LAN-Kabel angeschlossen, bootet.

    ich kann ihn mit putty erreichen,

    als erstes habe ich einen falschen WLAN-Zugang eingetragen in /etc/wpa_supplicant/wpa_supplicant.conf und

    dann rebootet mit sudo reboot, putty gestartet und hier die Ausgabe von ip a:

    Schönen Gruß, kle

    Edited 2 times, last by kle ().

  • framp: Sagst Du bitte noch wo man diese Option rausnehemn muss? Die ist mir noch nie untergekommen.



    kle: das ist schon sehr speziell:

    • statische IP an PC und Raspi und
    • direkt-Verbindung zwischen Raspi und PC mit LAB-Kabel

    Ganz einfach: der PC und der Pi kommen in ein fremdes WLAN wo Verbindungen zwischen beliebigen IPs gesperrt sind. Dort brauche ich eine SSH-Verbindung, weil ich nicht noch Monitor und sonstiges Zubehoer mitschleppen will...


    Keine Ahnung wo der Netzwerkmanager dort hockt, und wie viel Aufwand es brauchen wuerde bis er die Verbindung zulaesst. Mit dem Kabel kann ich das elegant umgehen.

  • ich habe Notebook und Raspi (Edit: RPi 3B+) über WLAN am Internet,

    dynamische IP (=default) an Raspi und Notebook

    der Raspi bekommt automatisch die IP: 169.254.108.58

    wenn er, am Notebook mit LAN-Kabel angeschlossen, bootet.

    ich kann ihn mit putty erreichen,

    BTW: Aber zum booten mit am Notebook angeschlossenem LAN-Kabel muss man den PI3(+) (evtl. auch noch mit einem lite-OS) stromlos machen (... wenn er warum auch immer per WLAN/Bildschirm/Tastatur nicht mehr erreichbar ist). Genau das will man doch vermeiden und deshalb eine permanente statische IP-Adresse am eth0-Interface.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden