codelite Installation nicht möglich, 404 Not Found [IP: 93.93.128.193 80]

  • Habe gestern und heute versucht codelite zu installieren, aber immer wieder das gleiche Problem. Gibt es eine andere Möglichkeit?



    pi@raspberrypi:~ $ sudo apt-get install codelite

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:

    rpi.gpio-common

    Verwenden Sie »sudo apt autoremove«, um es zu entfernen.

    Die folgenden zusätzlichen Pakete werden installiert:

    libclang1-7 libllvm7 libwxbase3.0-0v5 libwxgtk3.0-0v5 libwxsqlite3-3.0-0

    wx-common

    Vorgeschlagene Pakete:

    codelite-plugins

    Die folgenden NEUEN Pakete werden installiert:

    codelite libclang1-7 libllvm7 libwxbase3.0-0v5 libwxgtk3.0-0v5

    libwxsqlite3-3.0-0 wx-common

    0 aktualisiert, 7 neu installiert, 0 zu entfernen und 6 nicht aktualisiert.

    Es müssen noch 16,2 MB von 26,4 MB an Archiven heruntergeladen werden.

    Nach dieser Operation werden 111 MB Plattenplatz zusätzlich benutzt.

    Möchten Sie fortfahren? [J/n] j

    Fehl:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf libllvm7 armhf 1:7.0.1-8+rpi1

    404 Not Found [IP: 93.93.128.193 80]

    Fehl:2 http://raspbian.raspberrypi.org/raspbian buster/main armhf libclang1-7 armhf 1:7.0.1-8+rpi1

    404 Not Found [IP: 93.93.128.193 80]

    E: Fehlschlag beim Holen von http://raspbian.raspberrypi.or…m7_7.0.1-8+rpi1_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

    E: Fehlschlag beim Holen von http://raspbian.raspberrypi.or…-7_7.0.1-8+rpi1_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

    E: Einige Archive konnten nicht heruntergeladen werden; vielleicht »apt-get update« ausführen oder mit »--fix-missing« probieren?

    pi@raspberrypi:~ $

  • apt-get update hatte ich schon Probiert. Aber leider auch nicht ohne Fehler, bzw. keine Zugriffsrechte. Die Dateien zu bearbeiten, Löschen oder umbenennen ist nicht möglich, auch keine Berechtigung...

    fix-missing wird nicht als befehl erkannt


    Wie kann man dieses Problem lösen?


    pi@raspberrypi:~ $ apt-get update

    Paketlisten werden gelesen... Fertig

    E: Sperrdatei /var/lib/apt/lists/lock konnte nicht geöffnet werden. - open (13: Keine Berechtigung)

    E: Das Verzeichnis /var/lib/apt/lists/ kann nicht gesperrt werden.

    W: Problem beim Entfernen (unlink) der Datei /var/cache/apt/pkgcache.bin - RemoveCaches (13: Keine Berechtigung)

    W: Problem beim Entfernen (unlink) der Datei /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Keine Berechtigung)

    pi@raspberrypi:~ $

  • Super, Danke, das war er entsprechende Tipp. Ich meine root war der Befehl um mit root rechten zu arbeiten... vor Jahren das letzte mal Linux verwendet...