ds18b20 Sensor in Reihe schalten funktioniert nicht

  • Hallo,

    zunächst einmal muss ich sagen dass ich blutiger Anfänger bin und deswegen euere Hilfe brauche. Ich habe mittels einer internetanleirung auf einem Steckbrett 2 DS18B20 Temperatursensoren an den raspberry pi angeschlossen. Der eine funktioniert auch, da ich den schonmal alleine angeschlossen habe aber der andere wird nicht erkannt wenn ich nach den sensoren Frage. Hat jemand eine Idee?

  • dann wird einer kaputt sein oder du hast Reihenschaltung falsch verstanden.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Der Sensor war nagelneu und die Anleitung habe ich 1 zu 1 aus dem internet entnommen. Ich habe sogar mal die zwei sensoren vertauscht und dann hat der alte auch funktioniert also ich denke nicht dass es an der Schaltung liegt.

  • also ich denke nicht dass es an der Schaltung liegt

    also ich denke nicht das ich hier weiterrate,


    1. zeigst du deine Schaltung nicht

    2. laufen bei mir 7 Sensoren auf 2-draht über 72m

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • aber der andere wird nicht erkannt wenn ich nach den sensoren Frage.

    Dann teste mal den anderen alleine. Wenn der eine alleine und der andere alleine funktioniert, dann bist Du vom finalen AHA Erlebnis nicht mehr weit weg.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Hallo, ich habe mich gerade nochmal weiter schlau gemacht.


    Wenn wir die entsprechenden Module beim Systemstart mitladen möchten, editieren wir die Datei „/etc/modules“ und fügen folgende Zeilen hinzu:

    1
    2
    w1-gpio
    w1-therm

    Wenn ich die datei editieren möchte kommt die Meldung:

    bash: /etc/modules: Keine Berechtigung

    HAbt ihr ne ahnung was ich falsch mache

  • Moin RudiRuessel ,


    erstmal: Herzlich Willkommen im Forum!


    Wenn ein Fühler funktioniert, warum wollt ihr denn das machen?

    Wenn wir die entsprechenden Module beim Systemstart mitladen möchten, editieren wir die Datei „/etc/modules“ und fügen folgende Zeilen hinzu:
    1
    2
    w1-gpio
    w1-therm

    Wenn ich die datei editieren möchte kommt die Meldung:

    Woher ist das? Link zeigen!!


    Ansonsten kann ich nur dem jar recht geben!!

    1. zeigst du deine Schaltung nicht

    2. laufen bei mir 7 Sensoren auf 2-draht über 72m

    Zeig uns was du da gebaut hast.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Module sollen aktuell nicht mehr über /etc/modules, sondern direkt in den (kernel-) device-tree geladen werden. Das geschieht mit einem Device-Tree-Overlay Eintrag in die Datei (boot/)config.txt.

    Da sich die Syntax der Modulaufrufe manchmal ändert, empfiehlt es sich am eigenen Sysstem in /boot/overlays/README nachzusehen, welche Parameter dem dtoverlay= Eintrag mitgegeben werden müssen, und welche per default (voreigestellt) einkompiliert sind.



    Servus !

    RTFM = Read The Factory Manual, oder so