Raspberry Pi ist trotz Port Forwarding am Router nicht von außerhalb meinen LANs erreichbar

  • Ich habe an meinem Raspberry Pi 3 B+ einen Server eingerichtet, den ich mit der IP-Adresse meines Pis aufrufen kann. Um den Server auch außerhalb meines LANs aufrufen zu können, habe ich mit meiner FritzBox an meinem Raspberry Pi folgende Portfreigaben gemacht.


    Das Problem ist, obwohl der Server läuft, kann ich außerhalb meines LANs immer noch nicht auf meinem Raspberry Pi zugreifen.


    Vorher hatte ich auf meinem Raspberry Pi eine Firewall eingerichtet, weil ich dachte, ich sollte es machen.

    https://www.elektronik-kompend…/raspberry-pi/1912191.htm

    Der Raspberry Pi ist für ein Studienprojekt und man sollte über die Hochschule auf ihn zugreifen können.


    Man sollte auf meinem Raspberry Pi vor allem mit der IPv6-Adresse darauf zugreifen können.

    Selbst, wenn ich in meiner Fritz.Box den Raspberry Pi auf Exposed Host setze, kann ich nicht auf den Raspberry Pi Server zugreifen.

    Was kann ich tun, damit der Server auf meinem Raspberry Pi auch außerhalb meines WLANs erreichbar ist?


    Nachtrag:


    Mir ist aufgefallen, dass mein Raspberry Pi zwei IPv6-Adressen und zwei IPv4-Adressen hat. Könnte es sein, dass das Problem daran liegt und wie eliminiere ich die zweite IP-Adresse?


    Edited once, last by PlainHeart53806 ().

  • Das Problem ist, obwohl der Server läuft, kann ich außerhalb meines LANs immer noch nicht auf meinem Raspberry Pi zugreifen.

    Wie greifst Du von außerhalb deines LANs auf deinen PI zu? Machst Du das von einem anderen/fremden v4-/v6-Internetanschluss? Versuch mal auch ohne den Repeater.


    EDIT:


    Hast Du eine FritzBox von deinem ISP (M-net) oder ist das deine eigene FritzBox?

    Hast Du einen Privatkunden-Tarif bei M-net?


    EDIT 2:


    Mach mal online (d. h. aus dem Internet) einen v8-Portscan und einen Ping6 mit:


    http://www.ipv6scanner.com/cgi-bin/main.py

    https://centralops.net/co/Ping.aspx

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited 3 times, last by rpi444 ().

  • Wie greifst Du von außerhalb deines LANs auf deinen PI zu? Machst Du das von einem anderen/fremden v4-/v6-Internetanschluss? Versuch mal auch ohne den Repeater.


    Indem ich ca. 10 Meter von meiner Wohnung entfernt von einem anderen Rechner oder mit meinem Smartphone die IP-Adresse von meinem Raspberry Pi im Browser eingebe. Die Seite wird nur angezeigt, wenn ich mich im nahen Umkreis von meinem Router befinde.


    Hast Du eine FritzBox von deinem ISP (M-net) oder ist das deine eigene FritzBox?

    Hast Du einen Privatkunden-Tarif bei M-net?

    Die FritzBox ist von M-Net.

    Ich denke, wir haben einen Privatkunden-Tarif bei M-net.

    EDIT 2:

    Mach mal online (d. h. aus dem Internet) einen v8-Portscan und einen Ping6 mit:


    http://www.ipv6scanner.com/cgi-bin/main.py

    https://centralops.net/co/Ping.aspx

    Im Ipv6-Scanner habe ich zunächst meine IPv4-Adresse vom Raspberry Pi angegeben:


    Bei meiner IPv6-Adresse ist ebenso alles filtered, bis auf Port 1080 Socks, der ist closed.


    Unter Centralops.net ist die IPv6-Adresse unreachable und die IPv4-Adresse "is a special address that is not allowed for this tool".

    Ich gehe davon aus, dass Du einen DynDNS-Service eingerichtet hast.... oder versuchst Du es über die 192.xxxxx?


    Gruß Norbert


    Ich versuche das über Ip-Adresse. Einen DynDNS-Service habe ich nicht eingerichtet.

    Edited once, last by PlainHeart53806 ().

  • Unter Centralops.net ist ... und die IPv4-Adresse "is a special address that is not allowed as a tool".

    Welche IP-Adresse hast Du verwendet?


    Evtl. hast Du keinen Tarif bei M-net mit nativem IPv4 (... DS-lite oder CGN?).

    Siehe auf deinem PI, die Ausgabe von:

    Code
    dig +short myip.opendns.com @208.67.222.222


    und die Ausgabe von:


    Code
    dig -6 aaaa +short myip.opendns.com @2620:0:ccc::2


    EDIT:


    Quote


    192.168.177.55 is a special address that is not allowed for this tool.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited 2 times, last by rpi444 ().

  • Ich versuche das über Ip-Adresse. Einen DynDNS-Service habe ich nicht eingerichtet.

    Dann wird das nichts.
    Schau mal in Deiner Fritzbox nach der "äusseren" IP-Adresse.Die kannst Du mal versuchen; s. screenshot. Allerdings ändert sich die alle 24h.

    - Am besten in der FB den DynDNS - Service aktivieren


    Gruß Norbert


  • Welche IP-Adresse hast Du verwendet?


    Evtl. hast Du keinen Tarif bei M-net mit nativem IPv4 (... DS-lite oder CGN?).


    Einmal die IPv4-Adresse vom Raspberry Pi: 192.168.178.135

    Und die dazugehörige IPv6-Adresse: 2001:a62:1427:4001:3408:47b3:9ea4:bd4e


    Siehe auf deinem PI, die Ausgabe von:

    Code
    dig +short myip.opendns.com @208.67.222.222


    und die Ausgabe von:


    Code
    dig -6 aaaa +short myip.opendns.com @2620:0:ccc::2

    Bei ersten bekam ich die Ausgabe

    Code
    62.216.205.52

    Beim zweiten die Ausgabe

    Code
    2001:a62:1427:4001:bc92:bd78:9a82:90c6


    Dann wird das nichts.
    Schau mal in Deiner Fritzbox nach der "äusseren" IP-Adresse.Die kannst Du mal versuchen; s. screenshot. Allerdings ändert sich die alle 24h.

    - Am besten in der FB den DynDNS - Service aktivieren


    Gruß Norbert


    Ich versuche den DynDNS zu aktivieren und melde mich dazu nochmal.

  • Mit der internen IP-Adresse des PI (.135) solltest Du es aus dem Internet (d. h. von außerhalb) nicht versuchen.

    Mit der externen IPv4-Adresse (wenn die von oben noch aktuell ist) deiner FB funktioniert es z. Zt. nicht:

    Code
    :~ $ nc -zv -w 3 62.216.205.52 21 22 80 443 8080
    nc: connect to 62.216.205.52 port 21 (tcp) timed out: Operation now in progress
    nc: connect to 62.216.205.52 port 22 (tcp) timed out: Operation now in progress
    nc: connect to 62.216.205.52 port 80 (tcp) timed out: Operation now in progress
    nc: connect to 62.216.205.52 port 443 (tcp) timed out: Operation now in progress
    nc: connect to 62.216.205.52 port 8080 (tcp) timed out: Operation now in progress

    Es kann an deiner Konfiguration liegen bzw. es kann auch an deinem ISP (M-net) liegen.


    Mit IPv6 geht es auch nicht. BTW: Konfiguriere deinen PI so, dass dieser eine feste Interface-ID bei der IPv6-Adresse hat (d. h. ohne PEs und mit "slaac hwaddr" oder gleichwertig).


    EDIT:


    BTW: Wenn es mit der externen IP-Adresse nicht geht, wird es mit dyndns (oder gleichwertig) auch nicht funktionieren.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ich habe mit meinem M-Net ISP telefoniert. Zu mir hat jemand gesagt, die IPv4-Option ist bei mir nicht gebucht. :(


    Frage zur Raspberry Pi-Konfiguration: Wie kann ich auf Nummer sichergehen, dass die Konfigurationen auf meinem Pi stimmen?


    Ich werde es versuchen, eine statische IPv6-Adresse / feste Interface-ID zu konfigurieren.

  • Frage zur Raspberry Pi-Konfiguration: Wie kann ich auf Nummer sichergehen, dass die Konfigurationen auf meinem Pi stimmen?

    Wenn Du die feste Interface-ID konfiguriert hast und die PEs deaktiviert hast, hier die brauchbar anonymisierten Ausgaben von:

    Code
    ip a
    sysctl net.ipv6.conf.all.use_tempaddr

    hier posten.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • rpi444 Ich werde die Interface-ID konfigurieren.


    Ich habe von M-Net nochmal eine Email erhalten:


  • Ich habe die IPv4-Option gebucht und bin nach dieser Anleitung hier vorgegangen: https://steemit.com/deutsch/@g…et-erreichbar-teil-1-ipv6


    In dieser Anleitungen habe ich dann noch zusätzliche Einstellungen am Router vorgenommen.

    In der /etc/dhcpcd.conf hab ich erfahren dass ich "slaac private" durch "slaac hwaddr" ersetzen musste und dann hatte ich wieder eine 2001-ipv6 adresse.


    Es hat dann funktioniert.

  • Toll das es funktioniert!


    Aber das man IPv4 "dazu buchen" muss ist eine Frechheit.

    Ich hatte das Problem auch mit Vodafone/Kabel Deutschland, mit einem Anruf haben dir mir einfachIPv4 wieder aufgeschaltet, das ist bei einem Provider 1Klick!

    Dafür €4.90 im Monat zu verlangen ist Abzocke.

  • Toll das es funktioniert!


    Aber das man IPv4 "dazu buchen" muss ist eine Frechheit.

    Ich hatte das Problem auch mit Vodafone/Kabel Deutschland, mit einem Anruf haben dir mir einfachIPv4 wieder aufgeschaltet, das ist bei einem Provider 1Klick!

    Dafür €4.90 im Monat zu verlangen ist Abzocke.

    Das sehe ich genauso. Hätte ich das vorher gewusst, dann hätte ich mich in Studienprojekt für einen anderen Projektteil entscheiden sollen.

  • Hätte ich das vorher gewusst, dann hätte ich mich in Studienprojekt für einen anderen Projektteil entscheiden sollen.

    Warum hast Du dann deinen PI (und das "border device") doch nicht so konfiguriert, dass dein PI per IPv6 aus dem Internet erreichbar ist? So wie Du es in deinem 1. Beitrag doch schon erwähnt hast:

    Quote

    Man sollte auf meinem Raspberry Pi vor allem mit der IPv6-Adresse darauf zugreifen können.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Warum hast Du dann deinen PI (und das "border device") doch nicht so konfiguriert, dass dein PI per IPv6 aus dem Internet erreichbar ist? So wie Du es in deinem 1. Beitrag doch schon erwähnt hast:

    Ich hatte es auch so konfiguriert und in der /etc/dhcpcd.conf das ipv6 freigegeben. Die Sache war, ich konnte an meinem Router die IPv6-Einstellungen nur vornehmen, wenn die IPv4-Option freigeschaltet war. Und laut einem Komillitonen, mit dem ich am selben Projekt arbeite, durfte ich keine statische IPv6-Adresse nutzen. Das Hauptproblem lag an meinem ISP und an den Router-Einstellungen. Danach konnte ich auch über IPv6 auf den Webserver von meinem Pi zugreifen.

  • Die Sache war, ich konnte an meinem Router die IPv6-Einstellungen nur vornehmen, wenn die IPv4-Option freigeschaltet war.

    Das verstehe ich nicht. Was hat hier IPv4 mit IPv6 zu tun? Welchen Router hast Du?


    BTW: Eine statische IPv6-Adresse wird ja auch nicht benötigt, denn es gibt v6-ddns-Provider.


    EDIT:


    Hast Du jetzt eine statische/feste externe IPv6-Adresse bekommen?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ich habe eine Frtiz!Box 7490. Ich habe eine feste IPv6-Adresse bekommen.

  • Ich habe eine Frtiz!Box 7490.

    Aber mit einer FritzBox kann man bei nativen IPv6 z. B. DS-lite) immer eine Portfreigabe mit der v6-Firewall der FritzBox konfigurieren. Eine statische/feste IPv6-Adresse ist dafür nicht erforderlich. Bei IPv6 ist eine Portweiterleitung nicht erforderlich, da kein NAT gemacht werden muss.


    Ich denke dein ISP (M-net) wollte dir entweder ein zusätzliches Produkt (für monatlich 4,90 EUR) verkaufen oder die haben gar nicht verstanden was Du willst.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ehrlich gesagt glaube ich, dass sie mir zusätzliche Produkte andrehen wollten. Wenn der Prüfungsstress vorbei ist, werde ich die Kündigungsfrist nutzen und IPv4 wieder abbestellen.


    Vorher hatte ich nie viel mit Portfreigaben tun, weswegen ich über IPv6 nicht viel wusste, was die Konfiguration am Router betrifft. Danke dir auf jeden Fall für die Info.