Raspberry Pi 4 TTP223 Kapazitiver Touch Sensor / Taster

  • wenn ich diesen Kondensator besorgen würde, 50pF / 1000V, wo müsste ich Ihn anlöten? Rechts neben den IC?

    1000V ist etwas viel, die Kondensatoren wird es aber nicht anders geben. Ist ja nur die Spannung bis zu der man ihn verwenden kann.


    Du lötest ihn dort an, wo du den schönen grünen Kringel gemacht hast.

    Glaube ersetzt kein Wissen

  • 1000V ist etwas viel, die Kondensatoren wird es aber nicht anders geben. Ist ja nur die Spannung bis zu der man ihn verwenden kann.


    Du lötest ihn dort an, wo du den schönen grünen Kringel gemacht hast.

    Diese Kondensatoren gibt es mit Sicherheit auch für kleine Spannungen so bis max. 50V, denn mit einem SMD Bauteil wird bei 1000V Spannung der Kontakt / Pinabstand nicht ausreichen. Wenn Du den Sensor im Gehäuse angebracht ist würde ich es erst einmal mit 20pF - 30pF versuchen, sonst könnte es passieren das der Sensor nicht mehr durch das Gehäuse funktioniert. Kondensatoren kann man zur Erhöhung der Kapazität auch parallel schalten, wenn es mit 20pF noch nicht zufriedenstellend funktioniert, lötet man den nächsten Kondensator quasi im Huckepack oben drauf. Man könnte auch einen einen einstellbaren Trimm-Kondensator verwenden.

  • Nicht so ganz. Ich würde mir eher einen Kondensator in SMD Bauform bestellen, bei dem bedrahteten Kondensator könnte es Schwierigkeiten mit dem anlöten geben, auch besteht die Gefahr dass man bei Unachtsamkeit die SMD Lötpad's abreist. Bei dem Wert von 47pF könnte es passieren, dass der Sensor nicht mehr funktioniert, da auf diesem ja bereits ein 30pF Kondensator verbaut ist.


    Hast Du denn so was nicht in einer Bastelkiste? Kondensatoren sind doch in fast jedem Gerät verbaut, das Problem ist nur, den richtigen Wert zu finden.

  • Könnte sein das der Kondensator bei diesem Sensor zw. VCC und GND geschaltet ist, das müsste man halt mal ausmessen. Ich bin bisher immer davon ausgegangen, das auf dem Sensorboard schon ein Kondensator zur Störungsunterdrückung zw. Antenne und GND geschaltet ist. Ob man nun SMD oder bedrahtete Bauteile verwendet muß jeder selbst entscheiden, aber jedes längere Stück Draht könnte schon als Antenne wirken und für weitere Probleme sorgen.


    Mich wundert eh, das der Sensor so am RPi bzw. der RPi damit funktioniert. Ich wäre davon ausgegangen, das man auf dem Sensorboard eine Lötbrücke schließen muss, damit der Sensor beim Betätigen auch auf LOW schaltet und dann den Shutdown ausführt.

  • Danke erstmal an alle. SMD löten ist nicht so mein Fall und der Kondensator mit Lötbeine könnte auch Fehler verursachen.

    OK dann muss ich wohl jemanden finden der mir eine bessere ansteuerung schreibt, als die eine Kommandozeile in der config.txt.

    hyle das mit dem Skript ist erstmal so eine sache das ich programmiertechnisch nicht so bewandert bin und es sich bei dem Skript ja nur um ein "Shutdown" handelt. Die Idee dich ich hatte war ja, das man mit dem Taster den RPI herunterfahren oder starten sollte.

    wie in diesem Blog nur mit einem Sensortaster.

  • Aus deinem Link ist zu entnehmen, das der Taster den GIPIO 3 Pin beim Betätigen auf Masse schaltet, macht denn das dein Touchsensor auch? Dafür müssten doch die Kontakte AB auf der Sensorplatine gebrückt sein und die rote LED sollte aus gehen, wenn man den Sensor berührt.

    OK dann muss ich wohl jemanden finden der mir eine bessere ansteuerung schreibt, als die eine Kommandozeile in der config.txt.

    Du könntest aber auch etwas Eigeninitiative aufbringen und selbst mal ausfinden was der Eintrag in der config.txt bewirkt. Vielleicht lohnt sich ja mal ein Blick in /etc/systemd/logind.conf Ob das aber bei deinem RPi auch so ist, weiß ich leider nicht.

    • Official Post

    und es sich bei dem Skript ja nur um ein "Shutdown" handelt.

    Jain. Das Skript ist für den Shutdown verantwortlich, richtig, aber der GPIO 3 (Pin 5) macht startet den RPi ootb, also ohne irgendeinen Eintrag irgendwo. ;)


    Für diesen Test musst Du den dtoverlay=gpio-shutdown,gpio_pin=3,active_low=1,gpio_pull=up erstmal wieder entfernen oder auskommentieren.


    In dem Skript reicht es aus den GPIO 17 in 3 zu ändern, dann sieht das so aus:


    Das dann auf dem RPi erstellen ist auch ganz einfach:


    - Du gibst im Terminal nano poweroff.py ein und kopierst den Code oben hinen. Dann speichern mit STRG+O und nano beenden mit STRG+X.

    - Aufgerufen wird das dann mit python3 ./poweroff.py. Wenn das funktioniert, dann kümmern wir uns um den Autostart.

  • Fliegenhals die rote LED leuchtet nicht permanent. es ist doch ein Taster und kein Schalter. Ich tippe den Sensor kurz an und dann leuchtet kurz die LED (Pi fährt runter), dann tippe ich kurz wieder auf den Taster und die LED leuchtet auch wieder kurz auf (Pi startet)


    Der Eintrag in der Config.txt soll das ja umsetzen. Mit einem normal Taster funktioniert es ja, nur halt nicht mit dem Sensor. Und Eigeniniziative habe ich ja auch schon durch. 3 Tage habe ich versucht den Fehler zu finden. Darum habe ich mich hier angemeldet und gehoft das mir jemand zeigt wie ich es richtig machen könnte. Schaltkreise lesen ist nicht mein Ding und beim programmieren von Scripten bin ich noch neu dabei. Den Eintrag in der Config habe ich aus dem Blog. Und ich Depp dachte es ist doch einfach das zu machen, nur halt mit einem Sensor.


    hyle Das ist doch mal was womit ich was anfangen kann (und auch noch lerne)

    werde es gleich mal testen und mich melden (wird aber etwas dauern. weil wenn das Skript funktioniert muss ich ja warten ob er sich nach 2-3 Stunden wieder automatisch abschaltet oder nicht.

  • So habe GPIO Zero installiert (Python 3)
    Das das Script erstellt wie hyle geschrieben hat.
    Dann getestet.
    Kommando im Terminal eingegeben


    python3 ./poweroff.py


    nun wartet das Script ja auf eine Aktion.

    Ich habe den Sensor für weniger als 1 sec. berührt (hold time war auf 2 geschrieben) und dann wird nach dem Pi Passwort gefragt.

    Das habe ich eingegeben und dann fährt der Pi herunter.

    Wenn ich dann den Sensor wieder für weniger als 1 sec. berühre, startet er neu.

    • Official Post

    Für diesen Test musst Du den dtoverlay=gpio-shutdown,gpio_pin=3,active_low=1,gpio_pull=up erstmal wieder entfernen oder auskommentieren.

    Hast Du gemacht?


    und dann wird nach dem Pi Passwort gefragt

    Ups, war ja Octoprint. Ok, dann 'sudo', raus aus dem Skript und das dafür starten mit sudo python3 ./poweroff.py.

  • so ich dachte ja ich spinne. aber habe jetzt man meinen Camcorder raus geholt. und siehe da. ich spinne nicht. der Pi liegt auf dem Tisch und die aktivitäts LED blinkt kurz auf. das heißt ja das er irgentwas registriert hat. und das wird der Fehler sein den ich habe.


    hyle ja ich habe es ausgeklammt mit einer #


    jetzt fragt er sofort nach dem Passwort. aber dann passiert erstmal nichts. erst wenn ich den Sensor kurz antippe dann fährt er runter. ich tippe und halte keine 2 sec.

  • Fliegenhals die rote LED leuchtet nicht permanent. es ist doch ein Taster und kein Schalter. Ich tippe den Sensor kurz an und dann leuchtet kurz die LED (Pi fährt runter), dann tippe ich kurz wieder auf den Taster und die LED leuchtet auch wieder kurz auf (Pi startet)

    Mit einem Taster kann man eine Spannung oder auch das Massepotential schalten. In dem Beispiel aus deinem Link wird die Masse beim Betätigen des Tasters an GPIO 3 ( H -> L ) geschaltet. Bei deinem Touchsensor ist es genau umgekehrt, damit werden +3,3V beim Betätigen des Sensor an den GPIO 3 ( L - > H ) geschaltet.

    • Official Post

    Arrrrg!

    Quote

    Logikpegel für Tastendruck; 0 = Active High, Schalter verbindet nach 3,3 V; 1 = Active Low (Standard-Einstellung), Schalter verbindet nach GND

    #Ansteuerung An/Ausschalter

    dtoverlay=gpio-shutdown,gpio_pin=3, active_low=1,gpio_pull=up

    Ändere hier mal active_low=1 in active_low=0, danach Neustart nicht vergessen! Und versuche es nochmals ohne dem Skript.


    //Edit

    Fliegenhals Das wäre der nächste Schritt gewesen, wenn das kann man im Skript einstellen. ;)

  • Fliegenhals ich dachte die 3,3V sind nur dafür da um den Sensor mit Strom zu versorgen. weil wenn ich den VCC Pind abstecke dann funktioniert nichts. das ist mir etwas hoch. aber ich bin immer noch guter hoffnung.

  • config.txt abgeändert.

    und wieder ist es passiert. wärend der Pi jetzt nur per Tastendruck startet, hat der Sensor wieder ausgelöst und den Pi wieder herunter gefahren.

    ohne das ich den Touch berührt habe. Man ist das ein mist.