In der DOSBox keine Taste mehr dieselbe

  • Hallo,


    ich habe ein echt seltsames Problem und ich wette, dass nicht einer von euch sich das erklären kann: Ich habe es mit Stretch und mit Buster getestet, ich habe DOSBox installiert. Starte ich diese in der GUI, ist alles iO, naja außer, dass das Bild zu klein ist, aber das ist ein Problem, um das es hier nicht gehen soll. Nein, das eigentliche Problem ist, wenn ich versuche die DOSBox am CLI auszuführen, gelange ich zwar an den DOS Prompt, aber ab da ist keine Taste mehr die, sie sie sein sollte. Ein A ist nicht mehr ein A und ein B nicht mehr ein B. Auch die Sondertasten sind betroffen, so ist Eingabe bspw. nicht mehr die Eingabetaste, sondern J ist die Eingabetaste, während U Backspace ist.


    Falls nun (zufällig) doch jemand sich dieses Phänomen erklären kann, wäre ich für einen Hinweis dankbar.

  • Moin CreativePi,


    du hast vor dem Starten der dosbox auch in der Config deutsch und so eingestellt??


    Gruss Bernd


    /EDIT

    Habe mal auf einem Buster mit Desktop die dosbox installiert. Ich kann deine Fehler nicht nachvollziehen.

    Das Ganze habe über VNC getestet.

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    Edited once, last by Bernd666 ().

  • Leider ist meine Glaskugel noch in Reparatur. ich vermisse zwei essentielle Sachen, ersten fehlen jedwede Konfigurationsdateien und zweitens sehe ich keine Bereitschaft von dir selbst nach fehlenden Informationen zu suchen.



    Das Ganze habe über VNC getestet.

    Es geht um das CLI, wobei sich CreativePi nicht darüber auslässt, ob er wirklich die blanke Textkonsole (Strg-Alt-F1) oder ein Terminal-Fenster meint.

    Glaube ersetzt kein Wissen

  • Die Einstellungen von Linux sind korrekt, sonst würde es ja unter Linux nicht funktionieren. Das Problem tritt nur in der DOSBox unter Linux auf (und zwar nur unter der nicht-grafischen Oberfläche, was Ansich schon der Beweis ist, dass die DOSBox korrekt konfiguriert ist), für die ich die entsprechende Spracheinestellung in der dosbox-irgendwas.conf vorgenommen habe. Das hat aber keine Änderung gebracht. Den Keymapper habe ich weder verändert noch genutzt. Mit CLI meine ich natürlich den reinen Textmodus (ohne irgendwelches Grafik-Gedöns). Im übrigen gucke und mache ich hier schon tagtäglich dran rum. Langsam habe ich die Fachsen dicke!


    Da es sich für mich relativ aufwändig gestaltet, irgendwelche Konfigurationsdateien bereitzustellen, wollte ich erstmal sehen, was gefordert wird. Also, was braucht ihr? Die conf? Was noch?

  • Wie rufst du die DosBox in der GUI und in der CLI auf? Welche Parameter werden dort zum Start mit angegeben?

    Glaube ersetzt kein Wissen

  • Parameter übergebe ich keine. In beiden Fällen (GUI und CLI) rufe ich die DOSBox mit dem Befehl "dosbox", den ich in die Konsole tippe, auf.

  • Der einzige Weg, DOSBox zu starten, den ich kenne, ist, über die Konsole "dosbox" einzugeben (auch im Desktop-Modus).

  • Und was ist mit all den Parametern die man eingeben kann?

    Hast du das aus der manpage If no configfile is specified at the commandline, a file named dosbox.conf (if present in the current directory) will be loaded automatically. beachtet?

    Glaube ersetzt kein Wissen

  • Nochmal: Ich übergebe keinerlei Parameter. Es sollte also, die Standard-Conf "dosbox-irgendwas.conf" genommen werden. Die kann ich ja mal posten, aber die ist an und für sich korrekt, da es ja sonst unter der GUI auch nicht funktionieren würde. Außerdem deutet die Art des Problems (nicht nur ein paar Tasten sind vertauscht, sondern die ganze Tastatur ist irgendwie umgemodelt - Beispiele hatte ich genannt) nicht auf eine falsch konfigurierte Conf oder DOSBox hin.


    Die einzige Erklärung, die ich hätte, die aber nicht sehr wahrscheinlich ist, ist, dass Raspbian bereits einen Keymapper für DOSBox mitbringt, ohne aber DOSBox selbst mitzubringen. Und dieser Keymapper wird dann (von der nachträglich installierten DOSBox) genutzt, der enthält aber falsche Angaben (was zu besagtem Fehler führt).

    Edited once, last by CreativePi ().

  • Moin CreativePi,


    so, nachdem ich mal Monitor und Tastatur rausgeholt habe, kann ich deine Beobachtungen bestätigen.


    Ist schon komisch...


    Mal sehen ob ich was finde.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin!


    Im übrigen gucke und mache ich hier schon tagtäglich dran rum. Langsam habe ich die Fachsen dicke!

    Tja, anscheinend nicht richtig!!


    Die Lösung:

    usescancodes=false

    default steht dort: usescancodes=true


    ich wette, dass nicht einer von euch sich das erklären kann

    Was habe ich nun gewonnen??


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Verdammt. Das mit der "usescancodes=true" hatte ich schonmal irgendwo gelesen, aber ich weiß nicht mehr, wo. Gewonnen nicht so direkt was, aber vielleicht erfreust du dich an meiner tiefen Dankbarkeit? :)

  • Moin!


    Schade...

    Dann mach dein Thema zu, falls es erledigt ist. Das geht oben bei "Thema bearbeiten".


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.