Anleitung für Anfänger zur Installation eines Raspberry Pi 4B mit Webserver, MariaDB, Samba, Nextcloud, Letsencrypt und einem kleinen Mediaserver

  • zeig mir bitte auch noch die Ausgabe von ls -la /var/www/html/nextcloud/data

    siehe Beitrag758



    Ja, das ist dein data-Verzeichnis.

    Wenn du in dem Installationsbefehl --data-dir /media/raspberry/data oder --data-dir /media/raspberry/Nextcloud/data eigegeben hättest, dann wären die ganzen Dateien und Ordner auch in einem Unterverzeichnis "data"

    das dürfte aber ja kein Problem sein, dadurch liegen die Dateien ja nur eine Ebene höher?!



    Eine Datei index.html ist da aber auch vorhanden.

    Dann weiß ich nicht, woher die Meldung kommt.

    Naja...dann steht die Meldung halt da. Ist mir zwar nicht sympathisch, aber hilft ja nichts....

    Edited once, last by r4mses ().

  • siehe Beitrag758

    Ja, hatte sich überschnitten.


    Dann erstelle noch eine leere index.html unter /var/www


    sudo touch /var/www/index.html

    und dann

    sudo chown www-data:www.data /var/www/index.html


    und den Neustart von apache2 nicht vergessen. (das musst du immer machen, wenn du etwas änderst)

  • Die Meldung steht nach wie vor....

    dann kann ich dir leider nicht weiterhelfen. Ich habe selbst auch V 21.0, aber die Meldung habe ich nicht.

    Wenn die Nextcloud ansonsten einwandfrei läuft, dann würde ich das ignorieren.

  • Mir ist zumindest noch nichts aufgefallen...

    Ich kann mir auch nicht vorstellen, dass das ein Problem ist.


    Ich habe hier seit einem "update" auf V21 auch zwei Meldungen, die ich noch nicht wegbekomme.

    Diese Meldungen hast du bei deiner "Neuinstallation" nicht. Dafür hast du eine andere :)


    Auf jeden Fall werden deine Daten in /media/raspberry/nextcloud (data-Ordner) gespeichert. Und zwar für jeden User in einem separaten Ordner.


    Der data-Ordner in /var/www/nextcloud muss aber bleiben. Der ist ebenfalls erforderlich.

  • was für zwei Fehlermeldungen hast du denn?

    Code
    Es gibt einige Warnungen bei Deiner Systemkonfiguration.
    Dein Web-Server ist nicht richtig eingerichtet um "/.well-known/webfinger" aufzulösen. Weitere Informationen findest Du in der Dokumentation.
    Dein Web-Server ist nicht richtig eingerichtet um "/.well-known/nodeinfo" aufzulösen. Weitere Informationen findest Du in der Dokumentation.
  • Geh mal in die apache2.conf nano /etc/apache2/apache.conf


    und änder da mal


    Code
    <Directory /media/festplatte/nextcloud>    entsprechend anpassen 
            Options Indexes FollowSymLinks
            AllowOverride None All
            Require all granted
    </Directory>

    AllowOverride None All

  • AllowOverride None All

    Ich habe schon alles mögliche versucht, das Internet abgegrast...... Alle angeblichen Lösungen funktionieren nicht.


    Die Medungen mit (.well-known/caldav) sowie (.well-known/carddav)habe ich ja wegbekommen.

    Aber bei "webfinger" und "nodeinfo" funktioniert alles nicht. Stört mich aber auch nicht mehr :)

  • Alle angeblichen Lösungen funktionieren nicht.

    Prüfe mal deine Config ob für das nextcloud-Verzeichnis wirklich "AllowOverride All" gesetzt ist.

    z.B. per

    Bash
    #!/bin/sh
    /usr/sbin/a2enmod info
    /usr/sbin/apache2ctl -DDUMP_CONFIG | /bin/grep -vE "^[ ]*#[ ]*[0-9]+:$"
    /usr/sbin/a2dismod info

    Menschen die keine Ironie verstehen finde ich super!

    Edited once, last by llutz ().

  • Prüfe mal deine Config ob für das nextcloud-Verzeichnis wirklich "AllowOverride All" gesetzt ist.


    Ja, "AllowOverride All" ist gesetzt.


    Folgende Einträge in der "apache2.conf sind gesetzt

    Code
    # In file: /etc/apache2/apache2.conf
    Redirect 301 /.well-known/carddav /cloud/remote.php/dav
    Redirect 301 /.well-known/caldav /cloud/remote.php/dav
    Redirect 301 /.well-known/webfinger /cloud/public.php?service=webfinger
    Redirect 301 /.well-known/nodeinfo /cloud/index.php/.well-known/nodeinfo

    carddav und caldav funktionieren auch einwandfrei.


    Wenn man gewissen Aussagen im Netz Glauben schenken kann, funktioniert das ganze mit nginx aber nicht mit apache2.

    .webfinger und .nodeinfo hat wohl mit der neuen "social-app" von Nextcloud zu tun, die anscheinend unter apache2 auch noch nicht funktioniert


  • Das es mit nginx funktioniert kann ich aus erster Hand bestätigen

    Wie gesagt, die Meldungen interessieren mich im Grunde nicht, da ich social... auf nextcloud nicht nutze.

    Ist halt nur ein Kosmetikfehler :lol:

  • Ja, ich empfehle den Port 80 NICHT freizugeben. Über den Port 443 wird alles verschlüsselt übertragen, das ist sicherer als über Port 80, dort wird ALLES unverschlüsselt übertragen.

    Wenn dein Bruder eine Fritzbox hat, kann er in 2 Minuten eine VPN-Verbindung für dich einrichten, die kannst Du dann benutzen um darüber über SSH auf den Raspberry zuzugreifen.

    Gibt's dazu ne einfache Anleitung? Ich hab leider nichts brauchbares gefunden.


    Also von der Einrichtung des VPN bis Zugriff auf den Raspi mit SSH.

  • Gibt's dazu ne einfache Anleitung? Ich hab leider nichts brauchbares gefunden.


    Also von der Einrichtung des VPN bis Zugriff auf den Raspi mit SSH.

    Eröffne dazu bitte einen neuen Thread in einem entsprechenden Unterforum.

    Das hat mit dem Thema dieses Tutorials nur noch indirekt zu tun.

  • apache2 auch noch nicht funktioniert

    Mein nextcloud 20.0.8 auf Debian Buster mit Apache2 meckert es nicht an.

    Sorry, das V21 hab ich überlesen.


    Nachtrag nach Update auf 21.0.1:

    Nextcloud 21.0.1 (Apache-2.4.38-3, php7.3 unter Buster) meckert es nicht an und die well-known-URLs werden korrekt aufgelöst.

    JSON-Antwort: {"message":"webfinger not supported"} (desgleichen mit "nodeinfo")


    Menschen die keine Ironie verstehen finde ich super!

    Edited 3 times, last by llutz: Nachtrag ergänzt ().

  • Da ich den VPN jetzt zum laufen bekommen habe und keine Hilfe gebraucht habe, wollte ich euch nur kurz informieren, wie ich es gemacht habe. Dem einen oder anderen kann es sicher auch helfen.


    VPN Zugang FritzBox


    Damit komme ich jetzt von meinem PC per putty auf den Raspi in dem Netzwerk. In Putty gebe ich nach dem Aufbau der VPN-Verbindung die IP des Raspi in seinem Netzwerk sowie den Port, über den er intern erreichbar ist, ein. Und ZACK - ich bin auf dem Raspi.