Raspberry Pi 4 B mit USB 3.0 von Festplatte booten

  • //Edit framp Unter win sieht er die ext4 ja nicht.

    Stimmt. Das vergesse ich immer wieder. Bei mir gibt es kein Windows ;)

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • OK,

    also nichts zu machen. Muss halt eine größere SD-Karte her und das Betriebssystem "Honeycomb OS" dann erst auf die SD-Karte und dann nach dieser Anleitung vorgehen ?

    Tutorial

  • Also habe alles markiert auf der SSD und auf die SD-Karte kopiert.


    Und die Datei /boot/cmdline.txt sieht so aus bisher:

    Code
    dwc_otg.lpm_enable=0 console=serial0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait    
  • Ja, ok.

    Aber was muss angepasst werden damit die SD nur zum booten genommen wird, aber das Betriebssystemauf der SSD läuft ?


    Gruß

  • Ich habe mich in diesen Thread reingehängt, weil ich denke mein Problem passt hierzu.


    Ich habe meinen Raspi 4 2GB auf booten von SSD umgestellt. Dies funktioniert auch. Allerdings gibt /bzw. gab es dabei 2 Probleme.


    1. Die Root-Partition befindet sich auf einer Intenso 1,8 Zoll portable SSD mit USB 3.0. Leider bootet der Raspi mit dieser SSD nur von den USB 2.0 Anschlüssen. Bei USB 3.0 bleibt der Bootvorgang nach Anzeige der Farbscala stehen. Die SSD lässt sich allerding am USB 3.0 Anschluss als normales Laufwerk lesen und beschreiben.


    2. Nachdem das Image auf die SSD augespielt und von der SSD gebootet wurde, konnte das Filesystem nicht auf die gesamte Platte ausgedehnt werden. Abbruch mit der Meldung "sda2 is not a SD-Card"


    Das 2. Problem hatte ich dann händisch gelöst.


    Was kann ich tun, damit die SSD als Root am USB 3.0 erkannt wird. Sytem ist auf dem neuesten Stand.

    Ich antworte nur wenn ich die Frage auch beantworten kann :stumm:

  • Ich habe mich in diesen Thread reingehängt, weil ich denke mein Problem passt hierzu.

    Finde ich nicht :no_sad:. Mach doch lieber einen eigenen Thread auf ;)

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • Eventuell kann jemand anderes helfen ?

    Ist das doof, da kauft man das aktuellste Modell , aber das kann dann nicht mit OS auf einer USB-SSD laufen


    Gruß

    Also habe alles markiert auf der SSD und auf die SD-Karte kopiert.


    Und die Datei /boot/cmdline.txt sieht so aus bisher:

    Code
    dwc_otg.lpm_enable=0 console=serial0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait    


    Ja, ok.

    Aber was muss angepasst werden damit die SD nur zum booten genommen wird, aber das Betriebssystemauf der SSD läuft ?


    Gruß

  • In der cmdline.txt muss root=/dev/sda1 stehen, wenn du nur eine Platte dran hast, oder du trägst dort auch die ID ein, dann gibts keine Verwechslung.

    Dann musst du in der /etc/fstab beim unteren Eintrag die PARTUUID=XXXXXXXX-XX für die root-Partition ändern /.

    Die Partuuid bekommst du mit sudo blkid raus.

    https://www.verdrahtet.info/20…erry-pi-4-von-ssd-booten/

    https://www.raspberrypi.org/forums/viewtopic.php?t=184513

  • fred0815

    Also ich versuche es nochmal:

    Habe nach dem Tutorial von https://www.verdrahtet.info/20…erry-pi-4-von-ssd-booten/ soweit gemacht wie ich kam.


    Bis zu dem Punkt wo ich die SSD anhänge mit dem selben OS komme ich.

    Ohne SSD ist es so:




    Die SSD eingesteckt und den Befehl nochmal ausgeführt, das Ergebnis:


    Aber bei keinen der beiden dazu gekommenen /sda Partitionen steht das hier aus der Anleitung:

    Code
    pi@raspberrypi:~ $ sudo blkid
    /dev/mmcblk0p1: LABEL_FATBOOT="boot" LABEL="boot" UUID="5203-DB74" TYPE="vfat" PARTUUID="6c586e13-01"
    /dev/mmcblk0p2: LABEL="rootfs" UUID="2ab3f8e1-7dc6-43f5-b0db-dd5759d51d4e" TYPE="ext4" PARTUUID="6c586e13-02"
    /dev/mmcblk0: PTUUID="6c586e13" PTTYPE="dos"
    /dev/sda1: LABEL_FATBOOT="boot" LABEL="boot" UUID="4BBD-D3E7" TYPE="vfat" PARTUUID="738a4d67-01"
    /dev/sda2: LABEL="rootfs" UUID="45e99191-771b-4e12-a526-0779148892cb" TYPE="ext4" PARTUUID="738a4d67-02"

    Bei meinem System fehlt doch das "rootfs"

    Also welche PARTUUID ist bei mir die korrekte ?


    Somit komme ich ja erstmal nicht weiter......


    Zusätzlich erscheint bei nächsten Befehl:

    sudo cp /boot/cmdline.txt /boot/cmdline.txt.old


    diese Fehlermeldung

    Code
    cp: cannot stat '/boot/cmdline.txt': No such file or directory

    Edited once, last by hyle: Ein Beitrag von dogfight76 mit diesem Beitrag zusammengefügt. ().

  • Jede Anleitung funktioniert nur auf dem System des Autors zum Zeitpunkt der Erstellung der Anleitung.

    Dabei haben sich im Laufe der Zeit in cmdline.txt und /etc/fstab die Partitionsbezeichnungen geändert, zumal eine Partition über verschiedene Parameter angesprochen werden kann < man mount >

    /dev/sda2

    LABEL=rootfs

    UUID=45e99191-771b-4e12-a526-0779148892cb

    PARTUUID=738a4d67-02

    haben in #73 im Mountbefehl dieselbe Bedeutung, wobei aber jeder Parameter nur einmal am Host vorkommen darf, was hier (# 73) nicht gegeben ist.

    Deshalb wird (vorerst) ein Booten von der Bootpartition der SD mit der Rootpartition der SSD nur dann funktionieren, wenn:

    in cmdline.text der SD-Bootpartition der Zeiger auf die Rootpartition root=/dev/sda2 steht, und in

    /etc/fstab der Rootpartition auf dev/sda2 Root- und Bootpartition eindeutig definiert sind. Derzeit also

    / /dev/sda2 .....

    /boot /dev/mmcblk0p1 .....


    Jeder Hostadmin ist dafür verantwortlich, dass einmalige IDs auch nur einmal am Host vorkommen.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Soll gehen habe irgendwo hier schon mal gepostet

    Das ist die gleiche Vorgehensweise wie im Beitrag von Jürgen Böhm

    cp: cannot stat '/boot/cmdline.txt': No such file or directory

    Erst einmal hat deine Bootpartition das Label "raspberrypi" statt "boot" (Das liegt warscheinlich an dem OS, welches du benutzt)

    versuch mal

    sudo cp /raspberrypi/cmdline.txt /raspberrypi/cmdline.txt.old

    wenn das funktioniert, kannst du später mit

    sudo nano /raspberry/cmdline.txt diese anpassen.


    Des Weiteren hat deine SSD dadurch dass du die gleiche img-Datei auf die SSD gespielt hast wie auf die SD die gleiche PARTUUID wie deine SD-Karte.

    Diese PARTUUID solltest du erst einmal ändern, wie im Tutorial von Jürgen Böhm beschrieben.


    Danach musst du die geänderte PARTUUID von sda2 in deine smdline.txt auf der SD-Karte eintragen.

    Anschliessend, wenn der Pi gebootet hat, kannst du den Eintag in der /etc/fstab anpassen.

  • sudo cp /boot/cmdline.txt /boot/cmdline.txt.old

    Ich habe gerade dashoneycombOS auf einer SSD lauffähig installiert.


    Wesentliche Unterschiede sind: ext3-Filesystem und das boot-Laufwerk heißt raspberrypi

    Code
    beekeeper@raspberrypi4-64:~$ df -h
    Filesystem      Size  Used Avail Use% Mounted on
    /dev/root       105G  2.2G   98G   3% /
    devtmpfs        1.8G     0  1.8G   0% /dev
    tmpfs           1.9G     0  1.9G   0% /dev/shm
    tmpfs           1.9G   17M  1.9G   1% /run
    tmpfs           1.9G     0  1.9G   0% /sys/fs/cgroup
    tmpfs           1.9G     0  1.9G   0% /tmp
    tmpfs           1.9G   64K  1.9G   1% /var/volatile


    Schreib oder kopier nicht alles was nicht bei 3 auf den Bäumen ist,

    benutze Dein Hirn.


    MfG


    Jürgen


    Edit: Hab Geduld, es dauert ein bißchen von den 4 Himpeeren bis zum Login.

  • Hallo,


    erhlich.....ich versuche das ja irgenwie zu verstehen. Ich bin aber Noob-Bastler.

    Also ich habe es geschafft von USB-SSD die PARTUUID auf "0x57daec12" zu ändern.

    Aber wenn ich den Befehl sudo nano /raspberry/cmdline.txt eingebe kommt es z dieser Meldung:


    Ich habe keine Ahnung warum. Die Ausgabe von "df -h" ist auch zu erkennen auf dem Screenshot.



    In dem Verzeichnissbaum des Raspberry sehe ich per WinSCP auch keinen Ordner "raspberrypi"


    Gruß

  • sudo mount /dev/mmcblk0p1 /boot

    sudo cp /boot/cmdline.txt /boot/cmdline.txt.ori

    sudo nano /boot/cmdline.txt

      dwc_otg.lpm_enable=0 console=serial0,115200 root=/dev/sda2 rootfstype=ext4 rootwait


    Oder lese Dir einfach die Installationsanleitung durch:

    https://iota-industrie-4-0.blo…llation-der-embedded.html


    Edit: Reboot


    MfG


    Jürgen