Ubuntu 19.10 auf Raspi 4

  • Zu 3: normal bin ich mit Raspbian unterweges.

    geb ich das ein im Terminal ein:


    Code
    history |grep i368

    kommt nur das heraus (was funktioniert hat):


    Code
    qemu-system-i386 -smp 2 ReactOS.vmdk -m 64 -net nic,model=rtl8139 -net user

    herunter geladen hab ich das: https://download.reactos.org/r…eactOS-0.4.5-REL-QEMU.zip


    Alles in Raspbian . Damit "-smp 2" hab ich getestet ob er 2 Kerne benutzt.

    (2 Kerne nicht: aber das war das einzigste was je mit qemu geklappt hat)

  • Die Raspberry Foundation arbeitet gerade am VideoCore 6.

    Der Videocore wird noch gar nicht unterstützt :)

    https://www.heise.de/newsticke…-4-in-Arbeit-4554262.html

    Also ich kann es mir einfach nicht vorstellen das Ubuntu das programmiert.

    Die nehmen einfach OpenGL, was vermutlich abwärtskomptibel ist.

    Im nächsten Raspbian Release wird das vielleicht unterstützt.

    Ich ware ja auch schon drauf das endlich Hevc-Codec auch in Raspbian funktioniert. Ich hab schon viel gelesen..

    Beim Raspberry 4 kann man angelich beim hochfahren den Grafiktreiber auswählen.


    In Raspbian ist der in /boot/config.txt drin --->dtoverlay=vc4-fkms-v3d

    Dem Namen nach vc4 ..... ist das VideCore4 also ohne hevec beschleunigung und dem alten OpenGL. Im nächsten Upgrade wird das wohl funktionieren.

    :) :) Mein Tablet kann den Hevc-Codec.

    Der Raspberry kann viel mehr hardwärmassig, was momentan unterstützt wird.


    Gruss

  • das Thema 64bit-Ubuntu 19.10 für Raspi 4 ist - trocken ausgedrückt - nach wie vor eine Baustelle. :conf:

    oder auf Neudeutsch: under construction


    Eher wird die USB-Bootoption fertig, wetten? :lol:


    (Edit: 64bit eingefügt)

    ---

    we all live in a yellow subroutine...

    Edited once, last by McDotter ().

  • Habe jetzt erfolgreich Ubuntu 19.10 auf dem 4er Raspi installiert. Habe die 64-Bit-Variante aus dieser Quelle verwendet.


    Es lief nicht auf Anhieb, denn bei angeschlossenem Monitor klemmte der erste Bootvorgang scheinbar mit der Meldung "Reached target cloud-init target". Durch Zufall habe ich festgestellt, dass hinter den Kulissen offensichtlich doch korrekt durchgebootet wurde. Ich konnte über SSH zugreifen und von dort aus die üblichen Installationsarbeiten (Update, Upgrade und Desktop-Installation) vornehmen.


    Habe mich für den LXQt-Desktop entschieden, weil der unter den schlanken ziemlich ausgefeilt ist und man sich als KDE-Fan dort gut zurecht findet (RAM-Beanspruchung des Systems nach dem Booten ca. 475 MB mit Display-Manager SDDM). Nach allen Installationsarbeiten wurde dann auch problemlos regulär gebootet. :)


    Gute Nachricht: der o. g. USB-Bug ist behoben. Der Workaround mittels künstlicher RAM-Kappung ist nicht mehr erforderlich. Die USB-Geräte, dich ich getestet habe, funktionieren anstandslos. :)


    ABER: Wenn ich eine SSD anschließe, gibt es Probleme mit dem WLAN. Der Netzwerk-Manager zeigt zwar keine Verbindungsunterbrechung an, aber Internetseiten werden nicht geladen, bis ich die SSD wieder abklemme. :-(( Ist das jetzt ein Problem des OS oder sollte etwa das reguläre RPi4-Netzteil nicht genügend Saft bieten für SSD und WLAN-Adapter?


    Weiß jemand etwas darüber?

  • Nachtrag: Unter Raspbian verstehen sich meine SSD und der WLAN-Adapter prima. Ist also kein Netzteil-Problem. Ich habe Ubuntu mal angetestet, um zu sehen, was der Pi4 unter einem 64bit-OS so leisten kann. Allerdings ist im Vergleich zum 32bit-Raspbian kein Performancegewinn zu spüren. Im Gegenteil: Das von mir getestete Lubuntu läuft spürbar träger als Raspbian. Es belegt auch nach Systemstart mehr als doppelt so viel RAM. Deshalb und wegen des WLAN-Problems werde ich auch beim Pi4 erst einmal bei Raspbian bleiben.

  • Danke unimatrix, das wäre noch einen Versuch wert. Da meine Ubuntu- und Desktop-Installation mit den entsprechenden Updates ca. 3,5 Stunden gebraucht hat, nehme ich mir das mal für später vor. Im Moment, nachdem ich gerade den SSD-Boot eingerichtet habe, bin ich erstmal entzückt von der Flüssigkeit des guten alten Raspbian :)

  • Habe jetzt erfolgreich Ubuntu 19.10 auf dem 4er Raspi installiert. Habe die 64-Bit-Variante aus dieser Quelle verwendet.

    Hi Leute,

    Ich will hier mal einhaken, weil es bei meiner 64Bit-Installation hakt.


    Ich habe auch das Image von der oben genannten Quelle bezogen, eigens einen Pi4 4GB gekauft, weil ich mit dem 64Bit-Untergrund was testen will. Aber ich bekomme den ersten Boot schon nicht zum Laufen.


    Das letzte, was ich noch auf dem Bildschirm sehe ist: siehe Anhang (will nicht abtippen).


    Es funktioniert auch nicht auf einem 2GB Pi4, ich habe das Image auf 2 verschiedenen SD-Cards probiert und mit Win32DiskImager und Etcher.


    Sind da noch irgendwelche Vorbereitungen notwendig, die ich nicht gesehen habe?

    Images

    --------------------

    Lg. Wolfgang

    Austria


    Verwendete Pi's

    5 RPi3: jeder hat nur eine Aufgabe (MqttServer, PiHole, MongoDB, Test, Firewall)

    6 RPi4: Sollen die Aufgaben der Rpi3 übernehmen, und zum Testen, FHEM, NAS, MediaSever

    1 RPI4: In der Schublade, wer weiss wann man einen braucht

  • unimatrix-0
    Danke für den Tipp, Ja das wäre automatisch mein nächster Versuch gewesen, ausser jemand hätte mich auf einen Verfahrensfehler hingewiesen.

    Prinzipiell ist mir die Ubuntu-Version egal, ausser sie verhindert das, was ich eigentlich will.

    Und was ich will:

    Ich würde gerne MongoDB oder ELK installieren, aber die neuesten laufen nur unter 64Bit. Ich habe zwar eine MongoDB in einem Docker-Container auf einem RPi3 am Laufen, bei einem Shutdown beendet sie jedoch nie richtig und jetzt will ich parallel dazu die neueste Version auf einem 64Bit-System ausprobieren

    --------------------

    Lg. Wolfgang

    Austria


    Verwendete Pi's

    5 RPi3: jeder hat nur eine Aufgabe (MqttServer, PiHole, MongoDB, Test, Firewall)

    6 RPi4: Sollen die Aufgaben der Rpi3 übernehmen, und zum Testen, FHEM, NAS, MediaSever

    1 RPI4: In der Schublade, wer weiss wann man einen braucht

  • unimatrix-0
    Danke für den Tipp, Ja das wäre automatisch mein nächster Versuch gewesen, ausser jemand hätte mich auf einen Verfahrensfehler hingewiesen.

    Prinzipiell ist mir die Ubuntu-Version egal, ausser sie verhindert das, was ich eigentlich will.

    Und was ich will:

    Ich würde gerne MongoDB oder ELK installieren, aber die neuesten laufen nur unter 64Bit. Ich habe zwar eine MongoDB in einem Docker-Container auf einem RPi3 am Laufen, bei einem Shutdown beendet sie jedoch nie richtig und jetzt will ich parallel dazu die neueste Version auf einem 64Bit-System ausprobieren

    Habe sehr gute Erfahrungen mit der inoffiziellen 18.03.04 Version, seit v11. Der Entwickler ist gut vernetzt und macht aus meiner Sicht echt gute Arbeit. Wenn du noch eine SD für Testzwecke über hast, wäre es sicherlich einen Versuch wert. Meine Empfehlung wäre, dass komplette Image mit Desktop zu testen. Da meine Umgebung unter lightdm + lxde läuft, gehe ich einen anderen Weg. Für dich könnte das fertige Image ggf. eine gute Lösung sein. Btw: Ausprobieren ist der beste Weg, soweit meine Erfahrungen mit den Ubuntu Version. good luck ux

  • Hi Leute,

    ich muss mich korrigieren. Ich bin auf 2 FAKE-SD's reingefallen.

    Als ich das erkannte, habe ich noch einmal probiert, das Ubuntu 19.10.1 zu installieren und mit einer korrekt laufenden SD-Karte war es auch kein Problem.

    Ich muss jetzt nur noch weiter testen, weil ich fürchte, dass Ubuntu bei Installationen mehr abferlangt als das Raspian.


    Problematisch für mich war gleich am Anfang die Sonderzeichen auf der deutschen Tastatur zu finden, weil das Layout auf US definiert war.

    Jetzt werde ich mich mal etwas einarbeiten :)

    --------------------

    Lg. Wolfgang

    Austria


    Verwendete Pi's

    5 RPi3: jeder hat nur eine Aufgabe (MqttServer, PiHole, MongoDB, Test, Firewall)

    6 RPi4: Sollen die Aufgaben der Rpi3 übernehmen, und zum Testen, FHEM, NAS, MediaSever

    1 RPI4: In der Schublade, wer weiss wann man einen braucht

  • Hier mal ne Info zur Kernel-Implementierung des RPi4


    https://www.heise.de/ct/artike…-verkuemmert-4605827.html


    Wenn Ubuntu nicht spezielle Treiber für den Raspi aufnimmt, ist unter 19.10 auch weiterhin mit Abschlägen (im Vergleich zu Raspian) zu rechnen

    Leider, aber es gibt ja zum Glück andere Ubuntu basierende Projekte die mit den aktuellsten Treibern arbeiten und somit ein gutes Stück weiter voraus sind. Gruß ux