Neustart nach Abschaltung USB

  • Hallo,


    ich benutzte einen Raspi 3B+ für die Übertragung einer Baustellen-IP-Kammera. Da dort kein Strom vorhanden ist wird dieser aus Sonne und Wind in einem Akku gespeichert.


    Zur Energieeinsparung wollte ich den USB-Anschluß mit dem LTE-Stick mit den Befehl:


    Code
    echo '1-1' >/sys/bus/usb/drivers/usb/unbind

    Nachts abschalten. Wenn ich dann nach ein paar Stunden wieder Strom auf den USB-Bus gebe (unbind -> bind) dann startet mein Raspi immer neu.


    Kennt jemand dieses Problem und die Lösung dafür?


    Hardy

  • Du solltest das mal mit einem ausreichenden Netzteil testen, um zu sehen, ob bei der Aktivierung des Sticks evtl. zu wenig Saft aus der Batterie kommt.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Hallo Outi,


    an der Spannung liegt es nicht, die 12V der Batterie gehen erst auf einen Step-Down-Wandler, eingestellt auf 5,1V. Der liefert mind. 2A und ist am Raspi direkt auf der Stiftleiste mit Kabel mit ausreichendem Querschnitt angeschlossen.


    Wenn ich den Stick rausziehe und stecke gibt es keine Probleme mit dem Neustart.


    Hardy

  • Moin Traceman,


    erstmal: Herzlich Willkommen im Forum!


    Wie schaltest du denn wieder ein? Bitte den Befehl mal posten.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo Bernd,


    es ist der gleiche Befehl, nur "un" wird weggelassen:

    Code
    echo '1-1' >/sys/bus/usb/drivers/usb/bind


    Hardy