UMTS Surfstick MF190 baut keine automatische Verbindung auf

  • Hallo zusammen,


    bin an meinem Pi3B+ seit gestern mit dem UMTS Surfstick MF190 am kämpfen.


    Und zwar bin ich nach folgender Anleitung vorgegangen:


    https://wiki.siduction.de/inde…llen_mit_Hilfe_von_wvdial


    Hat soweit geklappt.


    Hir mal ein paar Ein/Ausgaben:


    Code
    root@raspberrypi:~# lsusb
    Bus 001 Device 007: ID 19d2:0117 ZTE WCDMA Technologies MSM
    Bus 001 Device 004: ID 1908:2310 GEMBIRD
    Bus 001 Device 005: ID 0424:7800 Standard Microsystems Corp.
    Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
    Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    Hier steht noch KEIN Modem drin.


    Jedoch bei:


    Erhalte ich unter USB1 ein Modem.


    Verbindung müsste aufgebaut werden.


    Wenn ich jetzt das Netzwerkkabel ziehe habe ich seltsamerweise keine VNC Zugang mehr und auch ioBroker Cloud geht nicht, was eigentlich sein müsste.

    Vielleicht klappt auch nicht die automatische Umschaltung von Netzwerk auf die UMTS Verbindung.


    Also habe ich es mit direktem automatischen UMTS Aufbau versucht:


    In /etc/network/interfaces folgendes hinzugefügt:


    Code
    auto ppp0
    iface ppp0 inet wvdial
    provider umts


    So, jetzt habe ich aber wieder kein VNC und auch keine ioBroker Cloud Verbindung.


    Ich weiß auch nicht ob die Verbindung überhaupt steht, da Headless das Ganze.

  • Könnte sein, dass die APN bei Vodafone auf event.vodafone.de umgestellt werden muss.


    Allerdings bekomme ich seltsamerweise nun folgender Fehlermeldung:



    "pppd" ist in /usr/sbin vorhanden.


    in der wvdial.conf "path = /usr/sbin/pppd" hinzugefügt.



    Code
    sudo chown root:dip /usr/sbin/pppd
    sudo chmod 4754 /usr/sbin/pppd
    sudo chmod 777 /etc/ppp/pap-secrets
    sudo chmod 777 /etc/ppp/peers

    ...ausgeführt, Fehler ist noch immer vorhanden.


    Hat jemand noch eine Idee?

  • Wenn ich jetzt das Netzwerkkabel ziehe habe ich seltsamerweise keine VNC Zugang mehr und auch ioBroker Cloud geht nicht,

    Stell bitte alles wieder auf Anfang, also wie im ersten Post.


    Kannst du nach dem Ziehen des Netzwerkkabels die Ausgabe von ifconfig und route -n zeigen

    Glaube ersetzt kein Wissen

  • Nach dem Ziehen des Netzwerkkabels habe ich kein SSH mehr, somit kann ich nichts eingeben.


    Bin wieder etwas weiter gekommen indem ich ja beim 1. Mal unter Root eingegeben hatte.


    Im Log steht:


    Dec 9 13:23:32 raspberrypi pppd[4043]: Connect: ppp0 <--> /dev/ttyUSB1

    Dec 9 13:23:32 raspberrypi pppd[4043]: Warning - secret file /etc/ppp/pap-secrets has world and/or group access

    Dec 9 13:24:02 raspberrypi pppd[4043]: LCP: timeout sending Config-Requests

    Dec 9 13:24:02 raspberrypi pppd[4043]: Connection terminated.

    Dec 9 13:24:02 raspberrypi pppd[4043]: Modem hangup

    Dec 9 13:24:02 raspberrypi pppd[4043]: Exit.

  • Es ist schwierig zu sagen was da passiert.

    Um 11:06:05 wird eine Verbindung hergestellt, die um 11:06:36 wieder beendet wird. Alle nachfolgenden Autoconnect haben keinen Erfolg.


    Beim Stichwort "Exit Code = 16" gab es auch den Hinweis auf eine nicht stabile Stromversorgung. Hast du eine Möglichkeit den USB-Stick mit externen Strom zu versorgen?


    Hast du schon versucht die "AT-Befehle" direkt einzugeben?

    Glaube ersetzt kein Wissen

  • Hallo nochmal,


    ich hatte noch einen Huawai Stick (E353/E3131) rumfliegen und den mal ausprobiert.

    Der wurde als "eht1" erkannt.

    Über den Desktop und Aufruf von 192.168.1.1 kam ich auf den Stick und konnte eine Verbidnung herstellen.

    Das Ganze funktioniert sogar auch ohne WLAN, LAN.

    Also direkt nach dem Boot habe ohne "häusliches" Netzwerk direkt Zugriff per VNC oder auch ioBroker Cloud.

    Geil.

    Jetzt die nächste Hürde. Sorry, jetzt wird es off-topic

    Ich habe eine 5MP Raspi Cam angeschlossen und wie in dem Link hier konfiguriert:

    https://randomnerdtutorials.co…with-raspberry-pi-camera/

    Das funktioniert auch.

    Man bekommt im heimischen Netzwerk ein Bild über die entspr. IP Adresse mit Anhang ":8000"

    Also wäre das in meinem Fall 192.168.178.16:8000


    Wie mache ich das nun mit dem Stick?

    Selbst wenn ich über VNC mich einklinke bekomme ich kein Bild über folgende Adressen:


    192.68.1.1.8000

    192.168.1.100:8000

    192.68.1.24.8000

    192.168.1.255:8000

    Die Adresse hatte ich hierüber


  • Wenn du keine weitere Software wie z.B. ein VPN laufen hast und sowohl LAN als auch WLAN nicht verbunden sind, solltest du keine Verbindung zu deinem RPi herstellen können.

    Glaube ersetzt kein Wissen

  • Wie ich geschrieben hatte klinke ich mich über VNC ein.

    Hier komme ich ganz normal auf den Desktop des Pis.


    Die Frage ist nur welche Adresse gebe ich im Browser (des Pis) ein um die Webcam zu sehen.


    ...vielleicht hatte ich mich nicht klar ausgedrückt.

  • Ha!


    Es läuft!!! Durch einen Transport hatte sich nur die Kamera gelöst.

    Die IP Adresse+Port für die Cam ist übrigens 192.168.1.100:8000


    D.h. ich habe jetzt eine autarke Webcam mit der ich über UMTS Video-Streasm empfangen kann.

    Einzelne Bilder wäre eigentlich besser für mein Vorhaben anstelle eines Video-Streams , aber das wäre dann eine weitere kleinere Baustelle.