Config.txt wird ignoriert

  • Moin,


    kann es sein, dass die config.txt durch andere Dateien überlagert und infolgedessen ignoriert wird? Es ist vollkommen egal, was ich da reinschreibe, am Ende habe ich immer die Auflösung 1024x768.


    Ich kann zwar in den Einstellungen die richtige Auflösung einstellen, das funktioniert auch leidlich, solange ich arbeite, aber nach einem Neustart ist alles fort.


    Ich arbeite mit zwei Monitoren. raspi-config funktioniert auch nicht.


    Hat jemand Erfahrungen mit zwei Monitoren 4k und mit der config.txt?


    Danke, Wombat

  • kann es sein, dass die config.txt durch andere Dateien überlagert und infolgedessen ignoriert wird?

    Hallo MortalWombat,


    was meinst Du mit überlagern?

    Was schreibst Du denn rein?

    Was meinst Du mit "es funktioniert leidlich"?

    Wie stellst Du fest, dass raspi-config nicht funktioniert?


    Bitte konkrete Angaben, sonst kann Dir keiner helfen. Gruß, STF

    • Official Post

    Ich habe zwar keine (4k) Monitore am RPi4, aber evtl hilft Dir das weiter:

    Note for Raspberry Pi4B users: Because the Raspberry Pi 4B has two HDMI ports, some HDMI commands can be applied to either port. You can use the syntax <command>:<port>, where port is 0 or 1, to specify which port the setting should apply to. If no port is specified, the default is 0. If you specify a port number on a command that does not require a port number, the port is ignored. Further details on the syntax and alternatives mechanisms can be found on the conditionals page in the HDMI section of the documentation.


    bzw.

    The [HDMI:*] filter — Pi 4 only

    The Raspberry Pi 4 has two HDMI ports, and for many config.txt commands related to HDMI, it is necessary to specify which HDMI port is being referred to. The HDMI conditional filters subsequent HDMI configurations to the specific port.

    Code
    [HDMI:0]  hdmi_group=2  hdmi_mode=45
    [HDMI:1]  hdmi_group=2  hdmi_mode=67

    An alternative variable:index syntax is available on all port-specific HDMI commands. You could use the following, which is the same as the previous example:

    Code
    hdmi_group:0=2
    hdmi_mode:0=45
    hdmi_group:1=2
    hdmi_mode:1=67

    Ich meine damit die expliziete Angabe des HDMI-Ports.

  • Hallo STF,


    erstmal vielen Dank dafür, dass Du geantwortet hast.


    Mit überlagern meine ich, ob das System noch irgendwo anders Einstellungen speichert. Was passiert zum Beispiel mit den Änderungen, die ich über die GUI vornehme? In der config.txt ändert sich da nichts.


    Ich habe über

    sudo raspi-config

    versucht die Einstellungen für die Displays vorzunehmen. Das hat nicht funktioniert. Auch unter der GUI habe ich keinen Erfolg.


    Zwar sind beide Monitore auf 4k bei 30 HZ aber mit dem Neustart sind sie wieder weg. Zudem flackert einer. Also konkreter: er wird in unregelmäßigen Abständen kurz schwarz.

    Bitte konkrete Angaben, sonst kann Dir keiner helfen. Gruß, STF

    Ich mache sonst sehr konkrete Angaben, allerdings habe ich bei meinem Debütpost festgestellt, dass niemand reagiert, wenn die Angaben zu genau sind :-O Wahrscheinlich, weil es dann zu speziell ist.

  • Hier mein Code aus der config.txt


    Die Kommentare hab ich nur hier zur Erklärung eingefügt. Sie sind nicht Teil der config.txt.


    disable_overscan

    framebuffer_width=3840 framebuffer_height=2160

    hdmi_force_hotplug=1

    hdmi_group=1

    hdmi_mode=95 # diesen Wert habe ich mit tvservice -v 2 -m CEA bzw. tvservice -v 7 -m CEA entnommen. 2 und 7 wurde mir ausgegeben für meine Displays mit /opt/vc/bin/tvservice -v 7 -m CEA bzw. /opt/vc/bin/tvservice -v 2 -m CEA

    config_hdmi_boost=6 #damit wollte ich das "Flackern" unterbinden

    #alles was hier folgt stand schon in der config.txt

    dtparam=audio=on

    [pi4]

    dtoverlay=vc4-fkms-v3d

    max_framebuffers=2

    [all]

    dtoverlay=vc4-fkms-v3d


    Das Einzige, was wirklich funktioniert ist disable-overscan :D

  • Kommentier das mal aus:

    framebuffer_width=3840 framebuffer_height=2160

    Das hast Du 2mal drin:

    dtoverlay=vc4-fkms-v3d

    Und dann sieh Dir mal hier mal den Custom mode genauer an.


    Und fange klein an, Eine Änderung nach der anderen, nur weitermachen wenn es auch funktoniert.

    Ich vermute, Du hast Dir eine Menge Seiteneffekte eingehandelt. Fang also mit der originalen config.txt an.

    Und dann Schritt für Schritt.


    MfG


    Jürgen

  • kann es sein, dass die config.txt durch andere Dateien überlagert und infolgedessen ignoriert wird?

    Wenn ein Eintrag in der config.txt ignoriert wird, wird das i. d. R. in der Ausgabe von:

    Code
    sudo vcdbg log msg

    gezeigt. Z. B.:

    Code
    007030.080: dtparam: eth_led1=4
    007037.670: Unknown dtparam 'eth_led1' - ignored

    bei meinem PI4.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Wow Leute, vielen Dank schon mal für die vielen Anregungen, ich bin gerade dabei die Sachen von Hyle mal umzusetzen, leider bislang erfolglos.


    Einen Monitor alleine, kann ich gut ansteuern, er startet dann in 4k 30 Hz, 60 Hz klappt leider nicht. Ich mach jetzt mal einen Schritt zurück und probiere nacheinander Eure Ideen aus.

  • Fang also mit der originalen config.txt an.

    Das war übrigens extrem komisch, ich hatte einen ganz guten Status quo, der auch nach dem Reboot immer zu einem befriedigendem Ergebnis (ein Monitor 4k, einer 2.5K) geführt hat. Nachdem ich in der config.txt rumgebastelt habe, hab ich die alte config.txt einfach zurückkopiert und hatte trotzdem das gleiche schlechte Ergebnis. Daher auch meine Frage, ob die config.txt auch mal ignoriert wird. (Fehler beim Kopieren der config.txt kann ich nahezu ausschließen.)

  • Das war übrigens extrem komisch, ich hatte einen ganz guten Status quo, der auch nach dem Reboot immer zu einem befriedigendem Ergebnis (ein Monitor 4k, einer 2.5K) geführt hat.

    Aus der Dokumentation zur config.txt auf raspberrypi.org (Hervorhebung von mir):

    Quote

    hdmi_enable_4kp60 (Pi 4B only)

    By default, when connected to a 4K monitor, the Raspberry Pi 4B will select a 30hz refresh rate. Use this option to allow selection of 60Hz refresh rates. Note, this will increase power consumption and increase the temperature of the Raspberry Pi. It is not possible to output 4Kp60 on both micro HDMI ports simultaneously.

  • Hast Du auch den Grafikspeicher erweitert ??

    Mit der Standardeinstellung wird es wohl zu eng bei 2 Monitoren, vor allem, wenn sie evtl. unterschiedliche Inhalte anzeigen sollen.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Aus der Dokumentation zur config.txt auf raspberrypi.org (Hervorhebung von mir):

    Das hab ich natürlich beachtet- Nutzt aber nichts. Am erstaunlichsten finde ich nach wie vor, daß selbst das Zurückkopieren der config.txt nicht den ursprünglichen Zustand wiederherstellt. Es muss doch also irgendwo noch Einträge geben, die die config.txt überschreiben

  • Hast Du auch den Grafikspeicher erweitert ??

    Mit der Standardeinstellung wird es wohl zu eng bei 2 Monitoren, vor allem, wenn sie evtl. unterschiedliche Inhalte anzeigen sollen.

    Nein, ehrlich gesagt habe ich das noch nicht gemacht. Im Moment kann ich aber auch gar nicht mehr einen einzelnen 4k Monitor anschließen. Es ist echt frustrierend.

  • Du kannst ja die Änderungen über SSH durchführen.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Evtl. mal den Pi ganz runter fahren und für 10 Sekunden vom Netz nehmen. Meine alles auf Anfang.

    Nein, hat leider auch nichts gebracht. Aber ich konnte einen Fehler identifizieren...


    Die Zeile dtoverlay=vc4-fkms-v3d scheint verantwortlich zu sein. Wenn ich sie lösche, dann habe ich zumindest 4k Auflösung, wenn auch nur in 30Hz.


    Dafür fehlt mir die Funktion Screen-Configurator unter Einstellungen.

  • So funktioniert es jetzt mit einem Bildschirm und wie gesagt nur 30 Hz. hdmi_enable_4kp60=1 soll eigentlich dafür sorgen, dass 60 Hz unterstützt werden. Klappt aber nicht.


    Bildschirm ist ein LG27UL850W.