Dauer des Bootvorgänge bei Eurer Phoniebox

  • Mich würde Mal interessieren, wie lange Eure Phoniebox zum booten benötigt. Als Benchmark verwende ich momentan


    Code
    systemd-analyze blame


    Dabei kommen ~10s heraus.

    Da ich immer nur testen kann, wenn Grad keiner guckt oder die Kinder schlafen, hab ich noch nicht alle Services verstanden.

    Hier Mal mein Ergebnis:


    in der /etc/dhcpcd.conf hat geholfen, "noarp" hinzuzufügen, static IP und ip4only / noipv6 haben keine Auswirkung gehabt.


    In raspi-config habe ich fastboot aktiviert, was in meinem Benchmark 4 sek Unterschied macht.


    Welche Services kann ich noch disablen, welche Eingriffe machen sonst noch Sinn?

    Edited 2 times, last by bCid ().

  • Guter Hinweis mit dem Fastboot, das sollte ich mir mal ansehen! Ich glaube aber fast, dass Du nicht mehr viele Sekunden raus hauen wirst. Es ist ja jetzt recht simpel, schau dir die Langläufer an. Simples Beispiel: ssh


    Brauchst Du ssh noch, für mich ist es wichtig, andere haben vielleicht direkt nen USB- und HDMI-Anschluss zur Wartung berücksichtig. Zack 0,7 Sekunden gewonnen.


    Die meisten Sachen sind allerdings notwendig, nimm es nicht böse, aber da musst Du leider auch nen bissl googln ;-) Es wäre aber klasse, wenn Du Dein Wissen hier teilen könntest, interessant ist es in jedem Fall!!!

  • ggf. noch eine Option in der config.txt:

    Code
    dtoverlay=sdtweak,overclock_50=100

    Ich hab null Ahnung wie viel das bringt, im worst case nothing, aber da Du gerade testest und ich das mal auf meiner Agenda hatte ;-)

  • Zuerst Mal: mit Fastboot meinte ich, in den Network Options einzustellen, nicht auf das Netzwerk zu warten.

    Von der Kernel Einstellung Fastboot rate ich ab, da das den Filesystemcheck skippt. ich musste heute morgen ein Backup einspielen, nachdem mein Pi im bootloop stecken blieb.

    #korrektur: bootloop lag am Akku/schlechte Lötstellen/Spannungsabfall beim boot


    in die /boot/cmdline.txt

    Code
    quiet

    In /boot/config.txt


    Code
    #bluetooth deaktivieren
    dtoverlay=pi3-disable-btdtoverlay=pi3-disable-bt
    #bootloader von 1 auf 0 sek
    boot_delay=0
    #sdkarte auf 100mhz (gute Qualität benötigt
    dtoverlay=sdtweak,overclock_50=100

    Edited 2 times, last by bCid: Bootloop ().

  • Ach herje, ich habe jetzt auch mal geschaut und das kam dabei raus:

    Code
    13.079s dhcpcd.service
    6.796s hciuart.service
    4.041s phoniebox-startup-sound.service
    3.562s exim4.service
    1.994s nmbd.service
    1.657s dev-mmcblk0p2.device
    1.547s php7.0-fpm.service
    1.471s lighttpd.service
    1.402s raspi-config.service
    1.007s networking.service

    Der Startup-Sound kam nach 24 Sekunden, die Box ist nach 28 Sekunden vollständig einsatzbereit.

  • Du brauchst kein Bluetooth (hciuart),

    Kein exim4,

    Kein raspi-config

    Und den dhcpcd kannst du mit noarp um 5 sek. verringern (Arp checkt im Netzwerk, ob die verwendete IP frei ist, was im eigenen LAN eigentlich der Fall sein sollte, sonst kannst Du auch ne statische IP vergeben.


    Ich hab zusätzlich auch den Startup Sound abgestellt

  • Hab noch nen bissl Input gefunden (https://raspberrypi.stackexcha…i-lower-my-boot-time-more):


    Hab bis auf die auskommentierten Sachen alles durchgeführt... Auf der Seite wurde die cmdline.txt ebenso angepasst, gefällt mir ;-)

    Natürlich hab ich die dhcpcd.conf angepasst und folgendes zugefügt:

    Code
    noarp
    ipv4only
    noipv6


    Ergebnis:

    Startsound ca. 17 Sek. / Startbereit ca. 21 Sek.


    Satte 7 Sekunden Zeitersparnis können sich sehen lassen.


    Ich glaube ja, dass der Startsound im Endeffekt keine ganze Sekunde ausmachen wird, da wir ja die Jobs auch parallel ausführen und nicht mehr seriell arbeiten ;-)


    Meine Langläufer sind:

    Code
    7.977s dhcpcd.service
    4.046s phoniebox-startup-sound.service
    1.961s nmbd.service
    1.448s php7.0-fpm.service
    1.391s dev-mmcblk0p2.device
    1.388s lighttpd.service
    1.168s networking.service

    Davon würde ich wenn auch nur auf den startup sound verzichten, wobei ich teste mal... ca. 24 Sek. Moment, das ist ja langsamer! Tatsache, aktiviere ich den Sound, ist die Box knackige 3 Sekunden schneller. Das soll mir mal einer erklären :conf:


    Nehme das Thema mal in meine FAQ auf.

  • Ich habe die Empfehlungen von Splitti79s FAQ mal verfolgt. Brachte mir ca. 2-3 sekunden (Von 18s auf 15s)


    Es war kurz bei einer Verbesserung auf 11sekunden, aber irgendwie bekomme ich das nicht reproduziert.

    Laut systemd-analyze critical-chain kann es auch fast nicht mehr schneller werden, nur MPD ist wirklich relevant hier.

    Oder kann man da was machen?


  • Was hast Du denn so unter der Phonieboxhaube verbaut? Das ist ja schon ordetlich schnell...

    Ich hab gestern noch was gelesen, dass man den SWAP in den Arbeitsspeicher auslagern kann. Der sollte ja im Zugriff schneller sein, ob es war brint weiß ich nicht. Allerdings habe wir den Service ja eh deaktiviert. Vielleicht bringt es etwas den Dienst aktiv zu habe, aber eben mit dem Arbeitsspeicher:

    https://www.elektronik-kompend…/raspberry-pi/2002131.htm


    Hab meine Box soweit, dass der Startsound nach 10 Sekunden kommt und ab Sekunde 14 ist sie einsatzbereit.


    Dazu hab ich noch mal etwas experimentiert: Wie gesagt, gewisse Sachen laden ja parallel, bitte nicht steinigen ;-) Wenn man den Service MPD von der Abhängigkeit network löst, dann ist das System einfach nur noch schnell da...


    Dafür die Datei /etc/systemd/system/multi-user.target.wants/mpd.service ab Zeile 5 wie folgt anspassen:

    Code
    #After=network.target sound.target
    After=sound.target

    Danach noch

    Code
    sudo systemctl daemon-reload

    und bootet die Box neu. Glaube viel geht nicht mehr. Bin nun von 28 Sekunden auf 14 Sekunden, bis ich übers Internet was streamen kann...

  • Hallo,

    mal ne Frage: Ihr redet hier alle von der Version ohne Spotify, oder?

    Wollte nämlich nachdem meine Box jetzt an sich läuft, mal ans Tuning gehen. Danke an dieser Stelle an Splitti79 für die Anleitungen.

    Ich habe nämlich momentan das Problem, dass die normalen mp3s relativ schnell abspielbar sind, aber Spotify Inhalt ca ne Minute länger dauern. Gibts da vielleicht irgendwo schon Beiträge dazu, die ich nicht gefunden habe? Oder ist das einfach so?

    Danke und Grüße

    Philip

  • Ich nutze die Version mit Spotify. Erster Gedanke wäre schlechte WLAN Verbindung?


    Ich benutze möglichst schnelle Karten, imMoment Sandisk extreme microsdhc uhs-I u3. Aber die Unterschiede sind da glaub ich nicht soo groß..

    Edited once, last by bCid ().

  • Setup ist:

    Raspberry 3b, ohne Spotify. SD Karte ist eine 8 GB Sandisk. Nicht sicher welcher Typ...


    Den Swap habe ich sogar wieder aktiviert. Ich hatte das Gefühl dadurch dauert es länger.


    Mit splitti79 s Vorschlag den mpd vom Netzwerk zu entkoppeln, bin ich jetzt auf ca. 13-16 sekunden.

    Wenn man das macht, muss man doch auch nicht mehr die anderen Netzwerkoptimierungen machen (noarp etc.), oder?



    P.S. Wie messt ihr eigentlich die Startzeit?

    Ideal wäre ja mal eine Langzeitmessung. Sprich jedesmal wenn die Kiste eingeschaltet wird, schreibe die Startzeit in eine Datei... Aber da hapert es mit meinen Basic-Skript-Kenntnissen.

  • Wie wäre es, wenn ihr mal ne bessere SD-Karte nehmen würdet?


    Es lohnt nicht bei nem Pi ne UHS2 Karte zu nehmen, weil er es gar nicht so schnell anbinden kann. Meiner Meinung nach, sind die Samsung SD-Karten die besten.

    Wenn's brennt 112 hilft weiter!

  • Ich nutze diese hier: Samsung EVO 64 GB (Affiliate-Link)


    Die hat in Benchmarks richtig gut abgeschnitten beim Pi...


    Ich habe tatsächlich die Stoppuhr betätigt und gewartet, bis der mpd dem Display vernünftige Daten liefert. Das System bootet ggf. im Hintergrund noch den einen oder andere Dienst, aber im Grunde funktioniert alles schon, auch Netzwek. Aber mit Spotify braucht es halt immer etwas länger... Ich hab's per Webradio getestet, da geht der Stream so gut wie sofort los...

  • So, ich hab jetzt die Tuning Tipps aus Splitti79s FAQ (Danke!) mal angewandt und muss sagen, dass sich die Zeit bis zur Spotify Wiedergabe um Welten verbessert hat.


    Es ist ein Raspberry 3 B verbaut.


    Ich komme jetzt auf 17s bis zum Startsound und ca. 35s bis zur Spotify Wiedergabe.


    SD Karte weiß ich leider grade nicht, was ich im Raspberry stecken hab. Ich glaube es war ne Sandisk mit 128GB. Wenn ich die Box das nächste mal öffne schaue ich mal nach und tausche sie ggf. gegen ne schnellere aus.


    Danke für alle Tipps! Tolles Forum!

  • Bin weiter am "tunen" und hab noch ein paar nette Parameter gefunden. Sind alle dokumentiert im Blog. Bin bei 13 Sekunden, hab auch schon 10 geschafft...

    Code
    4.173s phoniebox-startup-sound.service
    3.079s dhcpcd.service
    1.776s dev-mmcblk0p2.device
    1.257s php7.0-fpm.service
    1.216s smbd.service
    1.188s networking.service
    1.177s lighttpd.service

    Die cmdline.txt stellt mich vor Herausforderungen, da ich hier nicht so schöne Dokumentationen finde, wie zur config.txt. Meinte sieht bislang so aus:

    Code
    dwc_otg.lpm_enable=0 console=serial0,115200 console=tty3 root=PARTUUID=<EURE-ID> rootfstype=ext4 elevator=
    deadline noatime nodiratime fastboot fsck.repair=yes rootwait loglevel=1 quiet logo.nologo

    Auf folgende Infos bin ich gestoßen: https://www.raspberrypi.org/forums/viewtopic.php?t=25777Alles in allem sollten wir mal weiter schauen, welche Pakete deinstalliert werden können...

  • Ich bin bei etwa 15Sekunden (RPi 3 V1.2, 32GB SD-Card von Samsung), wobei ich auch noch einen Service laufen habe, der das Logging in den Ram ermöglicht (schont die SD-Card), wie in Siehe hier und im Weiteren Siehe hier beschrieben. Dieser Service beansprucht zwar weitere 4-5 Sekunden, aber seis drum.
    Ansonsten habe ich einige Services deaktiviert, die dhcpcd.conf angepasst und den mpd-service "entkoppelt".

    Komischerweise ist der Startsound nun immer ziemlich laut, hat jemand eine Idee, woran das liegen könnte oder was ich anpassen kann, damit das nicht mehr so ist? Die maximal-Lautstärke habe ich per Web-Oberfläche angepasst auf 80%, aber der Startsound sollte doch eigentlich in der zuletzt eingestellten Lautstärke sein (die liegt immer so bei gut 10%) , oder ?

  • Bin weiter am "tunen" und hab noch ein paar nette Parameter gefunden. Sind alle dokumentiert im Blog. Bin bei 13 Sekunden, hab auch schon 10 geschafft...

    Code
    4.173s phoniebox-startup-sound.service
    3.079s dhcpcd.service
    1.776s dev-mmcblk0p2.device
    1.257s php7.0-fpm.service
    1.216s smbd.service
    1.188s networking.service
    1.177s lighttpd.service

    Heißt das du hast alle anderen Services rausgeworfen / deinstalliert? Oder ist das nur der Anfang des Listings?


    Ich denke immernoch dass die Reihenfolge der Services die Hauptrolle spielen muss. Warum brauche ich SMBD, Lighttpd oder php7 zum abspielen von Musik? Die können doch alle nach dem Startup Sound kommen.


    Was sagt denn bei dir Systemd-analyze critical-chain?

  • Das ist nur der Anfang der Liste.

    Smbd braucht man nicht immer, werde ich im nächsten Schritt auch rausnehmen. Lighttpd und php7 braucht man für das Webinterface (und ssh?)

    Mit der Reihenfolge hab ich mich noch garnicht auseinander gesetzt, würde mich sehr interessieren, wie ihr es im Einzelnen umsetzt.