Treiber aktivieren - Kernel Anpassung - USB-Gerät wird erkannt keine Verwendung möglich

  • Hallo,

    ich stehe vor einem ungewöhnlichem Problem. Für das Ambilight wird die Software Hyperion benutzt, sobald man einen (mit Linux kompatiblen) Videograbber anschließt wird ein Gerät mit der Bezeichnung „video0“ erzeugt. Auf dieses greift Hyperion zu.

    Eigentlich wird dazu der Chipsatz UTV007 benutzt. Jedoch habe ich nun einen UTVF007 erwischt. Ich habe bereits einige Recherche betrieben und folgendes herausgefunden :

    Quote

    The fix would probably involve adding a quirk to the kernel UVC driver, unfortunately I don't have the time to do that.

    Quelle:

    https://www.linuxtv.org/wiki/index.php/Talk:Easycap

    lsusb sagt mir folgendes (wie oben im Link):

    Code
    Bus 001 Device 004: ID 534d:0021  
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    dmesg sagt mir folgendes :

    Display Spoiler

    Wie bekomme ich dieses USB-Gerät zum laufen? Wie kann ich das anwenden, was er als Lösung vorgeschlagen hatte -> "adding a quirk to the kernel UVC driver„

    Ich würde mich über ein paar Tipps freuen.

    Edit:

    Schön wäre, wenn die ID dem utv007 zugewiesen werden könnte. Also das das System denkt es wäre ein utv007 obwohl es ein UTVF007 ist.

    Wenn's brennt 112 hilft weiter!

    Edited once, last by raspbastler (January 23, 2020 at 5:07 PM).

  • Treiber aktivieren - Kernel Anpassung - USB-Gerät wird erkannt keine Verwendung möglich? Schau mal ob du hier fündig wirst!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!