Wie installiere und starte ich Raspbian?

  • Hallo, bin Raspi 4 Neueinsteiger.


    Raspi 4 Paket von Heise mit Original Netzteil und abgeblich vorinstallierter 16 GB SD Karte.

    Auspacken, Karte rein, Strom an. Mehrmals versucht, entweder Bildschirm schwarz oder buntes Alle-Farben-Bild. Scheint also so nicht zu funktionieren.


    Auf eine andere SD-Karte LibreELEC raufkopiert, in Raspi rein, Strom an. LibreELEC + Kodi startet, lässt sich konfigurieren, alles läuft ganz normal und wie erwartet. --> Raspi also nicht defekt.


    Nun wieder Versuche mit der mitgelieferten SD-Karte. Karte mal mit Windows, mal mit dem SD-Format Tool formatieren, NOOBS Dateien drauf und starten. Meist kommt das Alle-Farben-Bild, ansonst passiert aber nichts.

    Dann die mitgelieferte wieder formatieren, LiebreELE drauf und nun startet auch diese Karte sauber. An der Hardware ist also nicht defekt. Warum lässt sich dann dennoch NOOBS in keinster Weise starten??


    Anderer Versuch nun mit einem Image von Raspbian (Originalhomepage) mittels balenaEtcher auf die SD-Karte kopiert, neue Startversucht. Nun passiert garnichts mehr, nicht einmal die grüne Status-LED am Raspi blinkt, nur noch konstant die Rote. Was ist da los, was mache ich falsch?


    Mein Eindruck ist, dass bei all meinen Versuchen die SD-Karte für den Raspi nicht bootfähig war. Meist sind auf der Karte zwei Partitionen drauf, entweder ist die größere ganz unformatiert oder zwar formatiert, aber nicht von Windows lesbar. Meinem Verständnis nach sollte das aber so sein.

    Wie schaffe ich es, dass ein funktionierender Raspi mit funktionierender SD-Karte startet und sich das Raspbian installiert? Wie muss die SD-Karte präpariert werden?

    • Official Post

    Hast Du das Image nach dem Download entpackt oder hast Du die Zip-Datei (richtigerweise) von Etcher entpacken lassen? :conf:


    Du kannst Dich übrigens hieran orientieren: https://www.raspberrypi.org/do…stalling-images/README.md Das sollte funktionieren.


    Btw. NOOBS will man nicht.

  • Bei mir haben bisher alle Installationen auf Anhieb funktioniert, indem ich einfach auf einem Linux Rechner eines der offiziellen Images per dd auf die Karte (oder den USB Stick) geschrieben habe, z. B. dd of=/dev/sdd if=/home/image.img bs=1M.

  • Und deswegen darf ich das hier nicht sagen, oder was? Meine Güte, dachte das wäre ein Diskussionsforum.

    • Official Post

    Doch, darfst Du, aber dann solltest Du auch etwas Konstruktives zu Diskussion beitragen. Oder erwartest Du das Apollo346 wegen Deines Beitrags ein Linux installiert?


    Bildlich gesprochen: Der To schreibt: "Bei meinem Auto ist die Zündkerze defekt. " und Du schreibst "Die Probleme habe ich bei meinem Diesel nicht."


    Verstehst Du das Dilemma?

  • Und deswegen darf ich das hier nicht sagen, oder was? Meine Güte, dachte das wäre ein Diskussionsforum.

    Mach dir nichts draus...die Jungs hier helfen schon durch Fachwissen und sind in der Regel kompetent.

    Aber bei über 7000 Beiträge wie bei Hyle ist wohl auch eine gewisse Ermüdung spürbar...1000mal kommt so ein Anfänger daher und immer wieder dasselbe...da entwickeln sie schon eine gewisse Überheblichkeit ...mein Vorschlag an die genervten Profiforumuser...macht Pause und macht mal was anderes eine Zeitlang. und fallt nicht über die "armen Unwissenden" her.

  • Mach dir nichts draus...die Jungs hier helfen schon durch Fachwissen und sind in der Regel kompetent.

    Aber bei über 7000 Beiträge wie bei Hyle ist wohl auch eine gewisse Ermüdung spürbar...1000mal kommt so ein Anfänger daher und immer wieder dasselbe...da entwickeln sie schon eine gewisse Überheblichkeit ...mein Vorschlag an die genervten Profiforumuser...macht Pause und macht mal was anderes eine Zeitlang. und fallt nicht über die "armen Unwissenden" her.

    @rayjoe + radioshack , willkommen im rpi Forum. Guter Tipp an euch beide Racker, einfach mal durchatmen. Die Menschen leisten die Hilfe / Arbeit aus freien Stücken hier im Forum. Daher einfach mal nachdenken wie, ihr beiden Racker gerne behandelt werden wollt und dann wird alles Gut. Gruß ux

  • Nein, ich bin kein Racker (was ist das?)….ich bin seit 2013 im Forum...nett dass du mich begrüßt.

    Aber die Arroganz und Genervtheit der Daueranwesenden hier, kann schon machen Neuling verschrecken

  • Aber die Arroganz und Genervtheit der Daueranwesenden hier, kann schon machen Neuling verschrecken

    Sorry an Apollo346 für das OT, nur muss ich dazu was sagen.


    Nein, es mag jeder mal einen schlechten Tag haben, doch ist hier weder jemand dauergenervt noch sonderlich arrogant. Keiner der vielen Beitragenden bekommt auch nur einem müden Cent dafür, seine Freizeit zu „opfern“. Gerade hyle (den ich sogar persönlich kenne und schätze) als ruhige und ordnende Hand nicht.


    Was mir mittlerweile tierisch auf den Sack geht, ist die Arroganz manch absoluter Neulinge, frei nach dem Motto „man helfe mir, aber sofort. Zack. zack. Und ich will eine mundgerechte Lösung, ohne selbst nachdenken zu müssen.“. Nur ist nichts davon in den Beiträgen von hyle und @rayjoe zu lesen. Es war lediglich der wohlgemeinte Ratschlag, darüber nachzudenken, ob der Beitrag dem Fragenden hilft, und das, BEVOR man postet.


    Ich schätze den Umgang hier sehr, gerade auch im Gegensatz zu anderen Foren. Also, ich schließe mich unimatrix-0 vollständig an, atme mal tief durch. Lernt doch bitte, mit sachlicher und fundierter Kritik oder anderen Meinungen umzugehen. Das können andere auch, es ist also nicht unmöglich.


    Schönen abend an alle, STF

  • Tut mir leid, dass ich das OT hier erzeugt habe und ich bitte um Entschuldigung! Aber, ich dachte wirklich, dass ich bei so einer grundlegenden Frage auch mit meiner Antwort bzgl. dd etwas beitragen könnte. Zum einen, hätte es ja sein können, dass der TE auch irgendwo ein Linux (oder MacOS) System greifbar hat, zum anderen auch für andere Newbies die das lesen oder nachgoogeln.

  • Hallo Leute, danke für die verschiedenen Tipps. Forums-Flamerei schockt mich nicht, habe genügend schon erlebt.


    So, der Reihe nach:

    -       ZIP-Datei vom Etcher direkt bearbeiten lassen, nicht entpackt, genau wie auf der raspberrypi.org beschrieben.

    -       Leider kein Linux-Rechner zur Hand. Vll. das erste Mal, dass ich ein Linux als nützlich empfände ...

    -       Betrachten wir mal das Ganze OT hier als vergeben und vergessen ...

    -       Ja, ein MacOS hab ich zur Hand, nur noch niemals irgendwas mit der Konsole angestellt, so dass ich mit dem oben genannten Befehl nichts anfangen kann. Müsste ich mir erstmal im einzelnen ansehen, was die Teile bedeuten und ... ich würd da als nächstes schaun, ob ich am Mac nicht ein Programm (statt Konsolenbefehlen) finde, mit dem ich die SD-Karte erstellen kann. Aber bislang wollte ich micht nicht mit dem Mac befassen, weils mir nicht in den Kopf reingeht, warum das mit Win nicht gehen sollte – wo es doch ausführlich beschrieben ist.

  • ZIP-Datei

    Welche genau?

    warum das mit Win nicht gehen sollte

    Weiß ich auch nicht, alle geeigneten Images liefen hier auf Anhieb.


    PS: Flames hab ich hier nicht gesehen ;)

  • Deep Breth. Aus meiner persönlichen Sicht eine bewährte Qelle für ein passendes Image z.b =>

    https://www.raspberrypi.org/downloads/raspbian/

    Etcher sollte ohne Probleme funktionieren, sonst wäre Win32Diskimager eine Alternative vorausgesetzt du nutzt Win**.

    Evtl. noch eine unbedarfte SD-Karte besorgen. Vorinstalliert kann manchmal Tricky sein. Im Grunde genommen bekommst du von Heise ein funktionsfähiges komplett System. Könnte auch durchaus ein Hardwareproblem / Garantiefall sein. Meine Heise = Plug and Play. Soweit meine :2cents:. Gruß ux

    • Official Post

    Apollo346 Du hast nicht zufällig das Raspberry Pi Desktop (for PC and Mac) gezogen? Sorry für diese "blöde" Frage, aber wir müssen das auch ausschließen. Das Image stammt bestimmt von hier oder?


    Ich verstehe ehrlich gesagt nicht weshalb das dann nicht will. :denker:


    Btw. radioshack Du bist ja schon eine Weile einer meiner "Fanboys". Kannst Du nicht einfach mal die Finger still halten oder mich per PN anschschreiben? Damit zerstörst Du keine Threads und tust dem Forum echt einen Gefallen. Keine Ahnung was ich Dir getan oder ob ich Dir irgendwann mal ans Bein gepinkelt habe. Ist (mir) auch egal, aber kein Grund Unbeteiligte damit zu stören.

    Davon ab... Müde macht es mich, wenn ich mich mit solchem Mist beschäftigen muss. In dieser Zeit könnte ich mich mit sinnvolleren Dingen beschäftigen. Und mal ehrlich... Arroganz, ... ich? :blush: ...:rofl: Danke! Das stärkt mein Selbstbewusstsein! :thumbup: Ehrlich? Nö! :shy:


    ...

    Und ist genau der falsche, also nichtfunktionierende Link! ;)


    Dieser Download ist für eine VM geeignet, aber nicht für eine SD.

  • Hey Leute, ich habs zum Laufen bekommen. Drei Dinge hab ich verändert und dann (nicht im Ausschlussverfahren) probiert:

    1. anderen HDMI-Port am Raspi angeschlossen (hier aufgeschnappt: https://www.raspberrypi.org/forums/viewtopic.php?t=250615) - glaube aber nicht, dass es das war, denn jetzt leuchtet beim Start die grüne LED und das tats vorher nicht.

    2. Die SD-Karte diesmal am Mac (wieder mit balenaEtcher, nicht per Terminal) bespielt

    3. Dieses mal ein anderes Image (Raspbian Buster with Desktop) von derselben Seite (raspberrypi.org) heruntergeladen.


    Vielleicht hatte ich das falsche Image, aber mehr noch glaub ich, dass es mein Win-PC irgendwie nicht hinbekommen hat.


    Edit: habe mir gerde nochmal oben genannten "falschen" Link angesehen, könnte auch sein, dass ich den zuerst erwischt hab - klar stehen tut da nicht, dass der falsch wäre ...


    Ich danke euch für die Tipps!

  • Kann es sein, dass du ein älteres Image erwischt hattest, welches für den RPi 4 noch nicht geeignet war?


    Auch mit dem WIN-PC sollte es ohne Probleme funktionieren.

    Freut mich dass es funktioniert. Viel Spaß beim basteln, programmieren und probieren.

  • Stimmt, ist geändert.

    :thumbup:

    Aber im Zitat #15 ist immer noch der falsche



    EDIT:

    Ist ja eigentlich nicht schlimm, aber wenn jemand hier liest "ist geändert" ,scrollt ein paar Beiträge zurück und erwischt den Link aus dem Zitat.....