Failed to start the Apache HTTP Server

  • Guten Abend zusammen,

    nach dem ich in der Suche nichts gefunden habe, das mir weiterhilft habe ich mich entschlossen, euch um Rat zu bitten.

    Ich habe mir einen Raspberry Pi4 gekauft und bin dabei das Neuland zu entdecken. Nach dem ich eine Anleitung für Nextcloudpi gefunden habe, habe ich dass dann installiert. Da die beschriebene Vorgehensweise mit der automatischen Erstellung eines SSL Zertifikates nicht geklappt hat, habe ich eine weitere Anleitung gefunden, nach welcher ich vorgegangen bin (https://www.itc-bremen.com/wp/…ine-webseite-ohne-domain/)
    Als ich zu dem Punkt kam, an welchem ich den Apache2 neustarten sollte, bekam ich eine Fehlermeldund, dass das nicht geht. Habe dann den Raspberry neugestartet und erhalte diese Meldung: Failed to start the Apache HTTP Server.

    Hier habe ich euch noch Informationen, die laut Apache hilfreich sein sollen, mir hilft es leider nicht :helpnew:


    Code
    pi@nextcloudpi:~ $ sudo service apache2 start
    Job for apache2.service failed because the control process exited with error cod                                                                                                             e.
    See "systemctl status apache2.service" and "journalctl -xe" for details.



    Ich bin euch jetzt schon für eure Mühe dankbar. Wenn weitere Infos benötigt werden, sagt mir bitte dazu, was ich eingeben muss um sie zu finden :blush:


    Schönen Abend noch und Grüße

    Dennis

    🎵🎸Die Nordsee schlägt dir ins Gesicht, trotzdem hast du verloren, du bist nicht weit gekommen, du läufst weiter nach vorn 🎵🎸

  • Hallo,


    ich weis leider nicht wie ich das beheben kann. Kannst du mir da helfen?


    Danke und Grüße

    Dennis

    🎵🎸Die Nordsee schlägt dir ins Gesicht, trotzdem hast du verloren, du bist nicht weit gekommen, du läufst weiter nach vorn 🎵🎸

  • Ja log wäre interessant: /var/log/apache2/error.log.

    Und vor allem auch auch der Inhalt von /etc/apache2/sites-enabled/ncp.conf so er nicht zu lang ist. Dort ist der Fehler.


    EDIT: Und ja, guck Dir die Anleitung von Hofei in Beitrag #4 an :)

  • Nach dem ich eine Anleitung für Nextcloudpi gefunden habe, habe ich dass dann installiert.

    Ich halte persönlich nichts von dem Komplettimage von Nextcloudpi, da es immer wieder Probleme bei der Installation gibt. Insbesondere beim Raspi 4.

    Es kommt gelegentlich vor, dass Nextcloudpi nach einem apt full-upgrade nicht mehr richtig läuft, oder dass es Konflikte mit anderen Anwendungen gibt.

    Meine Empfehlung:

    Installiere die neueste Version von Nextcloud. (Nicht Nextcloudpi) Eine Anleitung findest du in meiner Signatur oder im Beitrag #4 von Hofei

  • Hallo zusammen,


    vielen Dank für eure Bemühungen und Hinweise.


    Zu der Error.log - Datei, diese ist bei mir leer. Habe sie mit diesem Code geöffnet

    Code
    pi@nextcloudpi:/var/log/apache2 $ sudo less /var/log/apache2/error.log

    Auch mit "zless" wird eine leere Datei geöffnet. Mit dem Befehl "tail" passiert gar nichts.


    Die ncp.conf - Datei hat diesen Inhalt:


    Zu dem Thema mit Nextcloudpi: Danke für den Hinweis. Ich werde in diesem Fall eine Neuinstallation nach deiner empfohlenen Anleitung aufsetzen. Allerdings würde mich die Ursache und die Problembehebung für diesen Fehler doch interessieren.

    Ich würde gerne dazu lernen und versuchen immer mehr Zusammenhänge zu verstehen :thumbup:


    Grüße Dennis

    🎵🎸Die Nordsee schlägt dir ins Gesicht, trotzdem hast du verloren, du bist nicht weit gekommen, du läufst weiter nach vorn 🎵🎸

  • Hallo Ilutz,

    damit bekomme ich folgende Ausgabe:

    Code
    pi@nextcloudpi:~ $ grep -r Listen /etc/apache2/*
    /etc/apache2/ports.conf:        Listen 443
    /etc/apache2/ports.conf:        Listen 443
    /etc/apache2/ports.conf:Listen 80
    /etc/apache2/ports.conf~:Listen 80
    /etc/apache2/ports.conf~:       Listen 443
    /etc/apache2/ports.conf~:       Listen 443
    /etc/apache2/sites-available/ncp.conf:Listen 4443
    /etc/apache2/sites-enabled/ncp.conf~:Listen 4443

    Sind die doppelten Ports hier das Problem?


    Danke und Grüße

    Dennis

    🎵🎸Die Nordsee schlägt dir ins Gesicht, trotzdem hast du verloren, du bist nicht weit gekommen, du läufst weiter nach vorn 🎵🎸

  • Hier die Antwort von deinem Code

    Apache Configuration
    pi@nextcloudpi:~ $ apache2ctl -M |grep -E "tls|ssl"
    AH00526: Syntax error on line 9 of /etc/apache2/sites-enabled/Hugos.conf/Hugos.conf:
    RewriteRule: bad flag delimiters

    Habe hier gleich noch einen Auszug der Datei, in welcher der Fehler sein soll. Zeile 9 habe ich nochmal mit der Anleitung (Link im ersten Post) verglichen und habe keinen Fehler gefunden

    Danke und Grüße

    Dennis

    🎵🎸Die Nordsee schlägt dir ins Gesicht, trotzdem hast du verloren, du bist nicht weit gekommen, du läufst weiter nach vorn 🎵🎸

  • Habe hier gleich noch einen Auszug der Datei, in welcher der Fehler sein soll. Zeile 9 habe ich nochmal mit der Anleitung (Link im ersten Post) verglichen und habe keinen Fehler gefunden

    Dann vergleiche noch einmal...

    hint: geschweifte vs. eckige Klammern

    Menschen die keine Ironie verstehen finde ich super!

  • Oh wie peinlich :rolleyes:


    Habe die eckigen Klammern eingefügt, aber der Apache2 startet immer noch nicht.


    Hier noch die aktuelle Ausgabe des journalctl, falls das weiterhilft:


    Danke und Grüße

    Dennis

    🎵🎸Die Nordsee schlägt dir ins Gesicht, trotzdem hast du verloren, du bist nicht weit gekommen, du läufst weiter nach vorn 🎵🎸

  • Entferne mal die Backup-Dateien *.conf~ aus dem enabled-Verzeichnis.


    btw. die <vhost>.conf Dateien liegen in sites-available/ und sollten nur nach sites-enabled/ verlinkt werden (a2ensite). Damit umgehst du obiges Problem.

    Menschen die keine Ironie verstehen finde ich super!

    Edited once, last by llutz ().

  • Okay im Verzeichnis "sites-enabled" ist jetzt nur noch ein Link zu der conf-Datei, in welcher ich die eckigen Klammern hinzugefügt habe.


    Kann den Apache2 aber trotzdem nicht starten.


    Danke und Grüße

    Dennis

    🎵🎸Die Nordsee schlägt dir ins Gesicht, trotzdem hast du verloren, du bist nicht weit gekommen, du läufst weiter nach vorn 🎵🎸

  • Fehlermeldung?


    Hint2:

    Wenn du verstehen willst, warum Dinge nicht funktionieren, musst du lernen Fehlermeldungen zu erhalten, zu lesen und zu verstehen. Dabei hilft $suchmaschine-deiner-wahl.

    Menschen die keine Ironie verstehen finde ich super!

  • Die Fehlermeldungen zu lesen ist noch sehr schwierig und damit das verstehen natürlich auch. Ich versuche nach zu vollziehen, was wir gerade unternehmen:thumbup:

    Hier wieder beide Meldungen


    Systemctl:

    Journalctl:

    Danke und Grüße

    Dennis

    🎵🎸Die Nordsee schlägt dir ins Gesicht, trotzdem hast du verloren, du bist nicht weit gekommen, du läufst weiter nach vorn 🎵🎸

  • AH00526: Syntax error on line 9 of /etc/apache2/sites-enabled/Hugos1.conf/default-ssl.conf:
    Feb 12 17:41:04 nextcloudpi apachectl[5186]: RewriteRule: bad flag delimiters

    Da steht's doch im Klartext. (Klammern passen nicht)


    Warum dieses Unterverzeichnis? Du machst dir das Leben unnötig schwer.

    Okay im Verzeichnis "sites-enabled" ist jetzt nur noch ein Link zu der conf-Datei,

    Die Fehlermeldung oben sagt was anderes. Was stimmt nun?

    ls -l /etc/apache2/sites-enabled/

    Menschen die keine Ironie verstehen finde ich super!

  • Es funktioniert!


    Das Problem war nun das Unterverzeichnis das du angesprochen hast, dort war noch eine conf-Datei drin.

    Deswegen auch die späte Antwort von mir, habe es nun gelöscht bekommen.


    Ich vermute dass er wegen des Unterverzeichnis den Link zu der richtigen conf-Datei nicht geöffnet hat?


    Vielen lieben Dank für deine Mühe :)

    Grüße und schönen Abend noch

    Dennis

    🎵🎸Die Nordsee schlägt dir ins Gesicht, trotzdem hast du verloren, du bist nicht weit gekommen, du läufst weiter nach vorn 🎵🎸