Eine Waage mit Raspberry pi bauen

  • Friede, wir kommen auch so klar

    wie ihr meint, ist aber auch ein Wunsch der Forenmoderation und ihr lest das ja nicht alleine!

    Also wer ist wir und wie kommt man darauf für ALLE zu sprechen?

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Eventuell habe ich den Fehler, jetzt habe ich die Waage mal andersrum gedreht, dann kamen nur positive Zahlen.

    Kann das sein das der Pfeil auf dem Gewichtssensor nach oben muss?

  • Hi matze1,


    wie bereits geschrieben, das sieht nicht gut aus.

    die Werte sind zu klein und streuen zu sehr.

    ich befürchte, du brauchst auch das eine Kabel, dass du weg gelassen hast.

    Was auch noch wichtig ist: du brauchst einen Null-Wert (ohne Gewicht), einen Referenzwert (mit definiertem Gewicht) und den Wert der eigentlichen Messung.

    Da der Referenzwert in der Regel länger stabil bleibt, wäre der so alle 7 bis 35 Tage zu prüfen.

    Aber zwischen Tara (leer) und Wiegen müssen ganz große Deltas auftreten - vorvallem im Vergleich zum "Rauschen" des Taras bzw. der Wägung.

    ---

    we all live in a yellow subroutine...

  • auch wenn du Gewicht auflegst?


    Sind bei deinem Aufbau das/die Wägeelemente freistehend (oder berühren diese z.B. eine Wand/Wände?

    Das/die Element(e) liegen auch nicht auf der Seite?

    ---

    we all live in a yellow subroutine...

  • Sie liegen weder an der Wand oder liegen.

    Jetzt habe ich nochmal nachgelötet, das grüne Kabel hatte ein bisschen Wackelkontakt.

    Das script erst ohne Gewicht, dann 1kg drauf gestellt (sieht man an den höheren Werten).

    Dann das Script abgebrochen, und neu gestartet mit Gewicht dann gibt es die Ausgabe.

    Code
    pi@raspberrypi:~/hx711py $ sudo python3 example.py
    Tare done! Add weight now...
    31.77777777778101
    -14.222222222218988
    21.77777777778101
    21.77777777778101
    24.77777777778101
    -12.222222222218988
    30.77777777778101

    @ unimatrix Ja die Pins sind richtig nach dessen Anleitung verbunden. https://tutorials-raspberrypi.…uen-gewichtssensor-hx711/

  • meine Erwartungshaltung wäre:

    du hast unbelastet (ohne Gewicht) die Zahlen wie zuesrt gepostet, und wenn du dann bei laufenden Script (!) Gewicht auflegst, dass die Zahlen gewaltig nach oben schnellen.

    Eine Erklärung, warum das Script, dass du - wenn ich das richtig verstanden habe - neu gestartet hattest, NACHDEM du Gewicht aufgelegt hast, wieder nur ganz kleine Zahlen ausspuckt, wäre, dass das Script zuerst die Werte von der Schnittstelle einliest, mittelt, dann AUF NULL setzt (tariert) und DANN erst Werte ausgibt.

    in dem Fall wäre der Versuchsaufbau wohl okay, nur die Bedienung / Nutzung wäre nicht korrekt.


    Von daher schlage ich vor, du startest das Script, wartest mal so 100 Werte, legst eine 1l-Flasche auf (oder sonst was, was stabil auf der Messeinheit steht, ohne was anderes zu berühren und wartest dann wieder 100 Werte ab.

    Wenn sich dann die Zahlen DEUTLICH verändert haben, wäre es wohl ok.

    auf jeden Fall wäre ich an allen Zahlen interessiert.


    Edit: super, das war genau das, was ich erhofft hatte.

    ich schau kir das jetzt mal an, rechne vielleicht noch etwas und melde mich dann

    ---

    we all live in a yellow subroutine...

  • OK. hier nochmal das aktuelle script:

    Hier die Messwerte im laufenden script.

    Erst ohne dann mit 1kg (da werden die Werte deutlich höher):

  • okay, denke, du hast ja heraus gefunden, wie deine Waage funktioniert. :bravo2:


    Das Script tariert wie vermutet erst die Waage, bevor es dir Werte ausspuckt.

    Also gib ihm Zeit, bevor du was auf die Waage legst.

    Zum Wägen würde ich empfehlen, mindestens 10 Werte zu mitteln.

    Nach dem Auflegen von Wägegut gib der Waage auch mindestens 10 Werte zum Stabilisieren, bevor du die Zahlen auswertest (also diese 10 Werte verwerfen). Du könntest auch Schwellwerte verwenden...

    kann ich - falls gewünscht - näher erläutern.


    jetzt zu den Zahlen:

    unbelastet hast du Streuwerte von 75% oder ein Delta von 55 Einheiten. Ich denke, das ist okay.


    Mit 1kg kommst du auf <1% Streuung, <0,2% rel. Abweichung.

    das sind gute Werte und in der Regel völlig ausreichend.


    Pro 100g sollte sich ein Delta von 8950 Einheiten einstellen (war das Kilo brutto oder kommt das noch eine Hülle zum Inhalt dazu - wie im Falle von 1 Liter Wasser?)

    das Delta dürfte stabil bleiben...


    Glückwunsch :bravo2:

    ---

    we all live in a yellow subroutine...

  • Vcc = 5 V per Anleitung. Du schreibst Vcc = 3,3 V gesteckt. Falls ich das richtig verstanden habe. Evtl. schaust du dir mal die Definition von Logikpegel und der zugehörigen Technologie an. Wenn ein zb. TTL Baustein in einem undefinierten Bereich betrieben wird, kommt am Ende auch nur undefinierte Werte raus. :2cents:

  • abgesehen vom technischen Hinweis von "primäres Element von..." :angel: (sorry, cnr)

    ich denke, die Stabilität der Stromversorgung ist noch wichtiger als die angegebene Spannung.

    letztendlich erzeugt der Druck auf den Wägeelementen ja einen Strom. Den "Wert" des Stromflusses musstvdu so oder so einmesssen.

    von daher: konstante Spannung rules, ob 3,3V oder 5V - was dein Raspi besser verkraftet - jedes Bauelement dazwischen verfälscht die Messung

    ---

    we all live in a yellow subroutine...

  • abgesehen vom technischen Hinweis von "primäres Element von..." :angel: (sorry, cnr)

    ich denke, die Stabilität der Stromversorgung ist noch wichtiger als die angegebene Spannung.

    letztendlich erzeugt der Druck auf den Wägeelementen ja einen Strom. Den "Wert" des Stromflusses musstvdu so oder so einmesssen.

    von daher: konstante Spannung rules, ob 3,3V oder 5V - was dein Raspi besser verkraftet - jedes Bauelement dazwischen verfälscht die Messung

    Dann ist doch alles Paletti McOtter . 3.3 oder 5.0 alles irrelevant.:rofl: Falls mal ein Anfänger den Thread liest wird er sicher die Weisheit verstehen. Wenn den, schreibt doch bitte die richtigen und verwertbaren Vcc Werte. :gk1: bringt nicht viel ;)

  • ich denke, die Stabilität der Stromversorgung ist noch wichtiger als die angegebene Spannung.

    du denkst falsch und so ein Unsinn gehört nicht ins Internet.


    Wenn eine Schaltung mit 3,3V funktioniert und 3,3V Komponenten angeschlossen sind sollte man eher nicht 5V verwenden, einzige Ausnahme man weiß genau Bescheid wie die zusammenarbeiten.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • meines Wiseens nach verträgt ein hx711 sowohl 3,3V bis 5V (sogar einen noch größeren Bereich).

    bin aber technisch nicht so versiert wie der eine odere andere Guru hier im Forum - vielleicht gibt es auch Modelle mit der gleichen Bezeichnung und viel restrikteren Spannungsanforderungen, was weiß ich schon? :angel:

    Normalerweise und allgemein bei Elektronik kann ich eure Hinweise nur unterstreichen - so lange nichts anderes angegeben ist. Und in den Spez. nachlesen geht immer über aufgeschnappte Meinungen im allwissenden Internetz

    ---

    we all live in a yellow subroutine...

  • https://cdn.sparkfun.com/datas…rceFlex/hx711_english.pdf

    Ist doch besser, wenn wir über die Fakten diskutieren. Es gibt meiner (Anfänger) Meinung nach einen Unterschied zwischen 3.3V und 5.0 Volt. Daher +1 jar .

    Edit: Wägezelle

    [Blocked Image: https://images-na.ssl-images-amazon.com/images/I/51ZdOXL2JqL.jpg]


    https://robu.in/product/weighi…electronic-yzc-133-wires/

  • Also jetzt blicke ich so richtig nicht mehr durch.

    Ist nun 3,3V ok?

    Auf der Verlinkten Wägezelle von @unimatrix ist das Grüne Kabel an A+ angeschlossen, in den ganzen anderen Anleitungen im Netzt, ist das grüne an A- angeschlossen. :conf:.


    Wenn jetzt meine Werte stimmen, kann ich ja mit den kalibrieren wie in den Tutorial beschrieben beginnen.


    Und ich hatte genau 1kg auf der Waage gehabt.

  • bin aber technisch nicht so versiert wie der eine odere andere Guru hier im Forum - vielleicht gibt es auch Modelle mit der gleichen Bezeichnung und viel restrikteren Spannungsanforderungen, was weiß ich schon? :angel:

    einmal erkläre ich es noch, die Wägezelle arbeitet von 2,7V bis 5,5V das ist richtig, aber sie wird am PI angeschlossen und der IST NICHT 5V tolerant und nimmt 5V an GPIO Ports oft übel, deswegen bei 3,3V bleiben.


    Es gibt OC open Colletor Schaltungen die gemischte Spannungen erlauben weil sie low basierend arbeiten, es ist stets zu prüfen ob es zutrifft.

    Eine gute Erklärung hat der Forenbetreiber gebaut.

    RealTimeClock - DS1307 - Anschluss an I2C mit 5V?


    leider geht der Umbau bei dem besseren RTC3231 Modul mit LiR2032 Akku nicht so leicht, das nutze ich aber mit Pegelwandler, damit der Akku geladen wird braucht 5V und I2C den PI mit 5V nicht überlastet.

    https://eckstein-shop.de/DS323…MIVW3l3iBwZIaAkw3EALw_wcB

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • OK alles klar, schon mal vielen dank.

    Aber das kalibrieren funktioniert bei mir wie hier beschrieben nicht.

    Ich kommentieren die Zeile

    Code
    hx.set_reference_unit(referenceUnit)

    aus.

    Dann das Gewicht von 1kg drauf gepackt und das Script laufen lassen, dann kamen wieder diese Zahlen

    also das Gewicht wieder entfernt, dann das Script gestartet und Gewicht drauf, dann kam wieder immer

    Code
    88766.77777777778

    das habe ich dann durch 1000 genommen (wegen 1000g) dann in der Variable gespeichert

    Code
    referenceUnit = 89

    und anschl. das auskommentierte wiederhergestellt.

    Aber das Zeigt mir jetzt wieder Zahlen an um die

    :conf: