Webserver mit PHPmyadmin aufsetzen

  • Hey zusammen,


    bin leider etwas ratlos mittlerweile.. und zwar habe ich folgende Dinge getan:


    - einen Webserver aufgesetzt

    - php installiert

    - mysql installiert

    - phpmyadmin installiert.


    leider funktioniert das Ganze nicht so.

    Also der Webserver läuft, mein PHP auch (habe hier folgende Version)


    Das MySQL machte mir anfangs Probleme (Da lief der mysql-server nicht), mittlerweile sollte das aber auch laufen:


    PHPmyadmin habe ich nun per sudo apt-get install phpmyadmin installiert.

    ist soweit auch durchgelaufen, allerdings kann ich die URL http://MEINE_IP/phpmyadmin/ nicht öffnen.


    Ich würde jetzt gerne alles wieder wegwerfen (also Phpmyadmin, Apache, PHP und Mysql) und das ganze neu aufziehen.


    Der Befehl sudo apt-get purge <program name> sollte dafür doch funktionieren oder?

    Leider sind aber trotzdem noch die PHPMyadmin-Ordner da. Das bringt mich irgendwie zum verzweifeln..


    Danke an Alle





  • Ich würde Dir raten, Webserver, php und mysql nach der LAMP Anleitung hier im Forum zu installieren, und dann phpmyadmin händisch im Documentroot des Webservers herunterzuladen und zu entpacken. Macht vieles einfacher.

  • Hast du nach der Installation des PHPMYADMIN den Apache neu gestartet ?

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

  • mach mal ein : sudo a2query -c und poste den Output


    Danach ein sudo ls -la /etc/apache2/conf-available


    und ein sudo cat /etc/apache2/conf-available/phpmyadmin.conf

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

  • Hey sorry für meine verspätete Rückmeldung... war auf Geschäftsreise.


    Hier die Ausgaben;

    Habe inzwischen auf die von dir verfasste LAMP-Doku gefunden: https://public.bcse.de/wiki/doku.php?id=linux:install:lamp


    Hier bekomme ich aber schon beim ersten Befehl ein Problem..



    Ich wollte danach mal das Package MariaDB entfernen.. aber das funktioniert irgendwie auch nicht.

    Der Befehl wäre doch "sudo apt-get remove mariadb-server mariadb-client" oder?


    Danke

  • PHPmyadmin habe ich nun per sudo apt-get install phpmyadmin installiert.

    Das war ein Fehler. PHPMyAdmin wird in den Repositorys von buster nicht mehr upgedatet, Du hast eine vollkommen veraltete Version installiert.

    Hier bekomme ich aber schon beim ersten Befehl ein Problem..

    Immer diese vollkommen veralteten Anleitungen


    Schau dir mal mein Tutorial an. Link in meiner Signatur.

  • Dankeschön, habe es inzwischen beheben können.

    Habe auch die Version geupdatet, da die Version die ich hatte (4.6.6) Probleme mit PHP 7.3 hatte.

    Jetzt läuft alles. :)