Brauche Hilfe beim Mounten von Synology NAS

  • Moin allerseits.


    Ich bräuchte mal Hilfe. Ich möchte ein Laufwerk von meinem NAS einbinden. Am Synology habe ich die Freigabe erteilt und es funktionierte auch. Nach einem Neustart war der Mount weg und ich wollte mit Hilfe einer Anleitung mit einem Eintrag in der fstab den mount dauerhaft einrichten. Ich muss dabei wohl was falsch gemacht haben, auf jeden Fall hat es mir das System total zerschossen. Jetzt habe ich alles nochmal neu aufgesetzt, habe aber Probleme mit dem mounten. Wenn ich den Befehl


    sudo mount -t nfs -o soft 192.168.178.10:/volume1/homes /home/Synology


    eingebe, dann passiert gar nichts. Sonst konnte ich immer im Dateiexplorer auf das NAS zugreifen, aber der Pfad ist leer.


    Wie ihr vielleicht bemerkt habe, bin ich absoluter Neuling in Sachen Linux und Raspberry und ich habe echt Schiss, dass ich mir wieder alles zerschieße. Also, nochmal in Kürze, warum sehe ich meine Dateien nicht und wie richte ich den mount dauerhaft ein? Ich würde mich über Unterstützung wirklich freuen.


    LG, Crazy

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS Bullseye

  • Mache ein umount /home/Synology und dann probiere mal diesen Aufruf:

    Code
    sudo mount -vf -t nfs -o soft 192.168.178.10:/volume1/homes /home/Synology

    Und kopieren hier die Ausgabe die kommt. Edit: Code Block korrigiert.

    Edited once, last by daxb ().

  • pi@raspberrypi:~ $ sudo umount /home/Synology

    umount: /home/Synology: not mounted.

    pi@raspberrypi:~ $ sudo mount -vf -t nfs -o soft 192.168.178.10:/volume1/homes

    mount: 192.168.178.10:/volume1/homes: can't find in /etc/fstab.

    pi@raspberrypi:~ $ /home/Synology

    bash: /home/Synology: Ist ein Verzeichnis

    pi@raspberrypi:~ $


    So sieht das dann aus.

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS Bullseye

  • mount: 192.168.178.10:/volume1/homes: can't find in /etc/fstab.

    Wenn, wie hier, noch kein funktionierender Eintrag in fstab vorhanden ist, musst Du beim mounten Quelle und Ziel angeben.


    Solange in fstab ein fehlerhafter Mount eingetragen ist, wird dieser beim Booten ausgeführt und blockiert einen neuen manuellen Mount auf dieselbe Quelle/Ziel.


    Deshalb lösche zuerst den fehlerhaften Eintrag in fstab, oder zeige ihn wenigstens her.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Wenn ich das ohne Zeilenumbruch eingebe, dann kommt das hier raus:


    pi@raspberrypi:~ $ sudo mount -vf -t nfs -o soft 192.168.178.10:/volume1/homes /home/Synology

    mount.nfs: timeout set for Tue Feb 18 14:30:47 2020

    mount.nfs: trying text-based options 'soft,vers=4.2,addr=192.168.178.10,clientaddr=192.168.178.11'

    pi@raspberrypi:~ $


    Der Inhalt meine fstab sieht so aus:


    proc /proc proc defaults 0 0

    /dev/mmcblk0p6 /boot vfat defaults 0 2

    /dev/mmcblk0p7 / ext4 defaults,noatime 0 1

    # a swapfile is not a swap partition, no line here

    # use dphys-swapfile swap[on|off] for that

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS Bullseye

    Edited once, last by Crazy32 ().

  • Das Finetuning kannst Du auch später vornehmen.

    Probiere erstmal: < sudo mount -v 192.168.178.10:/volume1/homes /home/Synology >


    Servus !


    Ed: dann < sudo mount -v -t nfs -o timeo=20 192.168.178.10:/volume1/homes /home/Synology >

    dann < sudo mount -v -t nfs -o timeo=20,no_root_squash 192.168.178.10:/volume1/homes /home/Synology >

    RTFM = Read The Factory Manual, oder so

    Edited once, last by RTFM ().

  • So, ich habe die Befehle aus euren Beiträgen mal eingeben. Ich poste hier mal alles zusammen.


    EDIT: Im Dateimanager ist aber nichts zu sehen, obwohl die Pfade zum NAS doch erkannt wurden, oder?


    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS Bullseye

  • dein nfs-share ist gemountet, nun trägst du das in die /etc/fstab ein:

    Code
    192.168.178.10:/volume1/homes /home/Synology nfs  _netdev,defaults 0 0

    Dann

    sudo umount /home/Synology

    sudo mount /home/Synology

    ls -l /home/Synology

    Menschen die keine Ironie verstehen finde ich super!

  • Teilweiser Erfolg. Nachdem ich den Code in der fstab ergänzt und die Befehle eingegeben habe, wurden die Laufwerke im Dateimanager angezeigt :thumbup: Nach einem Reboot sind sie aber wieder weg :(


    So sieht die fstab aus, ahbe ich da einen Fehler drin?


    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS Bullseye

  • Das Speichern der fstab hat auch funktioniert? Weil dafür braucht man root Rechte (Geany als root gestartet?). Einfacher ist meiner Meinung nach das Editieren der fstab im Shell Fenster mit z.B. sudo nano /etc/fstab. Strg + o zum Speichern und Strg + x zum Beenden.

  • Das Speichern der fstab hat auch funktioniert? Weil dafür braucht man root Rechte (Geany als root gestartet?). Einfacher ist meiner Meinung nach das Editieren der fstab im Shell Fenster mit z.B. sudo nano /etc/fstab. Strg + o zum Speichern und Strg + x zum Beenden.

    Ja, das Speichern hat geklappt. Ich hatte mich als Root User angemeldet. Der Screenshot ist nach dem Neustart entstanden.

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS Bullseye

  • das übliche Problem, zur Bootzeit ist das Netzwerk noch nicht da und deshalb fehlt das nfs-share. Abhilfe evtl. eine systemd-mount-unit.


    Gibt es die Option defaults bei nfs überhaupt?

    aus "man fstab"

    Quote

    Basic filesystem-independent options are:

    defaults

    use default options: rw, suid, dev, exec, auto, nouser, and async.

    Menschen die keine Ironie verstehen finde ich super!

    Edited once, last by llutz ().

  • das übliche Problem, zur Bootzeit ist das Netzwerk noch nicht da und deshalb fehlt das nfs-share. Abhilfe evtl. eine systemd-mount-unit.

    Und genau deswegen ist meine Anleitung entstanden, weil auch zu dieser Zeit _netdev nicht zuverlässig funktionierte. Wer weiß vll hatten sie auch zu dieser Zeit einen Bug der mittlerweile gelöst ist.

    Ist zwar für cifs geschrieben, aber mit ein paar Anpassungen muss das auch für nfs funktionieren:

    Netzwerkfreigabe mounten mit systemd Mount Unit

    Ein möglicher Weg führt über einen Eintrag in der Datei /etc/fstab. Da ich oft Probleme, mit zur Bootzeit noch nicht erreichbaren Freigaben im Netz, hatte und sich diese auch nicht mit Parametern wie _netdev lösen ließen,

  • Gibt es die Option defaults bei nfs überhaupt? Vielleicht habe ich die auch nur in der man-Page übersehen.


    Versuchs mal mit _netdev,rw. Siehe auch hier: https://wiki.ubuntuusers.de/NFS/#Auf-Freigaben-zugreifen

    Damit hat es leider auch nicht geklappt. Ist der mount denn im Hintergrund trotzdem noch eingerichtet? Ich hätte ja gedacht, dass ich das mit dem Befehl sudo mount -v 192.168.178.10:/volume1/homes /home/Synology wieder zum Laufen bekomme, klappt aber auch nicht. Ich hätte kein Problem den mount nach einem Reboot von Hand wieder zu starten.

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS Bullseye