Raspi seit neuestem immer wieder nicht über IPv4 erreichbar (IPv6 geht)

  • Hallo,


    ich habe mich hier neu angemeldet, da ich ein Problem habe und mal Tips bräuchte.


    Ich habe einen Raspberry 3B+ mit dem ich PiHole und IOBroker betreibe. Der lief jetzt monatelang problemlos durch, seit dem letzten apt-get upgrade und Aktualisierung (aktuell nun 4.19.97-v7+) habe ich folgendes Problem:


    Seit dem Update ist der raspi immer ab ca. 12:15 Uhr nicht mehr über IPv4 zu erreichen oder anzupingen. Die IPv6 Adresse geht aber noch.
    Nach einem Neustart reagiert er dann auch wieder über die IPv4 Adresse.


    Da es immer etwas zur gleichen Zeit ist (zwischen 12 - 12.30 Uhr mIttags), hab ich die crons geprüft aber nichts gefunden.

    In den /var/logs bzw. syslog sehe ich auch keine Auffälligkeiten, nur dann den Neustart nachdem er nicht mehr erreichbar war.

    Hat jemand Tips wo ich suchen könnte, warum sich quasi die IPv4 Adresse "aufhängt" während die Netzwerkkarte über IPv6 noch reagiert?


    Danke und Gruß
    Heiko

  • Nach einem Neustart reagiert er dann auch wieder über die IPv4 Adresse.

    Wie sind vor und nach dem Neustart, die Ausgaben von:

    Code
    ip a
    route -n
    ip n s
    dmesg | tail -n 20

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Wie sind vor und nach dem Neustart, die Ausgaben von:

    Code
    ip a
    route -n
    ip n s
    dmesg | tail -n 20

    Hallo,


    ich hab die Logs (vorher / nachher) mal als Dateien angehängt.

    Es sieht so aus, als ob sich einfach die IPv4 Adresse vom Adapter "löst".


    Was ich noch gefunden habe ist folgendes (es ist übrigens nicht nur um 12 Uhr Mittags sondern anscheinend auch gg. 0 Uhr - oder es ist einfach Zufall)


    Feb 21 23:25:31 raspberrypi dhcpcd[389]: eth0: hardware address e4:e0:c5:0a:16:d9 claims 192.168.178.23

    Feb 21 23:25:32 raspberrypi dhcpcd[389]: eth0: hardware address e4:e0:c5:0a:16:d9 claims 192.168.178.23

    Feb 21 23:25:32 raspberrypi dhcpcd[389]: eth0: 10 second defence failed for 192.168.178.23

    Feb 21 23:25:32 raspberrypi avahi-daemon[367]: Withdrawing address record for 192.168.178.23 on eth0.

    Feb 21 23:25:32 raspberrypi dhcpcd[389]: eth0: deleting route to 192.168.178.0/24

    Feb 21 23:25:32 raspberrypi avahi-daemon[367]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.178.23.

    Feb 21 23:25:32 raspberrypi dhcpcd[389]: eth0: deleting default route via 192.168.178.1

    Feb 21 23:25:32 raspberrypi avahi-daemon[367]: Interface eth0.IPv4 no longer relevant for mDNS.

    Feb 21 23:25:32 raspberrypi dhcpcd[389]: eth0: probing address 192.168.178.23/24

    Feb 21 23:25:33 raspberrypi dhcpcd[389]: eth0: hardware address e4:e0:c5:0a:16:d9 claims 192.168.178.23

    Feb 21 23:25:33 raspberrypi dhcpcd[389]: eth0: DAD detected 192.168.178.23


    Das lässt auf eine doppelte Adresse schließen, aber ich habe alle Geräte an einer fritz.box die als DHCP Server dient (dort sehe ich auch keine doppelte .178.23 Adresse) und den Geräten den Raspberry als DNS Server mitteilt!? Und wieso sollte das nun erst seit dem Update sein und der Raspi lief zuvor monatelang ohne Problem!?


    Im IOBroker finde ich auch nichts. Nur dass der auch feststellt, dass er keine IPv4 Adresse mehr hat:


    host.raspberrypi 2020-02-22 00:26:49.968 info No IPv4 address found after 5 minutes.

    Ciao
    Heiko

  • Hi,


    ich hab nun mit nmap und arp scan nochmal gespielt und aus dem log oben die MAC Adresse mal in der Fritzbox gesucht, die die IPv4 des Raspis claimt.
    Laut MAC ist das mein Samsung-Fernseher mit der IP 192.168.178.22 (also eine IP-Nr. unter dem Raspi).

    Ich habe dem Fernseher nun mal ne andere feste IP zugeteilt...mal testen und beobachten...

    Ciao
    Heiko

  • Im IOBroker finde ich auch nichts. Nur dass der auch feststellt, dass er keine IPv4 Adresse mehr hat:

    Poste die Ausgaben in code block und im spoiler.

    Wenn Du avahi nicht brauchst, dann deinstallieren:

    Code
    sudo apt-get purge --remove avahi-daemon

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hi,


    das Ändern der IP für den Fernseher hatte nichts gebracht.. es gab wieder einen Adresskonflikt angeblich mit meinem Samsung TV (der seit Jahren ohne Änderungen am WiFi hängt).


    Nun habe ich mal avahi deinstalliert... bisher ist das Problem nicht mehr aufgetreten.. mal beobachten.


    Erklären kann ich mir das jedenfalls nicht, vor allem warum es erst seit letzter Woche bzw. dem Update auf das neueste Raspian auftritt... an der Fritzbox wurde auch nichts geändert... wie soll plötzlich eine andere Adresse reinspuken?


    Ciao

    Heiko

  • Hi,


    seit der deinstallation von avahi keine "Hänger" oder Adresskonflikte mehr...komisch, aber ich denke, es ist damit gelöst.
    Danke an rpi444.

    Ciao

    Heiko