Letsencrypt Probleme Benötige Hilfe

  • Hallo Franjo,


    ich habe gerade nochmal alles neu aufgesetzt.

    Betriebssystem ist:

    Raspbian Buster with desktop and recommended software

    Image with desktop and recommended software based on Debian Buster
    Version:February 2020
    Release date:2020-02-13
    Kernel version:4.19
    Size:2530 MB


    -> Dann habe ich die Grundinstallation gemacht. Das hat alles soweit geklappt gut geklappt.

    -> Dann habe ich den NAS (Samba) und Mediaserver auf dem Raspberry Pi installiert. Das hat ebenfalls geklappt. Ich finde sogar das Raspberry Laufwerk und kann mich mit dem User anmelden.

    -> Dann wollte ich Apache2, MariaDB, PhpMyAdmin installieren. Apache habe ich mit folgendem Befehl installiert:

    sudo apt install php7.3 php7.3-cli php7.3-curl php7.3-gd php7.3-intl php7.3-json php7.3-mbstring php7.3-
    mysql php7.3-opcache php7.3-readline php7.3-xml php7.3-xsl php7.3-zip php7.3-bz2 libapache2-mod-php7.3
    php7.3-imagick php-apcu

    -> Dann habe ich MariaDB installiert was auch ohne Probleme geklappt hat.


    -> Anschließend muss ich noch PhpMyAdmin hat er soweit runtergeladen und auch installiert ohne Fehler.

    Dann muss man noch die phpmyadmin.conf datei neu erzeugen mit folgendem code der im dokument steht. Den code im Dokument habe ich auch mehrfach überprüft ob dort evtl. ein Tippfehler ist.

    Danach habe ich PhpMyAdmin aktiviert und Apache2 neu gestartet


    Wenn ich dann die Ip-Adresse vom Raspi /phpmyadmin kommt folgender fehler

    Not Found

    The requested URL was not found on this server.

    Apache/2.4.38 (Raspbian) Server at 192.168.XXX.XXX Port 80


    Das war schon der fall. Ich weis nicht wo und wie Ich Php noch richtiger installieren soll.

    Der Raspi lässt sich auch im Netzwerk unter der IP Adresse anpingen.

    Ich verstehe nicht wo der Fehler liegt.


    Vielen Dank für die Hilfe und Bemühungen im Voraus

    Chulaka

  • Zeig mal die Ausgabe von : ls -lad /usr/share/phpmyadmin


    Ich denke der Ordner gehört noch root und es fehlt nur ein chown -R www-data:www-data /usr/share/phpmyadmin

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

  • Hallo,


    vielen Dank für die Hilfe.

    Das ist die Ausgabe wenn ich den Befehl

    ls -lad /usr/share/phpmyadmin



    root@raspberrypi:/usr/share# ls -lad /usr/share/phpmyadmin

    ls: Zugriff auf '/usr/share/phpmyadmin' nicht möglich: Datei oder Verzeichnis nicht gefunden

    root@raspberrypi:/usr/share#


    Vielen Dank

    Chulaka

  • Ich verstehe nicht wo der Fehler liegt.

    Hallo Chulaka


    Ich glaube ich habe den Fehler gefunden.

    Bei der letzten Aktualisierung der Datei ist mir ein Copy/Paste/Fehler unterlaufen.


    Beim Umbenennen der Datei phpmyadmin steht in der Anleitung:

    sudo mv /usr/share/phpMyAdmin-4.9.2-all-languages /usr/share/phpMyAdmin


    Gib den Befehl noch einmal folgendermassen ein:

    sudo mv /usr/share/phpMyAdmin /usr/share/phpmyadmin EDIT geändert

    und die Befehle:

    sudo chmod -R 0755 /usr/share/phpmyadmin

    sudo a2enconf phpmyadmin

    systemctl restart apache2


    Dann sollte es funktionieren.


    Bitte gebe mir eine kurze Rückmeldung, ob's geklappt hat.




    EDIT:

    Hab's in der Anleitung gerade geändert.

  • Ich denke der Ordner gehört noch root und es fehlt nur ein

    Nein, War mein Fehler in der Anleitung. s.#24

    Der Ordner muss nicht www-data gehören.

  • Chulaka Der Fehler war, dass der Ordner Gross-Kleinschreibung beinhaltete, und in der Config nur Kleinschreibung.

    Beachte meinen EDIT in #24

  • Bitte gebe mir eine kurze Rückmeldung, ob's geklappt hat.

    Hallo Franjo,


    ja jetzt bin ich auf eine Anmeldeoberfläche von phpMyAdmin gekommen.

    Es hat funktioniert.

    Ich probiere jetzt die weiteren schritte.


    Vielen Dank!

  • Hallo Chulaka, hallo Franjo


    <OT>

    ich habe das Bild IMG_8753.HEIC in IMG_8753.jpg gewandelt und will es inline darstellen. Das ist das erste Mal, dass ich ein Bild im Blog darstelle:


    Für mich eine Gelegenheit zu üben.

    </OT>

  • Hallo Franjo,


    phpmyadmin funktioniert und Apache2 auch.

    Auf die phpmyAdmin Seite kann ich mich einloggen und auch die zwei Fehler sind beseitigt.

    1. Fehler: "Ab sofort muss ein geheimes Passwort zur Verschlüsselung in der Konfigurationsdatei gesetzt werden [blowfish_secret]

    2.Fehler: "Auf das $cfg['TempDir'] (./temp) kann nicht zugegriffen werden. PhpMyAdmin kann keine Templates zwischenspeichern und ist daher langsam."


    Jetzt habe ich einen Neuen Fehler beim Installieren von Nextcloud

    ->Das Verzeichnis /NC ist angelegt und es gibt auch einen Ordner /NC/data


    Fehler:

    root@raspberrypi:/var/www/html/nextcloud# sudo -u www-data php occ maintenance:install --database "mysql" --database-name "nextcloud" --database-user "XXXX" --database-pass "XXXX" --admin-user "XXXX" --admin-pass "XXXX" --data-dir /home/NC/data

    Can't create or write into the data directory /home/NC/data

    root@raspberrypi:/var/www/html/nextcloud# sudo -u www-data php occ maintenance:install --database "mysql" --database-name "nextcloud" --database -user "XXXX" --database -pass "XXXX" --admin -user "XXXX" --admin -pass "XXXX" --data -dir /home/NC/data



    The "--database" option requires a value.



    maintenance:install [--database DATABASE] [--database-name DATABASE-NAME] [--database-host DATABASE-HOST] [--database-port DATABASE-PORT] [--database-user DATABASE-USER] [--database-pass [DATABASE-PASS]] [--database-table-prefix [DATABASE-TABLE-PREFIX]] [--database-table-space [DATABASE-TABLE-SPACE]] [--admin-user ADMIN-USER] [--admin-pass ADMIN-PASS] [--admin-email [ADMIN-EMAIL]] [--data-dir DATA-DIR]


    root@raspberrypi:/var/www/html/nextcloud# sudo -u www -data php occ maintenance:install --database "mysql" --database-name "nextcloud" --database -user "XXXX" --database -pass "XXXX" --admin -user "XXXX" --admin -pass "XXXX" --data -dir /home/NC/data

    sudo: Ungültige Option -- d

    usage: sudo -h | -K | -k | -V

    usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]

    usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user] [command]

    usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p prompt] [-T timeout] [-u

    user] [VAR=value] [-i|-s] [<command>]

    usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p prompt] [-T timeout] [-u user]

    file ...

    root@raspberrypi:/var/www/html/nextcloud# sudo mkdir /NC/data

    root@raspberrypi:/var/www/html/nextcloud# sudo -u www -data php occ maintenance:install --database "mysql" --database-name "nextcloud" --database -user "XXXX" --database -pass "XXXX" --admin -user "XXXX" --admin -pass "XXXX" --data -dir /home/NC/data

    sudo: Ungültige Option -- d

    usage: sudo -h | -K | -k | -V

    usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]

    usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user] [command]

    usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p prompt] [-T timeout] [-u

    user] [VAR=value] [-i|-s] [<command>]

    usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p prompt] [-T timeout] [-u user]

    file ...

    root@raspberrypi:/var/www/html/nextcloud# sudo -u www-data php occ maintenance:install --database "mysql" --database-name "nextcloud" --database-user "XXXX" --database-pass "XXXX" --admin-user "XXXX" --admin-pass "XXXX" --data-dir /home/NC/data

    Can't create or write into the data directory /home/NC/data

    root@raspberrypi:/var/www/html/nextcloud# sudo mkdir home/NC

    mkdir: das Verzeichnis „home/NC“ kann nicht angelegt werden: Datei oder Verzeichnis nicht gefunden

    root@raspberrypi:/var/www/html/nextcloud# sudo -u www-data php occ maintenance:install --database "mysql" --database-name "nextcloud" --database-user "XXXX" --database-pass "XXXX" --admin-user "XXXX" --admin-pass "XXXX" --data-dir /NC/data

    Can't create or write into the data directory /NC/data


    Vielen Dank für die Hilfe und Bemühungen im Voraus


    Chulaka

  • Vielen Dank für die Hilfe und Bemühungen im Voraus

    Dein Text ist fast unlesbar.

    Bitte schreibe die Ausgaben im Codeblock. (3. Zeichen von rechts in dem schwarzen Balken oberhalb.


    Zeig mit mal die Ausgabe von ls -la /home

  • Bitte schreibe die Ausgaben im Codeblock.

    Chulaka das ist das -Symbol im schwarzen Balken.


    Info: durch einfaches Copy & Paste gehen führende Leerzeichen verloren und Buchstaben haben unterschiedliche Breite... All das passiert nicht im Codeblock.

    Schönen Gruß, kle

  • Hallo Franjo ,


    ich habe den code nochmal in einen Quellcode Block eingefügt. Ich hoffe es ist jetzt besser lesbar.

    Vielen Dank für deine Hilfe und Bemühungen


    Chulaka

  • 1. Die Befehlszeilen enthalten alle Leerzeichen, wo keine hingehören. z.b. (--database -user.......)

    Fehlermeldung The "--database" option requires a value

    2. Das Verzeichnis kann nicht erstellt werden Da fehlt ein / vor home Das muss so aussehen mkdir /home/NC

    3. Can't create or write into the data directory /NC/data Das Verzeichnis /NC existiert nicht, oder du hast den Besitzer und die Gruppe nicht auf www-data gesetzt.

    4. Can't create or write into the data directory /home/NC/data Das verzeichnis /home/NC existiert nicht, oder du hast den Besitzer und die Gruppe nicht auf www-data gesetzt.


    Überprüfe, ob ein Ordner /home/NC existiert und ob der Besitzer und die Gruppe www-data gehören.


    Lösung.

    Wenn das Verzeichnis nicht existiert:

    Erstelle ein Verzeichnis /home/NC (Das Unterverzeichnis "data" wird von Nextcloud erstellt.)

    mkdir /home/NC


    Wenn das Verzeichnis existiert oder du es gerade erstellt hast:

    Setze den Besitzer und die Gruppe des Ordners "NC" auf www-data

    chown -R www-data:www-data /home/NC


    Installiere Nextcloud (Ich setze voraus, dass du die Datenbank, den Datenbankuser und das Passwort wie beschrieben angelegt hast.)

    sudo -u www-data php occ maintenance:install --database "mysql" --database-name "nextcloud" --database-user "nc_user" --database-pass "Passwort" --admin-user "Admin_user" --admin-pass "Admin_Passwort" --data-dir /home/NC/data


    database-name, database-user und database-pass hast du beim Anlegen der Datenbank festgelegt.

    admin-user und admin-pass kannst du frei wählen. Das sind die Anmeldedaten für die Nextcloud-Oberflache.

    data-dir Das ist das Verzeichnis, welches du erstellt hast + /data


    EDIT:

    Alle Befehle als user "root" oder mit sudo ausführen