RS232-Modul ist mit minicom nicht verwendbar, Ziel faxmodem

  • Hallo,

    ich will am raspi über ein RS232-Modul ein faxmodem ansteuern. Es gibt bei ebay zwei dieser module, eines habe ich gekauft für 3,50 Euro


    [Blocked Image: http://aiai.de/foren/rs232-raspberry.jpg]


    Mit raspi-config habe die serielle Schnittstelle so configuriert, dass raspi-config zusammenfassend ausgibt:


    The serial login shell is disabled

    The serial interface is enabled


    Wenn ich auf /dev/ttyS0 etwas cat'e:

    cat aalksdjfasldjf > /dev/ttyS0


    dann blinkt eine winzige Diode auf der Platine.

    Wenn ich mit minicom draufgehe:

    minicom -D /dev/ttyS0


    dann reagiert minicom nicht wenn ich auf der Tastatur tippe, es bekommt offenbar keine keine Antwort.

    Aber die gleiche Leuchtdiode auf der Platine flackert wenn ich tippe.


    Das serielle Modem (elsa microlink) funktioniert an einem alten debian-PC einwandfrei, Kabel und Modem sind also ok.


    # setserial -a /dev/ttyS0

    /dev/ttyS0, Line 0, UART: 16550, Port: 0x0000, IRQ: 36

    Baud_base: 62500000, close_delay: 50, divisor: 0

    closing_wait: 3000

    Flags: spd_normal skip_test


    Ich dachte ich könnte mit

    # setserial -a /dev/ttyS0 port 0x0000 UART 16550 irq 36 Baud_base 115200

    die Baudzahl herunterholen, aber es ändert sich nichts. Der Befehl wird aber angeommen. Ich arbeite übrigens immer als user "root".


    Wer hat mit einen Tipp wie ich die Schnittstelle zum Laufen bekomme?

    (Hinweis: die USB-Seriell-Adapter, die es seit 10 Jahren auf dem Markt gibt, funktionieren alle nicht mit modem und hylafax.)


    Warum ich noch so altes Zeugs verwende? Weil die USB-Modems auf dem Markt nicht mit linux und hylafax laufen! Alle diese kleinen schwarzen Dinger, die es überall für 10 Euro gibt, sind mit einem chip von connexant ausgestattet, der NICHt von Linux unterstützt wird. Viele Verkäufer behaupten es gäbe Linux-Unterstützung, ich verlange von denen gerade Geld zurück. Vor 5 Jahren gab es noch ein identisch aussehendes, aber mit einem anderen Chip., das geht!


    Gruß

    Eckard

    Edited 2 times, last by egerlach ().

  • Wer hat mit einen Tipp wie ich die Schnittstelle zum Laufen bekomme?

    die Teile sind Schrott weil sie Dsub female haben, da brauchst du erst man ein Adapterkabel

    Ein echter PC hat male und da kann man mit Nullmodemkabel verbinden!


    Hast du Rx und Tx richtig probiert?


    Test erst mal Pin 2 nach Pin 3 brücken da sollte erst mal ein Zeichen am PI zurückkommen, wenn nicht hast du Rx und Tx verwechselt


    Ich habe diese Teile alle weggeworfen und nutze gleich:

    https://www.ebay.de/itm/2-5-10…rter-Adaptor/233312918102


    in einem Dsub Stecker male (wie im PC) und verbinde mit Nullmodemkabel Rx und Tx gekreuzt

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Adapter (Changer) habe ich noch, alles von vor 10 Jahren, eine ganze Kiste davon voll. Das ist hier doch nicht das Problem. Wenn sie nur deswegen "Schrott" sind, dann habe ich kein Schrott-Problem ;)


    Danke für die Hinweis wegen vertauschter Rx/Tx. Vielleicht sind die am PI (Pin 8 und 10) -> siehe

    http://www.henrykoch.de/de/ras…chnittstelle-rs232-nutzen vertauscht.

    Also Du meinst die mal umstecken, die 8 und 10?


    Habe erstmal Pin 2 und 3 verbunden. Das hat nichts verändert. LED flackert weiterhin beim Tippen. Dabei habe ich bemerkt, dass auf der Platine eine LED für Tx und eine für Rx ist! Es flackert nur die für Rx!! Komisch, es müsste doch Tx flackern!


    Also pin 8 und 10 am Raspi vertauscht - und siehe da: jetzt flackern beide LEDs (bei verbundenen Pin 2 und 3 der RS232!! Und bei minicom gibts echo, als die Zeichen, die ich tippe, erscheinen im echo! Hurrah! Ein erster Erfolg! Also hat der Autor "henrykoch" das verkehrt angeschlossen, zumindest im Bild.


    Dann das faxmodem angeschlossen. Geht nicht, kein Echo mehr am minicom :( Schade ... liegt das vielleicht daran, dass so ein serielles Faxmodem 5Volt erwartet? Der Pi macht ja nur 3,3V und normale PCs haben 5/12Volt, aber nicht 3V. Die RS232 ist von 3 bis 15 Volt spezifiziert, ist nur die Frage ob ein elsa microlink faxmodem auch so flexibel ist.


    Aber mit Nullmodemkabel will ich eigentlich nicht rum machen, wenn das funktioniert, funktioniert

    noch lange nicht hylafax. Nullmodem wird vermutlich funktionieren, da schonmal das echo am minicom funktioniert.

    Edited 2 times, last by egerlach ().

  • Also hat der Autor "henrykoch" das verkehrt angeschlossen, zumindest im Bild.

    ja es wird viel im Netz verbreitet, auch Falsches!

    Der Pi macht ja nur 3,3V und normale PCs haben 5/12Volt

    kommt auf die Bestückung vom RS Wandler an, normalerweise kann der 3232 das auch an 3,3V betrieben, ich hoffe du hast VCC vom RS Wandler an 3,3V geklemmt?


    Es gibt Wandler die arbeiten mit 232 der erst ab 4,5V arbeitet und 5V an den Ports mag der PI nicht!


    Also die Bestückung MUSS einen MAX3232 haben und VCC MUSS an 3,3V

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Die 3,3V Spannungsversorgung für die Plantine kommt vom PI, siehe Anleitung von dem "henryKoch...", Link oben.


    Läuft das Modem vielleicht erst mit 5V? Das damit testen:

    Die Platine mt dem 3232 hat einen Micro-USB-Eingang, siehe Foto im Eingangsposting von mir. Da hatte ich auch schon mal USB 5V dran, aber ohne angehängtes Raspi. Wenn ich in die Spannungsversorung über USB 5V mache, nur die Rx/Tx-Leitungen an den Raspi anschließe, kann das gut gehen?? - Oder brauche ich unbedingt Spannung +3,3V Vcc und GND vom Raspi, dann eine Diode in das 3,3V-Vcc-Kabel reinlöten, dass der Strom nicht in den Raspi zurück fleßt?

  • Die Platine mt dem 3232 hat einen Micro-USB-Eingang

    mein Fehler habe nicht genau genug geschaut! (ich kenne und habe nur die ohne microUSB gekauft!):blush:

    Da hatte ich auch schon mal USB 5V dran, aber ohne angehängtes Raspi

    sehr gut, dann dürfte der deswegen keinen Schaden genommen haben!:thumbup:

    Läuft das Modem vielleicht erst mit 5V?

    ist an der Chip Bestückung zu sehen, MAX232 ab 4,5V nur MAX3232 laufen mit 3,3V

    Wenn ich in die Spannungsversorung über USB 5V mache, nur die Rx/Tx-Leitungen an den Raspi anschließe, kann das gut gehen??

    ja kann, aber es kann auch schief gehen weil der PI an seinen Ports eben nicht 5V tolerant ist!

    Ich würde das im Zweifel nie versuchen, Ausnahme Serien R und BAT42 als Ableitdiode nach +3,3V


    so kann der PI eher 5V Signale überleben:

    https://forum-raspberrypi.de/attachment/1615-rs232-jpg/


    Ein externes 5V Signal trifft am PI auf 3,3V am Port, Die Differenz ist 1,7V und die Diode leitet den Strom von (5-3,3)/470 = 3,6mA nach 3,3V ab, Die Spannung am GPIO wird durch die Schwellspannung der Diode angehoben aber das geht noch weil es ja auch interne Bodydioden gibt.

    Nur fehlt dem PI halt diese Schutzbeschaltung (serien R + Dioden) die jeder Atmel AVR 8-Bitter hat.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Das dumme ist bei "Echten" Seriellen Anschlüssen, das sie mit -12V/+12V laufen!

    Weshalb so gut wie alle PC-Netzteile auf noch eine Ader mit einer -12V Spannung auf dem ATX-Stecker haben.

    Die ist nur für die serielle Schnittstelle da, die mittleweile auf den meisten Board zwar als Option da ist, aber so gut wie nicht mehr gebraucht wird.

    Könnte also durchaus sein, das z.B. ein serielles FAX-Modem irgendwie diese -12V/+12V erwartet.

    Da wäre dann vielleicht ein USB FAX Modem besser, das würde mit 5V per USB laufen.

    Da brauchst dann nur ein USB Faxmodem und einen Linuxtreiber dazu.

    Da sparst dir das ganze Serielle Gedöhns mit Adapter und Einstellungen etc.

    Denn eine Serielle Schnittstelle zum laufen zu bekommen ist ja das eine, das richtig einstellen bezgl. Baud und Bits, das andere!


    Ansonsten, zuerst mal versuchen den Seriellen Adapter zum laufen zu bekommen.

    Dazu kannst du dir einen sog. "Nullmodem" Stecker basteln, mit dem du dann, anhand eines Terminal proggis ermitteln kannst, ob die serielle Schnittstelle funktioniert!

    Mit einem Nullmodem Stecker schickst du quasi vom Ausgang direkt wieder das Signal in den Eingang und kontrollierst per Terminal, ob das Signal ankommt.

    Früher gab es auch mal Serielle Kabel, die man am Steckergehäuse per Dipschalter konfigurieren konnte.


    Serielle Schnittstelle, das war früher mal ganz wichtig, als Akustikkoppler und danach Analoge Modems aufkamen, später kamen dann die Analogen USB Fax Modems, da war es dann einfacher.


    Ich habe zur Seriellen Kommunikation noch eine gute Erklärung gefunden!

    In der auch davor gewarnt wird, einen Pi direkt mit Seriellen Endgeräten zu verbinden.

    Link

    Edited once, last by Thomas H: Nachtrag ().

  • Das dumme ist bei "Echten" Seriellen Anschlüssen, das sie mit -12V/+12V laufen!

    nö was du meinst ist V24 und hat erst mal nichts mit "Echten Seriellen Anschlüssen" zu tun!

    Weshalb so.....

    ab hier wirds langweilig, kann überall nachgelesen werden und hilft dem TO bei seinem Problem nicht weiter.


    Sind denn Serielle die nicht nach V24 arbeiten deswegen unecht? Was soll das hier?

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Das dumme ist bei "Echten" Seriellen Anschlüssen, das sie mit -12V/+12V laufen!

    ...

    Könnte also durchaus sein, das z.B. ein serielles FAX-Modem irgendwie diese -12V/+12V erwartet.

    oh ... gar nicht daran gedacht ... nachgemessen mit Voltmeter an serieller RS232 eines "alten" PC: an TxD liegen 8 Volt an!!!!! Oahhhhhh! Mist!!!!! Also MUSS 12Volt im Spiel sein!!! Vielleicht läuft das Elsa Microlink gnädigerweise noch mit 5Volt ..., siehe oben ... absichern des PI gegen diese 5Volt.

    mit USB-seriell.-Adapter funktionieren die seriellen faxmodes (elsa) teilweise auch, sie wählen immerhin, also muss es nicht 8 oder 12 Volt geben, also muss 5V reichen, den USB hat nicht mehr als 5V ... Ich teste mal den USB-seriell-Adapter mit dem Raspi ... vielleicht geschieht ja ein Wunder und faxen geht ... ;) Bisher die Jahre zuvor ist jedenfalls kein fax durchgegangen.

    so, getestet: minicom geht, wählen geht auch, wenn werfe ich mal hylafax an auf /dev/ttyUSB0 ...


    @ gemacht! hylafax kann das modem konfigurieren, erkennt es perfekt. Das Senden scheitert aber schon am anfang:

    Feb 7 18:40:19 archivpi FaxGetty[3558]: /dev/ttyUSB0: Can not initialize modem.

    Das erkennen geht, die Fähigkeiten auslesen (Geschwindigkeit, etc) , dann aber nicht senden können. Weiß hier jmd weiter? Irgend ein handshake oder so geht mit dem USB-seriell-Adapter nicht wie von hylafax gewohnt !

    Da brauchst dann nur ein USB Faxmodem und einen Linuxtreiber dazu.

    haha ... genau das gibts nicht mehr! Die vielen schwarzen USB-Modems bei ebay für 10 Euro laufen alle mit dem idProduct=1300 , dieser Chip von connexant wird NICHT unterstützt. Bis 2015 hat lb-link.cn das gleich aussehende Modem mit idProduct=1340 hergestellt, DER Chipsatz ist unterstützt. (obwohl auch dieses Modem nach 500 Fax'en langsam schlapp macht, es ist schlampige China-Ware.) Viel Verkäufer preisen Linux-Support, sind von ihrem Lieferanten aber belogen worden. Ich hole mir gerade für solche Bestellungen das Geld zurück. Habe die Verkäufer (Chinesen) vor Kauf bekniet einmal das Modem in einen beliebigen PC einzustecken und die idProduct= XXXX auszulesen, das war ALLEN aber zu viel Arbeit.


    Dann gibt auch ähnlich aussehende USB-Modem für 50 oder 80 Euro (weiß, oder auch schwarz), die sind aber ALLE ausdrücklich als nur von Win unterstützt gekennzeichnet: "nur Win-Unterstützung". Den Chipsatz geben die leider nicht raus. Bei Käuferrezensionen versuche jmd zu erwischen, der mir freundlichweise die idProduckt=xxxx ausliest. Die Hersteller und Verkäufer sind nicht kooperationsbereit.


    Wer hat mir ein USB-modem, das von Linux unterstützt wird?

    Hier die Chipsätze, die connexant von Linux unterstützbar gemacht hat: http://linuxant.com/drivers/dgc/index.php


    Das idProduct=1300 ist seit 16 jahren nicht unterstützt: https://hsflinux.mbsi.narkive.…-1300-and-chip-cx06836-11


    danke an alle hier! :)

    Edited 5 times, last by egerlach ().

  • ist an der Chip Bestückung zu sehen, MAX232 ab 4,5V nur MAX3232 laufen mit 3,3V

    auf dem Chip im aufgeschraubten Modem steht: GD 75 232D . Die "D" sind vielleicht keine solchen, die sehen aus wie "I" und umgedrehtes "C" mit einem dünnen Abstand, als wie ein D mit 2x unterbrochener Farbe direkt bei dem "I"

    @absichern mit widerstand 470Ohm, dann mit Dioden ableiten ... kapiere ich nicht auf den ersten Blick. Wenn es so aufwändig wird, dann halte ich mal nach anderen alternativen Ausschau als alte Modems an einer RS232 zu betreiben.



    Alternative USB-seriell-Adapter:

    @ wer hat eine Idee was dem USB-seriell-Adapter fehlt, das Modem direkt vor Versand eines Fax zu initialisieren? Siehe mein posting oberhalb! Was könnte zeitkritisch sein, was ist beim USB-seriell-Adapter vielleicht anders als bei einer echten seriellen Schnittstelle?

    Eigentlich kann es nur eine Kleinigkeit sein, denn:

    1. wählen tut es , mit minicom atd 123456 ... geht!

    2. Das modem wird von faxaddmodem (Befehl von hylafax) perfekt erkannt, ausgelesen, getestet auf Geschwindigkeit etc.

    wer hat eine Idee?

    Übrigens: bei dem USB-seriell-Adapter (USB 1.1) habe ich schon den "guten" da, den mit dem fti-Chipsatz oder so ähnlich. USB-seriell als USB 2.-Adapter geht genauso wenig.


    Ich vermute elektrische Effekte, die hylafax daran hindern, das Modem vor einem Faxversand zu "initialisieren": Habe vor Jahren beruflich versucht über einen USB-seriell-Adapter die Daten "Vorname, Name und Nummer" für EKG (Gerät, Medizin) zu übertragen. Ging nicht! Nur diese paar Zeichen zu übertragen schlug fehlt, nichts zu machen, Laptop als Aufnahmegerät für EKGs nicht geeignet, weil keine serielle Schnittstelle. Vermultich war eine besonders "schlaue" Programmierung des Herstelles "Schiller" daran "schuld". Ansonsten tönte es vor 10 Jahren überall: USB-seriell geht auch. In vielen Fällen hat es auch geklappt.

    Edited 8 times, last by egerlach ().

  • auf dem Chip im aufgeschraubten Modem

    moment mal, hier läuft gerade was fürchterlich schief!:wallbash:


    Das fing doch mal an mit:

    ich will am raspi über ein RS232-Modul

    und von DEM Modul rede ich, ob der 5V oder 3,3V benötigt!:denker:

    Was ist da mit aufschrauben?:conf:


    Ich glaube ich bin urlaubsreif, oder versammeln sich hier nun Trolle?

    Die Fragen werden immer merkwürdiger und jegliche Kommunikation wird zur Farce.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Hab nochmals nachgeschaut, dieses Modul auf deinem Bild, müsste eine Ladungspumpe im Chip eingebaut haben, vermutlich einem MAX232 und müsste dann als normale Serielle Schnittstellen durchgehen und somit mit deinem seriellen Modem funktionieren.

    Allerdings wundert mich die 2. Stromversorgung durch die Micro USB-Buchse auf dem Bild etwas, was aber auch auf 5V Spannungsversorgung hinweist.

  • Versuch es mit einem FTDI USB-RS232 Adapter und keinem PL230x, läuft bei mir am PI mit einem US-Robotics 56K Faxmodem einwandfrei.

    Die PL230x zicken nur rum. Umstieg auf FTDI war die Lösung.

    Ist einfacher wie das GPIO gefrickel, auch wenn es Spaß macht ;)

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

  • MAX232

    http://www.ti.com/lit/ds/symlink/max232.pdf

    VCC Supply voltage 4.5 - 5.5V

    ist eben nicht für den PI geeignet, schrieb ich bereits!


    wenn dann nur der MAX3232 mit VCC 3,3V


    Frage an Thomas H, warum antwortest du nicht hilfreich?


    Was soll ein Chip am PI der nicht mit 3,3V arbeitet ohne Pegelwandler am PI wenn er doch Signale ausgibt die in der Nähe seiner VCC liegen und der PI nicht mehr als seine VCC 3,3V verträgt?

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Versuch es mit einem FTDI USB-RS232 Adapter und keinem PL230x, läuft bei mir am PI mit einem US-Robotics 56K Faxmodem einwandfrei.

    Die PL230x zicken nur rum. Umstieg auf FTDI war die Lösung.

    Ist einfacher wie das GPIO gefrickel, auch wenn es Spaß macht ;)

    Aha!!! Mit US-robotics habe ich vor 15 Jahren nur schlechte Erfahrung mit hylafax. Viele Modelle liefen nicht, mit elsa microlink alle, daher habe ich US-robotics aufgegeben. Habe nur Adapter mit FTDI-Chipsatz. Bitte scheibe mir mal was genau für ein robotics Modell Du hast, das wäre DIE LÖSUNG! Und Du setzt auch hylafax ein? - Es wäre ja ein "dickes Ding" wenn nur Elsa Microlink Modems mit dem Seriell-Adapter ein Problem haben ...


    @ stelle gerade fest, dass alle meine USB-seriell-Adapter hier NICHT FTDI sind ... uahhh ... eventuell habe ich immer mit denen rumgemacht ... obwohl ich das mit dem FTDI-Chipsatz wusste ... grübel ... Habe jetzt einen FTDI bestellt, vermutlich funktioniert dann auch das Elsa-Modem. Das wäre ja eine Überraschung ... gleich mehrere auf einmal ... :)

    Edited once, last by egerlach ().

  • mit dem Seriell-Adapter

    interessiert es nicht was auf dem bestückt ist?


    OK dann bin ich raus.

    Du suchst Fehler, willst Hilfe aber antwortest nicht?

    Welcher Chip ist auf deinem Modul aus Beitrag #1 verbaut?

    http://aiai.de/foren/rs232-raspberry.jpg

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Aha!!! Mit US-robotics habe ich vor 15 Jahren nur schlechte Erfahrung mit hylafax. Viele Modelle liefen nicht, mit elsa microlink alle, daher habe ich US-robotics aufgegeben. Habe nur Adapter mit FTDI-Chipsatz. Bitte scheibe mir mal was genau für ein robotics Modell Du hast, das wäre DIE LÖSUNG! Und Du setzt auch hylafax ein???

    Nein, ich hab kein hylafax.

    Ich wollte damit nur sagen dass ein einfacher FTDI USB Adapter deine Probeme lösen könnte da dieser bei mir mit einem Modem ohne Probleme läuft.

    Die ganze Pegelgeschichte kann man sich dann sparen. Das erledigt der Adapter, recht zuverlässig. Auch bei Verbindungen zu Consolen von Routern/Switchen etc hab ich damit keinerlei Probleme.

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

  • Nein, ich hab kein hylafax.

    Ich wollte damit nur sagen dass ein einfacher FTDI USB Adapter deine Probeme lösen könnte da dieser bei mir mit einem Modem ohne Probleme läuft.

    Die ganze Pegelgeschichte kann man sich dann sparen. Das erledigt der Adapter, recht zuverlässig. Auch bei Verbindungen zu Consolen von Routern/Switchen etc hab ich damit keinerlei Probleme.

    Könntest Du noch genau den Typ von US Robotics Modem durchgeben, den Du erfolgreich verwendes? (oben habe ich schon ergänzt: ich hatte wohl doch immer nur diese PL230X-Adapter im Einsatz ... obwohl ich von dem FTDI wusste ... ) Habe jetzt Hoffnung endlich eine Lösung gefunden haben für Fax

  • Da er ja nur ein kleines Bilder seiner Seriellen Erweiterung eingestellt hat, weis ich nicht genau, was da für ein Chip drauf ist.

    Wenn es ein MAX3232 wäre, was soll dann diese Extra 5V Versorgung über die Micro USB-Buchse?

    Denn die brauchen herkömmlich Adapter eben nicht.

    VCC, GND, TXD0, RXD0, mehr ist da nicht nötig, bei den Erweiterungen, die ich im Netz sah, die sind alle mit 4-poliger Stiftleiste und ohne zusätzliche Stromversorgung.

    Nicht dass er da ein falschen Serielles Modul erwischt hat!

  • Da er ja nur ein kleines Bilder seiner Seriellen Erweiterung eingestellt hat, weis ich nicht genau, was da für ein Chip drauf ist.

    ich weiss es auch nicht, deswegen fragte ich ja, aber eine Antwort bekam ich nicht!

    Das dumme ist bei "Echten" Seriellen Anschlüssen, das sie mit -12V/+12V laufen!

    sind "serielle Anschlüsse" die nicht nach V24 laufen keine echten seriellen Anschlüsse?

    fragte ich auch!

    vermutlich einem MAX232

    kennst du nur den?

    Alle meine Module sind mit MAX3232 weil ich eben darauf achtete das sie mit 3,3V laufen

    https://www.ebay.de/itm/MAX323…-DB9-MAX232-/263891823855


    Dieser Händler bewirbt einen MAX232CSE Transfer Chip der eigentlich nicht geeignet wäre wobei das Bild aber einen 3232 zeigt.

    https://www.ebay.de/itm/RS232-…hip-Atmega-9/352785991277


    ist halt typisch, da werden irgendwelche Bilder gezeigt, was man wirklich bekommt weiss man fast NIE

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)