Relaiskarte mit glimmenden LEDs

  • Guten Abend zusammen,


    bei der in den beiden Bildern darstellten Relaiskarte glimmen nach dem Einstecken des Netzteils des Raspberrys die LEDs schwach, ohne dass ein Skript ausgeführt wird (kein Zugriff auf die Relaiskarte). Dies passiert aber nur, wenn das Netzteil eingesteckt wird. Während die LEDs glimmen, sind die Relais nicht angezogen. Wenn Software-seitig die GPIO-Ausgänge auf HIGH gesetzt werden gehen die LEDs aus und das in Python geschrieben Skript funktioniert tadellos. Wenn das Raspberry anschließend mit sudo reboot neu gestartet wird, glimmen die LEDs nicht auf.


    Hat jemand eine Idee wieso das so ist?


    Vorab vielen Dank und einen schönen Restsonntag.


    whitechristmas

  • Hallo Fliegenhals,


    vielen dank für Deine Rückmeldung. Die GPIOs sind wie folgend programmiert:


    Code
    [...]
    GPIO.setmode(GPIO.BOARD)
    GPIO.setup(16, GPIO.OUT)
    GPIO.setup(18, GPIO.OUT)
    GPIO.setup(22, GPIO.OUT)
    GPIO.setup(32, GPIO.OUT)
    GPIO.setup(29, GPIO.IN, pull_up_down=GPIO.PUD_DOWN)
    [...]

    VG whitechristmas

  • Ich tippe da eher auf ein Verkabelungsproblem. Kannst du mal zeigen, wie du verkabelt hast? Wenn ich das richtig sehe, hast du den Jumper Vcc-JDVcc gesetzt. Dann hängt bei dir womöglich Vcc und damit alles an 5 V und die gehen auf die 3,3-Volt-Eingänge des Pi. Das wäre nicht so gut...

    Du musst JDVcc mit 5 Volt und Vcc mit 3,3 Volt verbinden. Allerdings ist das auch nicht ideal, weil 3,3 V eigentlich zu wenig für den Steuerkreis sind.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

    • Official Post

    Hallo whitechristmas!


    Du kennst Wie frage ich nach Hilfe??! ;)


    GPIO 29 hat, im Gegenteil zu anderen, bis zur Initialisierung durch ein Programm, keinen voreingestellten Pull-up/down.

    Ich frage mich gerade wer nun in die falsche Reihe gerutscht ist, dort https://www.raspberrypi.org/do…/rpi_DATA_CM3plus_1p0.pdf oder da https://de.pinout.xyz/pinout/pin28_gpio1#. :conf:

  • Frage mal in einen Amateurfunkforum oder CB Forum die arbeiten laut eigener aussage immer mit Relais.

    Du solltest hier keine Leute veräppeln.


    Gibt es eine Bezeichnung für die Relaiskarte. Ich sehe da sowohl Optokoppler als auch Transistor auf der Platine. Je nachdem, wie die geschaltet sind, kann es beim ersten Start durch die hohe Verstärkung der Transitoren durchaus zum Glimmen kommen, falls die LEDs hinter den Transistoren sitzen. Die BCM-Chips reagieren beim Reboot anders als beim Start nach erstmaliger Stromzufuhr, weil der Chip mit Spannung versorgt bleibt.

    • Official Post

    Na gut, einen noch... Was hat ein WLAN-Repeater mit den o.g. Relais gemeinsam, außer das man beide ggf. im selben Elekronikfachmarkt kaufen kann?


    Wie sollen Deine Beiträge also dem TO weiterhelfen?


    //Edit


    Hätte ich doch fast vergessen... Ein Hering ist immer ein Zeltnagel.


    ><((((*>

  • Frage mal in einen Amateurfunkforum oder CB Forum die arbeiten laut eigener aussage immer mit Relais.

    Ein Relai ist immer ein immer ein Fernbedienter Schalter.

    ja und, was hat das mit dem Problem vom TO zu tun?

    Wifi Scanner?


    mir reichts jedenfalls mit deinen dümmlichen Aussagen.


    Es ist schnurzpiep egal wer wo und warum Relais benutzt, nur müssen diese gerade am PI richtig angeschaltet werden und funktionieren sehr selten bis nie wenn sie für Arduino designed wurden!

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • man kann sich auch einen Knopf an die Backe nähen und ein Klavier anhängen um zu merken wie schwer Musik ist.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Ich sehe da sowohl Optokoppler als auch Transistor auf der Platine. Je nachdem, wie die geschaltet sind, kann es beim ersten Start durch die hohe Verstärkung der Transitoren durchaus zum Glimmen kommen, falls die LEDs hinter den Transistoren sitzen.

    Kaum anzunehmen. Dieses Relaismodul wird mit allergrößter Wahrscheinlichkeit die "Standard"-Beschaltung haben.
    - Vcc über 1000 Ohm, Optokopplereingang und Status-LED an GND.
    - Optokoppler-Ausgang an Transistor-Basis.
    - JD-Vcc über Transistor und Relaisspule (mit Freilaufdiode parallel) an GND.

    Ich tippe nach wie vor drauf, dass der TO Vcc UND JD-Vcc mit 5 Volt versorgt hat. Gegen die 3,3 Volt des GPIO im HIGH-Zustand bleiben dann 1,7 Volt übrig, die das Glimmen der Status-LEDs bewirken. Im LOW-Zustand fallen ca. 3 Volt an Status- und Optokoppler-LED ab, den Rest schluckt der Pi.

    Ob der Pi das lange überlebt, ist fraglich.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Ich tippe nach wie vor drauf,

    ich auch, typische für den PI falsche Arduinoanschaltung!

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Q1, Q2 ... sind Transistoren. Neuere Karten haben einen Transistor vor dem Optokoppler, so dass man ab ca. 2V schalten kann. Ich habe auch schon Karten gesehen, da war der Transistor sinnloserweise hinterm Optokoppler. Das ist aber auf den Bildern nicht zu identifizieren.