PI 3b+ Startprobleme

  • Hallo liebe Raspberry Community,


    heute ist mein Pi angekommen und schon hab ich die ersten Probleme die mich seit Stunden ärgern..

    ich bekomme das WLAN nicht zum laufen..


    ich habe die Datei "ssh" ohne Dateiendung erstellt.

    ich habe in Notepad++ ein Dokument mit dem Namen „wpa_supplicant.conf" und folgenden Text erstellt:


    country=DE

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

    update_config=1


    network={

    ssid="WLAN SSID"

    scan_ssid=1

    psk="WLAN PASSWORT"

    key_mgmt=WPA-PSK

    }


    WLAN SSID und WLAN PASSWORT habe ich durch meines ersetzt, und die Datei mit Linux Zeilenende versehen.


    so weit so gut, stecke ich jetzt die Speicherkarte in meinen PI und danach wieder in meinen Laptop weil im Router der Pi nicht erkannt wird sind die beiden erstellten Dateien die ich in das Laufwerk boot(D:) geschoben hatte weg.


    Ich bitte um Hilfe :):danke_ATDE::danke_ATDE:


    liebe Grüße,


    Ivan

  • Moin SeiberIvan,


    erstmal: Herzlich Willkommen im Forum!


    Du hast dir als Betriebssystem "Raspbian" ausgewählt?


    Die grüne Led hat auch ordentlich geflackert?



    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin SeiberIvan,


    da die Dateien "ssh" und "wpa_suplicant.conf" verschwunden sind, scheint es ja richtig zu laufen.

    Neben dem Verschieben der Dateien und einrichten der beiden Prozesse, wird auch das Vergrößern der root-Partition angestossen.

    Danach erfolgt ein Restart, damit die Vergrößerung durchgeführt werden kann. Erst dann kannst du zugreifen.

    Das kann schon 2-3 Minuten dauern.

    Ein Hinweis: Die oben genannten Dateien werden nur bei einer Neuinstallation berücksichtig.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    • Official Post

    Hallo SeiberIvan,


    willkomen im Forum!

    weil im Router der Pi nicht erkannt wird

    Du meinst, die IP des oder der RPi taucht da nicht auf oder?


    So what! ;) Das ist manchmal so.


    Also wo ist Dein Problem? Kannst Du evtl. nicht per SSH darauf zugreifen? Dann verwende den Standardhostnamen raspberrypi anstelle der IP.

  • Quote

    da die Dateien "ssh" und "wpa_suplicant.conf" verschwunden sind, scheint es ja richtig zu laufen.

    Neben dem Verschieben der Dateien und einrichten der beiden Prozesse, wird auch das Vergrößern der root-Partition angestossen.

    Danach erfolgt ein Restart, damit die Vergrößerung durchgeführt werden kann. Erst dann kannst du zugreifen.

    Das kann schon 2-3 Minuten dauern.

    Ein Hinweis: Die oben genannten Dateien werden nur bei einer Neuinstallation berücksichtig.

    was meinst du mit erst dann kann ich zugreifen? Ohne IP kann ich doch garnicht auf den PI zugreifen?


    Quote

    Du meinst, die IP des oder der RPi taucht da nicht auf oder?


    So what! ;) Das ist manchmal so.


    Also wo ist Dein Problem? Kannst Du evtl. nicht per SSH darauf zugreifen? Dann verwende den Standardhostnamen raspberrypi anstelle der IP.

    genau, was ich machen will ist über die SSH auf den Desktop kommen..

    ich habe es erst mit einem DHCP Server und Putty versucht..

    Bei Putty bekam ich dann immer "Network Error - Connection refused" also dachte ich mir, dass ich mir ja eigentlich den DHCP Server sparen kann?

    Ich hoffe ich habe nichts durcheinander gebracht..


    gebe ich jetzt bei Putty statt der IP Adresse raspberrypi ein kommt "Unable to open connection - to raspberrypi - host does not exist "


    lg Ivan

  • gebe ich jetzt bei Putty statt der IP Adresse raspberrypi ein kommt "Unable to open connection - to raspberrypi - host does not exist "

    Dann hat es mit der WlAN Aktivierung warscheinlich nicht geklappt.

    Wenn du ein Lankabel hast, versuche es einmal damit. Wenns dann klappt, dann kannst du WLAN per raspi-config aktivieren

  • Moin SeiberIvan,


    was meinst du mit erst dann kann ich zugreifen? Ohne IP kann ich doch garnicht auf den PI zugreifen?

    Nein, ich meine, das du dem Raspberry die Zeit geben sollst.

    Dann kannst du ja in den DHCP-Server schauen, ob eine IP vergeben wurde.

    Zur Not kannst du ja mal ein Lankabel anstecken. Dann sollte SSH schon mal gehen.

    ich habe es erst mit einem DHCP Server und Putty versucht..

    Soll das heißen, du hast keine Wlan-Router, sondern nur einen DHCP-Server?


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Quote

    Soll das heißen, du hast keine Wlan-Router, sondern nur einen DHCP-Server?

    als der Pi heute ankam hab ich in der Euphorie erst mal vergessen, dass er WLAN hat und erst mal ein LAN-Kabel angeschlossen. HAHA


    Quote

    Zur Not kannst du ja mal ein Lankabel anstecken. Dann sollte SSH schon mal gehen.




    ich habe jetzt das Lankabel angeschlossen in Putty als IP-Adresse "raspberrypi" eingegben und es funktioniert :):)


    oh fucking yeah, das ist schon mal cool ! Danke für eure Hilfe !!!!!



    Jetzt ist mein nächstes Problem, wenn ich über die Remotedesktop Verbindung zum Desktop des Pis will kommen Fehlermeldungen wenn ich dort auch "raspberrypi" statt einer IP-Adresse eingebe?

  • Jetzt ist mein nächstes Problem, wenn ich über die Remotedesktop Verbindung zum Desktop des Pis will kommen Fehlermeldungen wenn ich dort auch "raspberrypi" statt einer IP-Adresse eingebe?

    du musst vnc aktivieren



    ich habe jetzt das Lankabel angeschlossen in Putty als IP-Adresse "raspberrypi" eingegben und es funktioniert :):)


    oh fucking yeah, das ist schon mal cool ! Danke für eure Hilfe !!!!!

    wo ist da das Problem gelöst? WLAN geht doch immer noch nicht?!

  • Moin SeiberIvan,


    du solltest nun zwingend die Einrichtung deines Raspberry's machen.


    Wie bist du nun verbunden? SSH und Putty? Ist dein Rechner ein Windows10?


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin SeiberIvan,


    lass dich nicht vom Weg abbringen! Ignoriere erstmal die Zwischenrufe.

    Wir kommen auch so zum Ziel.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Quote

    wo ist da das Problem gelöst? WLAN geht doch immer noch nicht?!

    noch nicht, aber die SSH funktioniert, das freut mich schon mal ;)


    Quote

    Wie bist du nun verbunden? SSH und Putty? Ist dein Rechner ein Windows10?

    ja und ja


    Quote
    • Für eine Remotedesktopverbindung muss er xrdp installieren
    Code
    sudo apt-get install xrdp

    ok, hab ich gemacht, trotzdem brauche ich noch vnc oder?




    Quote

    du solltest nun zwingend die Einrichtung deines Raspberry's machen.

    ich lade mir jetzt den vnc und komme dann hftl auf den Desktop des Pis und kann dann das WLAN einrichten

  • lass dich nicht vom Weg abbringen! Ignoriere erstmal die Zwischenrufe.

    :stumm:sry bin schon still

    Für mich hatte sich sein post nur so gelesen, als ob er das Problem mit dem WLAN einfach abhacken würde weil es mit LAN ja nun läuft.

  • Moin SeiberIvan,


    Windows10 kann von Haus aus SSH. Du brauchst kein Putty. Einfach in einem CMD-Fenster oder Powershell-Fenster ssh eingeben reicht.


    Wenn du via ssh verbunden bist, dann bist du mit sudo raspi-config in den Einstellungen.

    Dort, bitte, das Passwort ändern und die lokalen Einstellungen. Tastatur, Sprache, Uhrzeit usw. einrichten.

    Dabei kannst du auch VNC aktivieren.

    Du musst dann aber auf deinem Rechner noch den VNC-Viewer installieren. Einfach mal im Inet suchen.

    Kannst dich ja wieder melden, wenn du durch bist. Ansonsten, für heute ist Schulz...


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Quote

    Windows10 kann von Haus aus SSH. Du brauchst kein Putty. Einfach in einem CMD-Fenster oder Powershell-Fenster ssh eingeben reicht.

    ok, das ist natürlich cool !


    Quote

    Wenn du via ssh verbunden bist, dann bist du mit sudo raspi-config in den Einstellungen.

    Dort, bitte, das Passwort ändern und die lokalen Einstellungen. Tastatur, Sprache, Uhrzeit usw. einrichten.

    Dabei kannst du auch VNC aktivieren.

    Du musst dann aber auf deinem Rechner noch den VNC-Viewer installieren. Einfach mal im Inet suchen.

    Kannst dich ja wieder melden, wenn du durch bist. Ansonsten, für heute ist Schulz...

    alles erledigt, nur das WLAN will noch nicht so..



    DANKE für eure Hilfe und schlaft gut, bis morgen :)


    Ivan

  • alles erledigt, nur das WLAN will noch nicht so

    Guten Morgen,


    solltest Du RDP nach den Tipps hier installiert haben, dann wirf den Plunder erst einmal wieder herunter. Wenn VNC funktioniert, brauchst Du das nicht, insbesondere deshalb, weil es vielleicht nicht so funktioniert, wie Du denkst.

    Dein WLan kannst Du, wo Du ja jetzt schon einmal über Lan per VNC auf den pI kommst, mit der grafischen Oberfläche einrichten. Dazu gibt’s das Symbol oben mit den beiden Pfeilen. Klick drauf und folge den Anweisungen. Das fällt Dir evt. leichter, als mit Textdateien zu hantieren.

  • Moin SeiberIvan,


    meinem Vorschreiber STF kann ich nur zustimmen.

    kannst dich ja melden wenn du per VNC auf den Raspberry kommst.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.