Raspberry Zero mit Kamera V2.1 kein Video über myfritz und MotionEye

  • Hallo,


    habe einen Raspberry Pi Zero mit der Kamera V2.1 und der Software MotionEye.

    Dieser ist über einen UniFi AP-AC-Lite WLan-Router, mit der Fritzbox verbunden.


    In der Fritzbox habe ich myfritz eingerichtet und für die Kamera eine Portweiterleitung eingerichtet. In der Fritzbox habe ich festgelegt, dass der Raspberry immer dieselbe IP bekommt. In MotionEye habe ich den selben Port eingetragen wie in der Fritzbox für die Portweiterleitung.


    Bisher hat es so ohne Probleme funktioniert.

    Weil die Fritzbox defekt war habe ich eine neue Fritzbox (7590) gekauft und neu eingerichtet.



    Jetzt wir mir das Bild bzw. Stream der Kamera nicht mehr angezeigt (über Browser Firefox, wenn ich über abcdefghijk.myfritz.net darauf zugreife. Ich kann über die myfritz-Adresse auf die Fritzbox zugreifen und ich kann auch auf die Kamera zugreifen und Einstellungen vornehmen. Ein Bild/Stream wird wie gesagt aber nicht angezeigt. Es dreht sich eine Zeit lang in der mitte vom Browser ein "Suchsymbol" und danach wird ein Symbol einer durchgestrichenen Kamera angezeigt.


    Wenn ich aber über (aus dem Heimnetzwerk) die Ip-Adresse:Port vom Raspberry darauf zugreife funktioniert auch der Stream/Video.


    An welcher Einstellung kann es liegen?


    Habe es mal mit und mal ohne "Selbstständige Portfreigaben für dieses Gerät erlauben." in den Einstellungen bei der Fritzbox bei den Freigaben probiert.


    Danke

    Grüße


    Roogy

  • Hi Roogy,


    1. ist der UniFi AP-AC-Lite WLan-Router reiner Accesspoint oder macht der sonst noch was? (DHCP, etc?)


    2. Wie sieht die Freigabe in der Fritzbox genau aus? Welche Ports sind dort offen?


    3. Was sagt die Ausgabe von ss -alutn in einer Bash auf dem Raspberry PI?

  • Hallo Juppi,

    1. der UniFi wird als reiner Accesspoint genutzt. Dort ist "DHCP verwenden" eingestellt.

    An der Fritzbox ist auch DHCP für den IP-Berich xxx.100 bis xxx.200.

    Meinen Geräten habe ich in der Fritzbox allen eine Feste IP zugewiesen im Bereich xxx.002 bis xxx.99

    Am UniFi habe ich nichts verändert und hat vor dem Tausch der Fritzbox funktioniert.


    2. Nach der Neueinrichtung habe ich nur den Portfreigabe für die Kamera eingerichtet.

    Protokoll ist TCP

    "Port an Gerät", "bis Port", "Port extern gewünscht (IPv4)" ist überall derselbe Port eingetragen z.B. 8081

    Wie bereits geschrieben habe ich einmal mit der Einstellung "Selbstständige Portfreigaben für dieses Gerät erlauben." und einmal ohne dieser Einstellung es versucht.


    3. Hier weiß ich nicht genau was Du meinst?

  • Hi Roogy,


    Zu 1. Kannst du mal DHCP an UniFi abschalten, sodass der PI eine Adresse von der Fritzbox bekommt?


    Zu 2. Kannst du mal einen Screenshot von den Einstellungen machen?


    Zu 3. Wenn du per SSH auf dem PI bist oder eine Kommandozeile offen hast, dann zeigt dir der Befehl ss -alutn alle offenen Ports.

    Edited once, last by SpringWildflower59805 ().

  • Hi Juppi,

    1.

    ich habe bei der UniFi nur die Auswahl "DHCP verwenden" oder "Statische IP-Adresse".

    Eigentlich hätte ich geadacht, so wie ich es eingerichtet habe, bekommt der UniFi sowieso eine feste IP-Adresse von der Fritzbox?


    Unter Netzwerkverbinungen haben ich es so eingestellt, dass die UniFi immer dieselbe IP-Adresse bekommt (durch die MAC-Adresse).


    Sowohl der UniFi selber als auch der Raspberry, auf den der Controller für die UniFi läuft. Sorry, dass mit dem Controller habe ich vergessen zu erwähnen. Brauche ich für Smarthome.


    2.

    Als Anlage


    3.

    Den Befehl wahrscheinlich mit SSH auf den "UniFi-Contoller" ausführen?


  • Hallo Roogy,


    Zu 1: Ne, dann hat sich das erledigt. Dachte der UniFi ist DHCP Server.


    Zu 2: Kannst du nur mal kurz zum Test die Einstellung "Dieses Gerät komplett für den Internetzugriff über IPv4 freigeben (Exposed Host)" aktivieren und schauen, ob du dann von extern Bild hast? Wenn ja, dann brauchen wir nur die Info aus Punkt 3, welche Ports wir dann Freigeben müssen.


    Zu 3: Nein, per SSH auf dem Raspberry PI.

  • Zu 2:

    Wenn ich die Einstellung "...über IPv4 freigeben..." aktivieren funktioniert das Bild.


    Es wird aber eine Warnmeldung angezeigt:

    "Achtung: Ein komplett freigegebenes Gerät ist ungeschützt im Internet sichtbar und erreichbar. Für dieses Gerät ist der Firewall-Schutz Ihrer FRITZ!Box deaktiviert."

    zu 3:

    Wenn ich den Befehl (in Putty) auf den Raspberry mit der Kamera eingebe kommt folgende Meldung:

    -sh: ss: command not found


    Hab nach den Befehl ss gesucht und gesehen, dass es auch netsat gibt. Dieser funktioniert. Was muss ich hier eingeben?

    Bei nur netstat werden verschiedene Einträge zu den Ports angezeigt.


    Kann ich dies alles hier Posten oder sind da auch Dinge dabei, die ich im Internet besser nicht preis geben sollte?




    Das Komische an der Sache ist nur, dass mit der alten Fritzbox alles ohne Probleme funktioniert hat.

    Dort habe ich auch nur den Port in den Freigaben weitergeleitet.

    UniFi und die Kamera sind unverändert geblieben. Ist die Firewall in der neuen Fritzbox anders aufgebaut?

  • Zu 2: Sehr gut! Dann müssen wir nur noch die richten Ports finden. Die Meldung ist auch korrekt. Die Einstellung ist ja nur zum testen.


    Zu 3: Sry. Dachte den Befehl ss gibt es unter Raspbian. Dann probier mal mein sudo netstat -tulpn


    Kannst du hier posten.

  • Ich frage mich nur, warum es mit der "alten" Fritzbox 7390 funktioniert hat und mit der 7590 nicht?


    Der Befehl gibt folgendes aus:



  • Ich weiß nicht, warum.


    In dem Screenshot sehen wir nun, dass streameye auf Port 8081 "lauscht". Protokoll ist TCP.

    Also trag mal bitte diese Freigabe in der Fritzbox ein.


    Was das zweite mit python auf TCP Port 8085 ist, weiß ich nicht. Wenn der Video-Stream nach oben genannter Freigabe immer noch nicht funktioniert, kannst du den TCP Port 8085 zum Test ja auch mal freigeben.


    Wenn alles nix hilft, dann kannst du mal noch folgende Anleitung von AVM durchgehen:

    https://avm.de/service/fritzbo…e-auf-FRITZ-Box-Heimnetz/

    Edited once, last by SpringWildflower59805 ().

  • Danke schon mal für Deine bisherige Geduld und sorry, dass ich so viele Fragen habe.


    Einen Teilerfolg habe ich. Bis auf eine Unklarheit bei "Einstellung 1"


    Ich zeige nochmal zwei weitere Screenshots der Einstellungen von motioneye.


    Bei "Expert Settings" ist bei HTTP 8085 eingetragen.

    Ganz unten ist bei "Streaming URL" 8081 eingetragen (habe ich übersehen)

    Anscheinend werden zwei Ports benötigt


    Einstellung 1:

    Hab jetzt in der Fritzbox mal nur 8081 freigegeben.

    Wenn ich jetzt über die xxx.myfritz.net:8081 im Browser eingebe, wird mir gleich der Stream (in der Mitte vom Bildschirm) angezeigt.

    Wenn ich jetzt xxx.myfritz.net:8085 im Browser eingebe, wird der Loginbereicht angezeigt und nach erfolgten Login der Stream (oben links) und ich kann auch die Einstellungen auswählen.

    Warum funktioniert es trotzdem? den Port 8085 habe ich in der Fritzbox ja nicht freigegeben.


    Einstellung 2:

    Hab jetzt in der Fritzbox mal nur 8085 freigegeben.

    xxx.myfritz.net:8085 funktioniert wie vorher und Bild wird angezeigt

    xxx.myfritz.net:8081 Bild wird nicht angezeigt.


    Einstellung 3:

    Hab jetzt in der Fritzbox mal nur 8085 und 8081 freigegeben.

    xxx.myfritz.net:8085 funktioniert wie vorher und Bild wird angezeigt

    xxx.myfritz.net:8081 Bild wird angezeigt.



    Ist das Verhalten normal? Vor allem bei Einstellung 1? Wie kann es sein, dass der Port funktioniert, obwohl er in der Fritzbox nicht weitergeleitet ist?

  • Wo (d. h. an welchem Internetanschluss) befindet sich das Gerät mit dem Browser, in dem Du xxx.myfritz.net:8085 eingegeben hast?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Mit MotionEye und dessen Einstellungen kenne ich mich leider nicht aus, aber Einstellung 2 hört sich ja gut an.


    xxx.myfritz.net:8085 ist der Port von außen. Da könntest du auch xxx.myfritz.net:50000 drauß machen. Worauf wird den der Port weitergeleitet?


    Wichtig ist nur, dass niemand ohne Authentifizierung dein Bild sehen kann.

  • Worauf wird den der Port weitergeleitet?

    Lt. TE im Beitrag #11, wird der Port 8085 nicht weitergeleitet:

    Quote


    Wie kann es sein, dass der Port funktioniert, obwohl er in der Fritzbox nicht weitergeleitet ist?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Habe es jetzt nochmal getestet.

    Kann es sein, dass die Fritzbox etwa Zeit benötigt, die Einstellungen zu übernehmen?


    Jetzt denke ich funktioniert es richtig. Wenn ich nur den Port 8081 freigegeben habe kann ich nur das Bild bzw. den Stream sehen, Wenn ich zusätzlich den Port 8085 freigegeben habe kann ich auch nach dem erfolgten Login zu den Einstellungen.


    Der Port 8081 wird weitergeleitet nach Port 8081. Passt das?




    Wie meinst Du das mit "niemand ohne Authentifizierung"?

  • Wie meinst Du das mit "niemand ohne Authentifizierung"?


    Das heißt es soll niemand, der deine Adresse, bzw. externe IP kennt, auf xxx.myfritz.net:8081 dein Kamerabild zugreifen können. Ist ja mit einem Passwort geschützt, oder?