Raspberry Pi Zero W Rev 1.1 (512MB) keine Verbindung ins Internet

  • Hallo,

    Achtung Neuling mit dem Raspberry.

    Ich habe einen Raspberry Zero mit Modem für Amateurfunk im Einsatz.(MMDVM Hotspot mit Software von Pi-Star)

    Das funktioniert per Wlan oder Lan im Heimnetz mit Fritzbox 7490 einwandfrei.So wie es sein sollte.


    Aber im Wohnwagen nicht.

    Ich habe einen Alfa Router R36 der per Usb eine Außenantenne hat mit der man auf dem Campingplatz weit entfernte Wlan Signale empfangen kann.(Alfa Camp Pro)

    Das klappt auch einwandfrei und wurde mehrmals an versch. Orten so verwendet.Alle Geräte haben Internetzugang(Handy,Tablet,Laptop....alles)

    Aber der Raspberry nicht.Ich kann mit allen Geräten per Wlan zum Router die Configseite vom Raspberry aufrufen (Pi-Star Image) alles wunderbar.

    Also Raspberry hat Wlan oder Lan Verbindung zum Router.Aber Internet will einfach nicht gehen.

    Ist das ein Raspberry Problem oder doch der Router?

    Ich habe jetzt schon einige Tage gegoogelt auch bei Funkamateuren die das System auch verwenden aber ohne Erfolg.

    Vielen Dank im voraus für einen Tip und bleibt gesund!!!!!

  • DH5SDL

    Changed the title of the thread from “Rasperry Pi Zero W Rev 1.1 (512MB) keine Verbindung ins Internet” to “Raspberry Pi Zero W Rev 1.1 (512MB) keine Verbindung ins Internet”.
  • Also Raspberry hat Wlan oder Lan Verbindung zum Router.Aber Internet will einfach nicht gehen.

    Ist das ein Raspberry Problem oder doch der Router?

    Wie sind auf dem Raspberry die Ausgaben von:

    Code
    route -n
    ip a
    ip n s
    cat /etc/resolv.conf
    ping -c 2 1.1.1.1
    host -t A heise.de 1.1.1.1

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hier soweit die Daten.....ich hoffe ich habe alles richtig gemacht!!!



    pi­star@pi­star(ro):~$ route ­n

    Kernel IP routing table

    Destination Gateway Genmask Flags Metric Ref Use Iface

    0.0.0.0 192.168.2.1 0.0.0.0 UG 202 0 0 eth0

    169.254.0.0 0.0.0.0 255.255.0.0 U 304 0 0 wlan0_ap

    192.168.2.0 0.0.0.0 255.255.255.0 U 202 0 0 eth0

    192.168.50.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0_ap

    pi­star@pi­star(ro):~$



    pi­star@pi­star(ro):~$ ip a

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

    valid_lft forever preferred_lft forever

    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500qdisc pfifo_fast state UP group default qlen 1000

    link/ether 00:e0:4d:3a:a6:89 brd ff:ff:ff:ff:ff:ff

    inet 192.168.2.100/24 brd 192.168.2.255 scope global eth0

    valid_lft forever preferred_lft forever

    3: wlan0: <NO­CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000

    link/ether b8:27:eb:0e:da:c4 brd ff:ff:ff:ff:ff:ff

    4: wlan0_ap: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether b8:27:eb:00:00:01 brd ff:ff:ff:ff:ff:ff

    inet 192.168.50.1/24 brd 192.168.50.255 scope global wlan0_ap

    valid_lft forever preferred_lft forever

    inet 169.254.195.153/16 brd 169.254.255.255 scope global wlan0_ap

    valid_lft forever preferred_lft forever

    pi­star@pi­star(ro):~$



    pi­star@pi­star(ro):~$ ip n s

    192.168.2.106 dev eth0 lladdr a0:88:69:5b:65:b7 DELAY

    192.168.2.1 dev eth0 lladdr 00:c0:ca:93:c3:58 REACHABLE



    pi­star@pi­star(ro):~$ cat /etc/resolv.conf

    # Generated by resolvconf

    domain alfa.com.tw

    nameserver 192.168.2.1

    pi­star@pi­star(ro):~$


    pi-star@pi-star(ro):~$ sudo ping ­c 2 1.1.1.1

    PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.

    64 bytes from 1.1.1.1: icmp_seq=1 ttl=57 time=65.8 ms

    64 bytes from 1.1.1.1: icmp_seq=2 ttl=57 time=29.1 ms

    ­­­ 1.1.1.1 ping statistics ­­­

    2 packets transmitted, 2 received, 0% packet loss, time 1000ms

    rtt min/avg/max/mdev = 29.128/47.507/65.886/18.379 ms

    pi-star@pi-star(ro):~$

  • Hi DH5SDL,


    kannst du mal noch ein ping -c 2 google.de machen ?


    Ich glaube deine DNS Einträge stimmen nicht. Wenn das der Fall ist, dann füge mal mit sudo nano /etc/resolv.conf folgende Zeilen zusätzlich ein


    nameserver 8.8.8.8

    nameserver 8.8.4.4

  • Code
    pi­star@pi­star(ro):~$ cat /etc/resolv.conf
    # Generated by resolvconf
    domain alfa.com.tw
    nameserver 192.168.2.1

    Wie ist die Ausgabe von:

    Code
    host -t A heise.de 192.168.2.1

    ?


    Wie kommt die "domain alfa.com.tw" in die resolv.conf? Hast Du diese konfiguriert bzw. irgendwo eingetragen?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Das habe ich nicht eingegeben.(domain alfa.com.tw)

    Ich verstehe halt einfach nicht warum alle anderen Geräte problemlos ins Netz kommen.

  • DH5SDL


    Das wird dort automatisch eingetragen.


    Kannst du bitte mal prüfen, ob die DNS Einstellungen korrekt sind? Also zum Beispiel ein ping google.de?

  • DH5SDL


    Das wird dort automatisch eingetragen.

    Ja, aber dieser Eintrag nur dann, wenn man nicht richtig konfiguriert, denn:

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Kurzes Update:

    Selbst ein neuer Router im Wohnwagen hat nichts gebracht.Keine Verbindung möglich vom Wlan Extender zu meinem Gastzugang zu Hause.(Wohnwagen steht im Garten daher habe ich diesen Weg gewählt)

    Dann habe ich mein Smartphone als Hotspot eingerichtet und konnte im Wohnwagen die gewünschte Verbindung herstellen.(über den Wlan Extender Alfa Camp Pro ins Mobilfunknetz,nicht zum Gastzugang)

    Ich denke das es an meinem Gastzugang liegt den ich zu Hause teilw. verwende bzw. für den Test genommen habe.

    Da geht irgendwie nur das eine Gerät nicht richtig ins Netz.

    Der nächste Test kommt später wenn ich mal mit dem Wohnwagen wieder reisen darf (Corona bremst mich leider aus)

    Danke an alle für die Hilfe und vor allem bleibt gesund!!!

  • Nur mal so als blöde Idee:

    Kann es sein, daß das WLan auf 5GHz funkt? Der Raspi0 kann nur 2,4GHz.

    bd. Alv