Retropie/Emulation Station bootet nicht mehr automatisch

  • Hallo,


    Folgendes Problem. Aus mir unbekannten Gründen bootet bei meinem LCL Pi Boy Emulation Station nicht mehr automatisch. Manuel komm ich rein in dem ich mit Tastatur den cmd "emulationstation" eintippe. Aber wie kann ich wieder einstellen, dass er ES automatisch bootet? Google konnte mir bisher nicht weiter helfen. Wäre sehr dankbar für Hilfe.


    PS... Bin ein noob was Raspberry Pi angeht:daumendreh2:

    • Official Post

    Du richtest einen Autostart für das Programm ein. Wenn du es modern und umständlich brauchst bau, dir ne systemd service unit. Beispiele findest du hier im Forum. Ich bin pragmatisch und würde es, wenn es funktioniert, über die rc.local starten.

  • Erstmal danke schon mal für die Antwort.


    Ist leider nur Fachchinesisch für mich. Ich hätte es wenn möglich so wenig umständlich wie möglich, weil wir gesagt... Ich habe keine Ahnung von Raspberry Pi. Das Gerät selbst hab ich fertig bekommen, bis vorhin hat es auch selbständig gebootet....

  • Also das Problem besteht nach wie vor und ich bin offensichtlich ein zu großer noob um es hin zu bekommen. Auch Google hat mich nicht zu einer brauchbaren Lösung geführt... Ich meine man findet bestimmt was aber ich bin wahrscheinlich zu dumm. Kp... Weiß nicht weiter. Vielleicht kann mir hier jemand Idiotensicher erklären wie ich nun Emulation Station beim anschalten des Gerätes wieder automatisch starten lassen kann.

    • Official Post

    Da ich das Gerät nicht kenne und ich nicht weiss welche User darauf existieren und wie die Berechtigungen aussehen hier die Holzhammer Methode

    Code
    sudo nano /etc/rc.local

    in der Zeile vor exit 0

    schreibst du emulationstation


    Speichern und beenden - > STRG + X, J (oder Y)


    neustarten.

  • Ich kenne das Gerät auch nicht, aber RetroPie lässt sich konfigurieren mit: sudo ./RetroPie-Setup/retropie_setup.sh. Ob das Skript bei dir vorhanden ist und wenn ja wo, kann ich nicht sagen. Autostart Konfiguration findet man unter "Configuration / tools" -> "autostart".

  • dbv

    Also wenn ich das mit rc.local probiere passiert... Nichts. Emulation Station startet weiter nicht automatisch. Beim booten des Gerätes zeigt er mir das an was man im angehängten Foto lesen kann.


    daxb

    Ins retropie Setup komme ich wie von dir beschrieben rein. Unter configuration / tools finde ich nur keine Autostart Option.


    Bin also nicht weiter wie vorher. Leider. Trotzdem recht vielen Dank für die Antworten.

    • Official Post

    zeigt er mir das an was man im angehängten Foto lesen kann

    Also zeigt "er" nichts an?! :fies:


    Etwas Mühe kannst Du Dir schon geben.




    Falls englisch auch chinesisch für Dich ist, gibt es Übersetzer https://www.deepl.com/translator oder https://translate.google.de/?hl=de ;)

  • Unter configuration / tools finde ich nur keine Autostart Option.

    Welche RetroPie Version benutzt du denn? Bei aktueller Version sieht es hier so aus:

    Vielleicht findest du den Autostart auch irgendwo anders, wenn du die Menüs durchgehst.

  • Auf selbiges bin ich bereits gestoßen. Hat zu keinem Erfolg geführt. Hab's genau so gemacht. Startet trotzdem nicht automatisch.


    Okay, also hab da alles durch geguckt. Nix.

    Wo zeigt er mir an welche Version ich hab?

  • sudo raspi-config

    To fix the auto-login configuration, go to 3 Boot Options, choose Desktop/CLI and finally choose the Console Autologin option. Go back to the main menu and choose Finish and Reboot your Pi.

    • Official Post

    Ein Würgaround könnte folgendes sein:

    Code
    nano ~/.bashrc

    und dort am Ende in eine neue Zeile

    Code
    emulationstation

    Ich habe aber auch kein Retropie und kann deshalb nicht sagen ob die Datei oder nano existiert.

  • Wenn ich es richtig sehe, kann man auch /opt/retropie/configs/all/autostart.sh manuell editieren. Wenn du die Änderung mit retropie_setup.sh machst, ändert (z.B. mit cat oder nano prüfen) sich dann diese Datei? Theoretisch müsste dort emulationstation drin stehen.

    Wo zeigt er mir an welche Version ich hab?

    Wenn du retropie_setup.sh startest, dann sollte die Version oben stehen. Falls du ein Update machen möchtest, dann vorher ein Backup machen.