Raspi 4 Störungen im BIld bei HDMI

  • Hallo zusammen,

    ich benutze schon länger einen Raspi 3+ als Mediaplayer (LibreElec) und gelegentlich als Surf-PC (Raspbian) an meinem Samsung TV (Full-HD). Keine Probleme.

    Jetzt habe ich einen Raspi 4 beschafft zum selben Zweck um den 3er abzulösen. Leider habe ich beim 4er immer Störungen im Bild. Bildpunkte einer bestimmten Farbe bzw. Helligkeit (kann ich nicht genau feststellen) erschienen in manchen Bildern als helle flackernde Punkte. Auf HDMI 0 eher grünlich schimmernd auf HDMI 1 eher rötlich. Die Störungen sind abhängig vom Bild immer an derselben Stelle. Der Effekt verschwindet, wenn ich eine niedrigere Auflösung oder Bildwechselfrequenz verwende. UHD kann ich leider nicht testen, ist aber irgendwann geplant. Da sehe ich aber schwarz, wenn Full-HD schon nicht geht. (Siehe Bild im Anhang - Raspbian Hintergrundbild - Singapur Towers)

    Der PI 3+ stellt dasselbe Bild am selben HDMI-Anschluss des TV in Full-HD sauber dar!

    Ich dachte zunächst der PI 4 und/oder das Kabel wäre defekt. Wurde auch vom Händler anstandslos gegen neuen PI 4 + Kabel getauscht. Das neue Set hat aber dasselbe Problem.

    Ist das Problem bekannt? Kann man das am Pi 4 etwas einstellen?

    Danke für Eure Hilfe!

    Gruß,

    Zusch

  • Ist der RasPi overclocked?

    Vlt. mal gucken, ob das RAM OK ist.

    Dafür gibts ein tool namens "memtester" =>

    apt-get install memtester

    "Volt, Watt, Ampere, Ohm, ohne mich gibts keinen Strom"

    Der Elektrolurch (Guru Guru)

  • Ist der RasPi overclocked?

    Vlt. mal gucken, ob das RAM OK ist.

    Dafür gibts ein tool namens "memtester" =>

    apt-get install memtester

    Nein, ist nicht overclocked. Jedenfalls nicht manuell. Einfach ausgepackt angeschlossen und Raspian-Sd rein.

    Memtest kann ich mal testen. Vielleicht hat ja die ganze Charge eine Macke... ist ja schon der zweite..