Raspi 4 stürzt des öfteren ab

  • Guten Morgen allerseits.


    Mein Raspi 4 ist gefühlt alle 2 Tage nicht erreichbar. Abhilfe schafft nur Stecker ziehen. Irgendwo gibt es doch Log-Dateien. Wo finde ich die und welche genau muss ich euch hochladen, damit ihr mir helfen könnt?


    EDIT: Als Betriebssystem nutze ich Raspian


    LG,

    Crazy

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS

  • Logdateien liegen üblicherweise in /var/log/, diese kannst du im Codeblock hier posten.

    Du kannst auch z.B. mit dmesg | grep voltage prüfen, ob es Unterspannungen gibt.

    Da gibt es viele Logfiles. Welches soll ich hier posten?

    dmesg | grep voltage im Terminal eingeben und laufen lassen?

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS

  • Guck mal in die syslog, kern.log und messages rein, vllt. steht dort was interessantes.

    Ja, den Befehl einfach ins Terminal eingeben, wenn etwas ausgegeben wird, hast du Unterspannung.

    P.S. Wenn du dmesg -T | grep voltage eingibst, sieht du eine lesbare Uhrzeit und Datum.

  • Mein Raspi 4 ist gefühlt alle 2 Tage nicht erreichbar. Abhilfe schafft nur Stecker ziehen.

    Wie ist dein PI mit dem Router verbunden? Mit welcher Software/Tool (unter welchem OS) greifst Du auf deinen PI zu? Welche Peripheriegeräte sind an deinem PI evtl. angeschlossen?


    Poste mal von deinem PI, die Ausgaben von:

    Code
    ls -la /dev/watchdog*
    ip a
    route -n
    ip n s

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Wie ist dein PI mit dem Router verbunden? Mit welcher Software/Tool (unter welchem OS) greifst Du auf deinen PI zu? Welche Peripheriegeräte sind an deinem PI evtl. angeschlossen?

    Mein Pi ist über Wlan verbunden. Auf dem PI läuft VNC Server und ich greife über meinen Windows PC per VNC Viewer auf den PI zu. An den USB-Anschlüssen habe ich einen Bluetooth-Dongle für eine Maus und eine SSD Festplatte angeschlossen. Die SSD ist per Sata/USB Adapter angeschlossen, auf ihr läuft Raspian.


    Poste mal von deinem PI, die Ausgaben von:


    pi@raspberrypi:~ $ ls -la /dev/watchdog*

    crw------- 1 root root 10, 130 Mai 4 06:17 /dev/watchdog

    crw------- 1 root root 251, 0 Mai 4 06:17 /dev/watchdog0

    pi@raspberrypi:~ $ ip a

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

    valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

    valid_lft forever preferred_lft forever

    2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000

    link/ether dc:a6:32:30:a2:c5 brd ff:ff:ff:ff:ff:ff

    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether dc:a6:32:30:a2:c7 brd ff:ff:ff:ff:ff:ff

    inet 192.168.178.11/24 brd 192.168.178.255 scope global dynamic noprefixroute wlan0

    valid_lft 859605sec preferred_lft 751605sec

    inet6 2003:e4:6f08:300:fa58:2c41:61c2:93b6/64 scope global dynamic mngtmpaddr noprefixroute

    valid_lft 6943sec preferred_lft 1321sec

    inet6 fe80::f52a:9572:b306:88ce/64 scope link

    valid_lft forever preferred_lft forever

    pi@raspberrypi:~ $ route -n

    Kernel-IP-Routentabelle

    Ziel Router Genmask Flags Metric Ref Use Iface

    0.0.0.0 192.168.178.1 0.0.0.0 UG 303 0 0 wlan0

    192.168.178.0 0.0.0.0 255.255.255.0 U 303 0 0 wlan0

    pi@raspberrypi:~ $ ip n s

    192.168.178.23 dev wlan0 lladdr 38:80:df:66:dd:05 STALE

    192.168.178.89 dev wlan0 lladdr ec:b5:fa:06:5a:f7 REACHABLE

    192.168.178.22 dev wlan0 lladdr dc:dc:e2:cf:4a:8a STALE

    192.168.178.85 dev wlan0 lladdr e4:f0:42:66:29:11 REACHABLE

    192.168.178.25 dev wlan0 FAILED

    192.168.178.10 dev wlan0 lladdr 00:11:32:81:06:26 DELAY

    192.168.178.45 dev wlan0 lladdr 14:0a:c5:2c:6a:a3 STALE

    192.168.178.52 dev wlan0 lladdr 20:df:b9:ab:fd:5d REACHABLE

    192.168.178.29 dev wlan0 lladdr ac:16:2d:62:14:07 STALE

    192.168.178.21 dev wlan0 lladdr c0:ee:fb:e7:0c:5a STALE

    192.168.178.24 dev wlan0 lladdr a4:45:19:6f:52:34 STALE

    192.168.178.27 dev wlan0 lladdr 14:0a:c5:ad:7d:7c STALE

    192.168.178.20 dev wlan0 FAILED

    192.168.178.1 dev wlan0 lladdr e0:28:6d:77:ea:38 REACHABLE

    192.168.178.201 dev wlan0 lladdr 98:f4:ab:b9:3d:8d REACHABLE

    192.168.178.79 dev wlan0 lladdr ee:df:70:11:b6:ff STALE

    192.168.178.39 dev wlan0 lladdr 34:14:5f:12:30:ad STALE

    2003:e4:6f08:300:e228:6dff:fe77:ea38 dev wlan0 lladdr e0:28:6d:77:ea:38 router REACHABLE

    fe80::e228:6dff:fe77:ea38 dev wlan0 lladdr e0:28:6d:77:ea:38 router REACHABLE

    pi@raspberrypi:~ $

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS

  • Mein Pi ist über Wlan verbunden.

    Evtl. ist es nur die WLAN-Verbindung zur FritzBox, die dann nicht mehr vorhanden ist?

    Das könntest Du mit einer Kabelverbindung (... wenn keine WLAN-Verbindung mehr vorhanden) zu deinem PI feststellen. Wenn das der Fall ist, muss lediglich die WLAN-Verbindung optimiert werden oder die WLAN-Verbindung neu gestartet werden. Welches Tool zum herstellen der WLAN-Verbindung benutzt Du mit raspbian?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Evtl. ist es nur die WLAN-Verbindung zur FritzBox, die dann nicht mehr vorhanden ist?

    Das könntest Du mit einer Kabelverbindung (... wenn keine WLAN-Verbindung mehr vorhanden) zu deinem PI feststellen. Wenn das der Fall ist, muss lediglich die WLAN-Verbindung optimiert werden oder die WLAN-Verbindung neu gestartet werden. Welches Tool zum herstellen der WLAN-Verbindung benutzt Du mit raspbian?

    Ich habe den Pi bei der Installation von Raspbian verbunden, als die Frage aufkam, mit welchem WLAN ich mich verbinden will. Ein extra Tool habe ich dafür nicht verwendet.

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS

  • Ein extra Tool habe ich dafür nicht verwendet.

    OK, dann schau mal nach wenn er "abstürzt", ob lediglich die WLAN-Verbindung weg ist.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ok, mache ich. Ich wollte aber gerne noch die Log-Dateien posten, scheitere aber gerade an Basics... Ich habe im Terminal per nano /var/log/syslog die Syslog-Datei geöffnet. Wie bekomme ich jetzt den Text hier rein? Wenn ich mit der Maus den Text markiere, dann markiert der nur bis zu der Zeile, die im Terminal unten als letztes zu sehen ist. Aber da kommen ja noch mehr Zeilen...

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS

  • Ich habe im Terminal per nano /var/log/syslog die Syslog-Datei geöffnet.

    Dafür soll nicht nano (Texteditor) benutzt werden, sondern z. B. cat (oder gleichwertig):

    Code
    cat /var/log/syslog


    EDIT:


    BTW: Den direkten Zugang zu deinem PI4 via direkte (d. h. ohne Routerbeteiligung) Kabelverbindung, kannst jetzt schon konfigurieren.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Lt. syslog verliert dein PI4 die WLAN-Verbindung. Diese wird vom dhcpcd danach nur einmal wieder hergestellt, wird dann aber wieder unterbrochen.


    Wenn Du nicht brauchst, dann deaktiviere auf deinem PI4 bluetooth in der config.txt, IPv6 in der cmdline.txt und deinstalliere den avahi-daemon.


    Poste mal die Ausgaben von:

    Code
    iwconfig
    sudo iwlist wlan0 scan
    ls -la /etc/modprobe.d
    cat /etc/dhcpcd.conf

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Lt. syslog verliert dein PI4 die WLAN-Verbindung. Diese wird vom dhcpcd danach nur einmal wieder hergestellt, wird dann aber wieder unterbrochen.


    Wenn Du nicht brauchst, dann deaktiviere auf deinem PI4 bluetooth in der config.txt, IPv6 in der cmdline.txt und deinstalliere den avahi-daemon.


    Poste mal die Ausgaben von:

    Code
    iwconfig
    sudo iwlist wlan0 scan
    ls -la /etc/modprobe.d
    cat /etc/dhcpcd.conf

    Hier bitte:


    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS

  • Hier bitte:


    Code
    pi@raspberrypi:~ $ iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11  ESSID:"Schlumpfhausen"  
              Mode:Managed  Frequency:5.5 GHz  Access Point: E0:28:6D:77:EA:3A   

    Konfiguriere als Test!, für die Zeitdauer von ca. 2 Wochen deine FritzBox und deinen PI4 so, dass nur das 2.4GHz-WLAN benutzt werden kann (d. h. 5.0GHz in der FritzBox und im PI4 deaktivieren).


    Poste auch die Ausgaben von:

    Code
    modinfo cfg80211 | grep -i parm
    modinfo brcmfmac | grep -i parm


    EDIT:


    BTW: Wenn dein PI4 24/7 mit der FritzBox verbunden sein muss, warum benutzt Du keine Kabelverbindung (statt WLAN)?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited 2 times, last by rpi444 ().

  • Konfiguriere als Test!, für die Zeitdauer von ca. 2 Wochen deine FritzBox und deinen PI4 so, dass nur das 2.4GHz-WLAN benutzt werden kann (d. h. 5.0GHz in der FritzBox und im PI4 deaktivieren).


    Poste auch die Ausgaben von:

    In der Fritzbox ist 5Ghz deaktiviert. Am Pi muss ich noch schauen wie es geht ;)


    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS

  • Am Pi muss ich noch schauen wie es geht ;)


    Erstelle die Dateien:

    Code
    sudo nano /etc/modprobe.d/cfg80211.conf

    mit dem Inhalt:

    Code
    options cfg80211 cfg80211_disable_40mhz_24ghz=1
    options cfg80211 bss_entries_limit=5

    und:

    Code
    sudo nano /etc/modprobe.d/brcmfmac.conf

    mit dem Inhalt:

    Code
    options brcmfmac roamoff=1
    options brcmfmac p2pon=0

    danach den PI4 rebooten.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Erstelle die Dateien:

    Code
    sudo nano /etc/modprobe.d/cfg80211.conf

    mit dem Inhalt:

    Code
    options cfg80211 cfg80211_disable_40mhz_24ghz=1
    options cfg80211 bss_entries_limit=5

    und:

    Code
    sudo nano /etc/modprobe.d/brcmfmac.conf

    mit dem Inhalt:

    Code
    options brcmfmac roamoff=1
    options brcmfmac p2pon=0

    danach den PI4 rebooten.

    Habe ich gemacht. Dann heißt es jetzt wohl erstmal abwarten :) Wenn ich das 5Ghz wieder aktivieren will, dann einfach die beiden Datein löschen?

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS

  • Wenn ich das 5Ghz wieder aktivieren will, dann einfach die beiden Datein löschen?

    Nein, diese beiden Dateien nicht löschen, denn damit hast Du nicht 5GHz auf deinem PI4 deaktiviert.

    5GHz könnte man z. B. mit Hilfe der wpa_supplicant.conf, auf dem PI deaktivieren. Aber wenn deine FritzBox jetzt nur noch 2.4GHz zur Verfügung stellt, muss der PI4 auch das benutzen.


    BTW: Könntest Du auch raspbian-lite auf deinem PI4 benutzen, oder muss es raspbian (ohne lite) sein?


    EDIT:


    Nur zur Info: Als mein PI4 mit raspbian-lite (und aus source-code kompiliertem wpa_supplicant bzw. eigener service-unit für den wpa_supplicant) noch 24/7 mit meiner FB verbunden war, habe ich diese (hier anonymisierte) wpa_supplicant.conf-Datei benutzt:

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Jetzt bin ich ein bisschen verwirrt. Oben hast Du geschrieben, dass ich 5Ghz am Router und am Pi deaktivieren soll. Muss ich das am Pi noch deaktivieren, oder nicht? In Deinem letzten Post hört sich das nicht so an, da Du sagst, dass der Pi eh das 2,4 Ghz Netzwerk nehmen muss, weil ich ja in der FB so eingestellt habe.


    Kannst Du mir grob erklären was die beiden Dateien bewirken sollen? Ich will es wenigstens halbwegs verstehen, wenn ich blind irgendwelche Dateien anlege :D


    Raspian-Lite ist ohne UI, oder? Schwierig, ich bin absoluter Neuling und bin ganz froh über das UI. Wenn es nicht unbedingt sein muss und Raspian mit UI nicht irgendwelche gravierenden Nachteile hat, dann würde ich lieber bei der Version mit UI bleiben.

    LG,

    Crazy


    Raspberry Pi 4B

    Raspbian OS