Raspberry Pi 3B mit zwei Display und Kodi

  • Hallo,

    ich habe mir für Kodi ein HTPC Gehäuse mit Display entwickelt und möchte Kodi zwischen dem DSI Display und Fernseher (HDMI Anschluss) umschalten können bzw. starten. Ein Restart mit eine anderen Konfiguration wäre akzeptabel, wenn man das DSI Display abstellen könnte (keine Hintergrundbeleuchtung). Ich verwende das neues Raspbian Buster.


    In meiner config.txt habe ich

    max_framebuffers=2

    framebuffer_priority=2

    display_default_lcd=0

    eingetragen.


    Mit einen startx und der framebuffer_priority kann ich den Desktop auf dem DSI oder HDMI Fernseher anzeigen lassen, dass funktioniert wie gewünscht.

    Wenn ich allerdings Kodi starte, dann wird das Programm aber immer auf den DSI Touch Display angezeigt. Das Programm ignoriert einfach alles.

    Es ist dabei sogar egal, ob ich es vom Desktop oder ohne startx vom Terminal starte.


    Im Moment kann ich nur mit ignore_lcd=1 das DSI abstellen und dann wird Kodi auf dem Fernseher über den HDMI Anschluss angezeigt. Das Problem ist aber, das Display bekommt Strom und die Hintergrundbeleuchtung leuchtet. Abstellen von der Beleuchtung geht nicht, da kein

    /sys/class/backlight/rpi_backlight/bl_power angelegt wird.


    Hat jemand eine Idee, warum Kodi immer auf dem DSI Display gestaltet wird und wie ich das ändern kann?


    PS: Mit raspi2raspi kann zwar der Bildschirminhalt auf beiden Displays angezeigt werden, aber es wird die niedrige Auflösung vom DSI Touch Display verwendet. Ist also auch keine Lösung :wallbash:

  • Da hat Linus hier https://github.com/linusg/rpi-backlight etwas für Dich.


    Gib mal in einem Terminal auf dem Desktop lxrandr ein. Kannst Du dort etwas sinnvoll anpassen?

    Das rpi-backlight funktioniert nur, wenn das DSI Display aktiv ist. Hilft mir also nicht weiter...

    Auch xrandr hilft mir nicht weiter, da Kodi alles ignoriert :(


    Ich suche eine Option mit dem ich Kodi beibringen kann, dass er den HDMI Anschluss benutzen soll, auch wenn ein DSI Display angeschlossen ist.

    Ich denke man muss ihm beibringen den Framebuffer fb1 zu verwenden, anstatt fb0.