Raspbian keine IP nach neuinstallation

  • Hallo,


    ich haber gerade Raspbian neu auf die SD Karte meines pi gezogen, bekomme aber keine IP zugewiesen.
    In meinem Speedport wird der pi zwar angezeigt aber nicht mit einer IP bestückt...
    woran kann das liegen?
    Ich habe am LAN Port noch nichts eingestellt. WIe gesagt es ist eine frische Installation.


    mfg
    DerHummelmann



    EDIT: jetzt ist der Eintrag im SPeedport auf einmal weg...

  • Monitor ist angeschlossen. Was genau soll ich wo nachsehen? Sorry ich hab quasi keine Erfahrung mit Raspbian / Linux


    Mit ifconfig bekomme ich

    Code
    eth0    Link encap:Ethernet Hardware Adresse b8:27 usw..  
            UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
            Rx packets:627 errors:0 dropped:0 overruns:0 frame:0
    ...


    und so weiter. die Zeile mit der ip fehlt

  • Hast Du /etc/network/interfaces angepasst, so, dass der Pi wenigstens mit DCHP bestückt ist?


    Code
    auto lo
    
    
    iface lo inet loopback
    iface eth0 inet static #anstelle von static ist auch ein setzen von dhcp möglich
    address 192.168.X.Y
    netmask 255.255.255.0
    gateway 192.168.W.Z


    So sieht die Datei bei mir zum Beispiel aus (wobei die Variablen natürlich durch Zahlen ersetzt sind) womit mein "Router" dem Gerät eine IP zuweist, unter welcher ich es erreichen kann.


    Sofern Du den Pi mit einem WLAN-Stick betreibst, sieht das ganze etwas anders aus.



    Grüße
    Hustenbold

    [font="Courier New"]

    Code
    print("Hallo Welt!")


    [/font]

  • Ist per Kabel angeschlossen und in der interfaces datei ist
    iface eth0 inet dhcp eingetragen


    wenn ich eine statische ip in der datei eintragen will bekomme ich die meldung "die datei kann nicht zum schreiben geöffnet werden" Aber an sich sollte es ja auch per dhcp funktionieren

  • Natürlich geht es auch mit DHCP.
    Allerdings musst Du damit rechnen, dass wenn der Pi neugestartet wird, etwa, nachdem er vom Stromnetz genommen wurde, dass dieser eventuell eine neue IP zugewiesen bekommt.
    Außerdem ist trotz DHCP dennoch die Netmaske und der Gateway, also die Adresse des Gerätes von Nöten, über welches der Pi ins Internet gelangen kann.


    /etc/network/interfaces wirst Du als 'pi' auch so nicht einfach bearbeiten können, das ist einzig und allein 'root' vorbehalten.
    Abhilfe verschaffen hier vorübergehende Superuser-Rechte, siehe auch sudo.



    Grüße
    Hustenbold

    [font="Courier New"]

    Code
    print("Hallo Welt!")


    [/font]

  • Ich hab die Datei einfach über den grafischen desktop geöffnet da ich mit dem Textdatei editor in der Konsole nicht klarkomme :P


    bin jetzt mi "vi interfaces" in der datei kann aber nix editieren, da meine tasteneingaben völlig fehlinterpretiert werden


  • Ich hab die Datei einfach über den grafischen desktop geöffnet da ich mit dem Textdatei editor in der Konsole nicht klarkomme :P


    Nun, GNU/Linux interessiert das wenig ;)


    Sofern Du weißt, wie der Editor für die grafische Oberfläche heißt, wie man ihn auch per CLI (Konsole) aufrufen kann, klatsche ein sudo zuvor dran, dann geht das auch.
    Und nochmal der Rat, lese Dich etwas in die Materie ein :)



    Grüße
    Hustenbold

    [font="Courier New"]

    Code
    print("Hallo Welt!")


    [/font]

  • Ich habe auch ein Speedport (W723V um genau zu sein) und das nimmt den Raspi in den Grundeinstellungen vom Wheezy problemlos an.


    Das ist meine /etc/network/interfaces



    Als Alternative zum LAN ist bei mir auch ein WLAN Adapter eingetragen, das stört sich bei mir nicht.


    Was mir zu dem Problem in den Kopf kommt:


    Das Speedport vergibt an bekannte Geräte i.d.R. immer die gleiche IP. Ich habe 2 Pi's und tausche da schon mal die SD Karten. Die Pi's erhalten vom Speedport aber immer "ihre" IP.


    Versuche doch mal in der Speedport Konfiguration unter "Netzwerk" / "Geräteliste" den Raspi anzuwählen und lösche dort den Eintrag vom Raspi.


    Wenn der Raspi dann wieder ans Netz angeschlossen wird sollte das Speedport ihn neu erkennen und ihm via DHCP eine neue / bzw. die durch die Löschung freigewordene IP vergeben.

  • Hilfe zur Selbsthilfe :P ist das beste weiß ich


    ICh hab die Datei jetzt mit Nano bearbeitet bekommen und hab mit "#" alles bis auf
    auto lo


    iface lo inet loopback
    iface eth0 inet static #anstelle von static ist auch ein setzen von dhcp möglich
    address 192.168.X.Y
    netmask 255.255.255.0
    gateway 192.168.W.Z


    "ausgeklammert"


    jetzt muss ich die IP noch im SPeedport eintragen oder?
    [hr]


    So ist auch die default Einstellung meines Pi. Das Problem ist ja, dass der Speedport (W724V) gar nichts erkennt...

  • Mit dem Speedport kann ich Dir nicht helfen, ich bin froh kein Drosselkom-Kunde sein zu müssen.
    In der Regel haben die Teile eine IP wie 192.168.2.1 oder 192.168.0.1, jedenfalls nachdem, was mir bekannt ist.


    Diese IP gilt auch als Gateway für Deinen Pi und alle andern Internet fähigen Geräte im Netzwerk, die muss also noch beim Pi in /etc/network/interfaces eingetragen werden.


    Danach wäre es ganz praktisch, wenn Du den Dienst neustartest, damit dieser die Änderungen wahrnimmt.

    Code
    $ sudo /etc/init.d/networking restart


    Das ist die schnelle Variante.
    Viel Erfolg dabei.



    Grüße
    Hustenbold

    [font="Courier New"]

    Code
    print("Hallo Welt!")


    [/font]

  • Hallo an alle,


    ich bin recht neu hier und habe ein ähnliches Problem.
    Zu Hause habe ich meinen Pi so eingerichtet, dass er ebenfalls eine statische IP bekommt, über WLan (192.168.1.108, Subnetzmaske 255.255.255.0 und Standardgateway 192.168.1.1). Nun bin ich über die Weihnachtstage bei den Schwiegereltern und wollte hier ebenfalls ein bisschen mit meinem Pi arbeiten. Mir war schon klar dass ich die Datei mit den Informationen für das statische IP neu schreiben muss (sudo nano /etc/network/interfaces). Ich habe mir das so vorgestellt, ich schließe den Pi erst mit einem Netzwerkkabel an den Router (Speedport W724V), in der Maske des Routers finde ich die IP des Pi im neuen Netzwerk heraus, logge mich über Putty auf den Pi und schreibe die Datei um, Bäm, Boom Bäng, mein Pi hat wieder WLan. Gesagt, getan, aber leider wird der Pi erst gar nicht am Router, als angeschlossen angezeigt, nichts, gar nichts!!! Der Pi zeigt am Netzwerkstecker, mit seinen zwei LED´s an dass er korrekt angeschlossen ist und ab und zu blinkt die eine LED vor sich hin (also kommuniziert mein Pi auch in dem Netzwerk). Allerdings ist wirklich am Router kein Pi zu sehen. Jetzt wollte ich Raspian neu installieren, allerdings habe ich den Adapter von MicroSD zu SD vergessen und weit und breit ist hier keiner der so einen Adapter haben könnte. Des weiteren ist in diesem Haushalt kein Fernseher der HDMI hat. Mir wurde vorgeschlagen an dem Router kurz DHCP aus zu schalten und zu schauen ob der Pi angezeigt wird, Fehlanzeige :no_sad: ! Ebenso habe ich versucht mit Angry IP Scanner heraus zu finden ob der Pi irgendwo im Netzwerk angezeigt wird.Das Spektrum der IP´s habe ich von 192.168.1.1 bis 192.168.2.255 gewählt. Das Spektrum deckt somit die IP´s meines Heimnetzwerks und das der Schwiegereltern ab. Ebenso erfolglos. Also, so wie ich das hier sehe, habe ich den Worst Case, was das arbeiten mit dem Pi angeht erreicht.


    Meine Vermutung ist, dass der Pi die Datei mit der statischen IP beim Booten läd und sich somit die IP von meinem Heimnetzwerk gibt, so dass der Router hier bei den Schwiegereltern erst gar nicht die Chance hat dem Pi ein IP zu zu weisen.


    Nun möchte ich fragen ob jemand noch einen Weg kennt auf den Pi, über Putty zu zu greifen um die Datei mit der statischen IP neu zu schreiben? =(

  • Ziemlich schwierige Bedingungen :-/


    Dieser Router hat standardmässig das 192.168.2.0/24 er Netz. Da ist Dein 192.168.1.0/24 Netz von Deinerm Homenetz nicht drin :no_sad:


    Du kannst das gesamte Netz Deiner Schwiegereltern am Router auf x.x.1.x umstellen - oder einfach einen Labtop nehmen und an dem eine x.x.1.x IP definieren und dann Deine Pi per Kabel am Labtop anschliessen. Dann solltest Du an Deine Pi kommen und die IP auf DHCP umstellen können :shy:

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • Notfallplan: Ich hatte damals bei der Installation auch keinen Adapter zur Hand. Bin dann irgendwann auf die Idee gekommen, dass mein Smartphone einen Speicherkartenslot hat. Hatte wenig Hoffnung, dass das klappen könnte.


    Also die Micro-SD in das Smartphone -> Smartphone anschalten und per USB an den Rechner -> Image schreiben


    Letzendlich hat die Installation problemlos funktioniert.


  • Jetzt wollte ich Raspian neu installieren, ...


    Warum willst Du raspbian neu installieren? Du musst doch nur die interfaces-Datei auf der SD-Karte ändern, d. h. für das eth0-Interface eine IP-Adresse aus dem Subnetz des Routers deiner Schwiegereltern (statisch oder für dhcp) konfigurieren.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden