Raspberry Türklingel

  • Hi Sascha,

    gib mal bei Conrad, Reichelt usw. "AQY" oder "AQW" ein. Das sind Halbleiter- Relais (von Panasonic) die als "Spule" eine Art LED drin haben. Die dürfte mit Vorwiderstand evtl. direkt am GIPO anschließbar sein. Strom und Vorwiderstand lassen sich mit Online-Rechnern ermitteln. Bitte erst ohne den Pi testen: den Widerstand so vergrößern, daß das Halbleiterrelais noch sicher anzieht.

    Der "Kontakt" ist optisch getrennt vom Pi und kann verschiedene, kleine Leistungen schalten (bei mir 60V 0,1A).

    Die Relais sind im DIL- Gehäuse mit 4 Pins (Einzelrelais) und passen bestimmt in ein Pi- Gehäuse.


    Auch umgekehrt, mit Kontakt hin auf die GIPO-Leiste, ist das wegen der Entkopplung eine interessante Sache.

    Ich hab erst letztens erfahren, daß es sogar Öffner von den Dingern gibt...

    Hans

  • Also bisher hat der Raspi alle Steckversuche mit gemacht

    Im Anhang wäre das relais zu sehen.


    Wenn ich den IN an masse vom Raspi halte dann geht es

    Ich glaube, das hatten wir schon mal. Das Relais hat einen PNP-Transistor (du könntest das mal an der Bezeichnung prüfen). Den kannst du mit Masse runterziehen, dann schaltet das Relais. Wenn du 3,3 V vom GPIO drauf gibst, schaltet es aber nicht aus. Wenn du 5 Volt drauf gibst, schaltet es aus. Wenn es sich hier um das gleiche Teil handelt, kannst du es mit dem Pi nicht direkt schalten.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Hallo


    Habe ich mich den da verlesen was oytschi gesagt hat?

    Also gibt es kein Relais was ich direkt mit dem Raspberry schalten kann?

    ich muss den Umweg über eine Extraspannung und einem Transistor gehen?

    Das relais ist genau das auf dem Bild, einen schaltplan hab eich leider keinen.

    Habe gerade gesehen das die Firma in D das auch nur in China bestellt hat, allerdings

    wesentlich günstiger :(

  • Wie hast du das Relais jetzt angeschlossen? Mit 5V Versorgt bzw. auch mal mit 3.3V versucht? Wie sieht der Code aus?

    Ich habe definitiv ein solches Relaisboard laufen am Raspberry im Auto, welches ein sicheres runterfahren vom Pi garantiert. Also ist es möglich :D

    Ich habe zwar gerade kein Foto davon, aber war eben auch ein fertiges Relais Board wie das welches du gepostet hast.

  • Doch, es gibt Relaismodule, die man direkt mit dem Pi schalten kann.

    Z. B. dieses hier.


    Das von dir gezeigte geht nicht ohne weitere Beschaltung. Bei anderen (mit getrennter Versorgung für Spulen und Steuerkreis - VCC/JD-VCC) geht es meistens, aber bei 3,3 V für den Steuerkreis ist der Strom ziemlich schwach und es gibt keine Sicherheit, dass das Relais zuverlässig schaltet.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Also einen Optokoppler hat meines sicher nicht drauf ;)

    Was soll auch so schwer und komplex an einer derartige einfachen Beschaltung sein...Relais, Transistor (n-Kanal FET oder NPN), Widerstand und eine Freilaufdiode.

  • Also einen Optokoppler hat meines sicher nicht drauf ;)

    Was soll auch so schwer und komplex an einer derartige einfachen Beschaltung sein...Relais, Transistor (n-Kanal FET oder NPN), Widerstand und eine Freilaufdiode.

    Sollte man meinen... Aber ich hab noch kein Realismodul gesehen, das rein über einen NPN-Transistor angesteuert wird. Ich kenne bislang nur welche mit PNP und eben die mit Optokoppler. Obwohl eigentlich die Beschaltung mit NPN die naheliegendste wäre... Warum es sowas nicht gibt, ist mir rätselhaft.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Ich glaueb es liegt am ioBroker, ich kann dort den GPIO nicht auf Pulldown stellen.

    Wenn ich den das Kabel vom steuersignal an GND halte schaltet das relais

  • Was erzählst du für einen Unsinn???

    Wenn du ein Relais schalten willst, steht dein GPIO auf OUTPUT - da gibt es keinen Pulldown.


    Wenn du meinen Beitrag #22 gelesen hättest, wüsstest du, wo das Problem ist.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Also ich erzähle nur was ich getestet habe, es ist gut möglich das die Platine defekt ist, das kann ich

    abe rnicht beurteilen.

    Fakt ist das von der Relais Platine 4.4V kommen.

    So ist es angeschlossen, 5V vom pin2, GND pin39,

    wenn ich jetzt von der Relais Platine pin "IN" an GND raspberry messe, habe ich 4.4V,

    und wenn ich diesen an Masse halte, dann schaltet das Relais.

  • Alles völlig korrekt und entspricht genau dem, was ich sage.

    Die Schaltung nutzt einen PNP-Transistor. AM Kollektor sind 5 V, der Spannungsabfall im Transitor ist 0,6 V, bleiben 4,4 v. Um den Transistor zu sperren, müssen 5 Volt an der Basis liegen.

    Wenn du jetzt 5 V an IN anschließt, schaltet das Relais ab.

    Wenn du 3,3 V an IN anschließt, schaltet es nicht ab.

    Da ein GPIO nur 3,3 V liefert, kannst du das Relais mit einem GPIO nicht abschalten.


    Nochmal erklär ich es nicht!

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Hallo Gnom

    Jetzt habe ich es verstanden, nur eins ist mir jetzt schleierhaft, wieso werden solche Relais

    angeboten?

    Das ist ja schon irgendwie Betrug, wenn dort steht das die für den Raspberry sind.

    Edited 2 times, last by sascha321 ().

  • Naja, geeignet ist relativ. Man kann sie ja anschließen, nur nicht ohne Zusatzschaltung.

    (Auf der anderen Seite gibts treffliche Streits darüber, was überhaupt machbar ist mit dem Pi, ob und wie weit man die 3,3 Volt überschreiten darf und wie viel Strom man den GPIOs aufbürden kann. Mangels klarer Spezifikation vom Hersteller ist der gängige Tenor: Die GPIOs sind nicht 5-V-fest, 3,3 Volt dürfen keinesfalls überschritten werden und der Strom darf nicht höher als 3 mA sein. Ob das so standhält, ist nicht klar. Es gibt diverse Tests und Dokumentationen, die zeigen, dass zumindest beim Strom erheblich Spielraum ist. Aber jedenfalls ist man auf der sicheren Seite wenn man diesen Rahmen einhält.)

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Was Du sagst leuchtet mir ein, ich habe es mal getestet.

    VCC = 5V

    GND= Masse


    IN = 5V -> passiert nichts

    IN = Masse -> Relais schaltet


    Also irgendwas ist doch da nicht IO :-/



    Habe es jetzt mal mit einer externen Stromversorgung probiert.

    Das Relais schaltet definitiv nur wenn ich es gegen Masse halte.

  • Es ist völlig in Ordnung. Nur ist das Relais für 5V gebaut und in dieser Form ohne Zusatzbeschaltung (Transistor oder Optokoppler) nicht mit dem Pi schaltbar.
    Meine Empfehlung: Nimm einen Optokoppler und einen Vorwiderstand (2 KOhm ist ok) das ist einfach und bringt dir zudem ne galvanissche Trennung.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Das wollte ich zwar vermeiden, da ich keine extra stromquelle legen wollte, der PI 4 hat einen POE anschluss.


    Aber nun, es ist wohl so wie es ist.

  • rein aus neugier:

    gibt es denn ein board, das dies kann (also keinen rpi4), ohne extraverlegung, etc. ?

    --- wer lesen kann, ist klar im Vorteil ---

    --- Freude entsteht aus Mangel an Information ---

    --- Scheiße ist, wenn der Furz etwas wiegt ---


  • Du musst keine externe Stromquelle legen (die galvanische Trennung kannst du machen, musst du aber nicht).
    - Schließe das Relaismodul an 5 V (VCC) und GND vom Pi.

    - Schließe den Optokoppler (mit 2K Vorwiderstand) an GPIO (Anode) und GND (Kathode) vom Pi.

    - Schließe den Ausgang des Optokopplers an IN (Kollektor) und GND (Emitter) des Relaismoduls.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • rein aus neugier:

    gibt es denn ein board, das dies kann (also keinen rpi4), ohne extraverlegung, etc. ?

    Wenn du mit "Board" ein Relaismodul meinst, das von einem Pi ohne Zusatzbeschaltung benutzt werden kann, dann schau unter #25.

    Wenn du einen Singleboard-Computer meinst. Ich hab bislang nur mit Pi gearbeitet und kenne deshalb keinen, der 5V-GPIOs hat. Wäre aber echt interessant, ob es welche gibt, die Pi-kompatibel sind und 5V-Peripherie haben.
    Aber jeder bessere µC (Arduino) ist mit 5V beseelt und tut's wunderbar mit diesen Modulen.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Jetzt gebe ich es auf, ich habe das gefühl das liegt am ioBroker und dem Module rpi2.0.

    Ich habe jetzt testweise mal einen 4n35 so angeschlossen wie gesagt, aber das tut sich nichts.

    Ich sehe zwar im ioBroker das die pins geschaltet werden, aber mehr ist da nicht. Das relais belibt stumm :-/


    Danke für die Hilfe.