Raspberry Pi 2 B V1.2 bootet nicht mehr

  • Hallo an alle,


    ich benutze nun schon jahrelang verschieden RPI und hatte damit noch keine großen Schwierigkeiten. Nun habe ich letztes Wochenende einen seit Jahren laufenden PI upgedatet nun startet er nicht mehr.


    Es handelt sich um ein RPI B mit einer openHABian Installation. Bei dieser kam es in den vergangenen Wochen immer wieder zu einem Ausfall von influxDB. Im openHAB Forum wurde ich über Ecken fündig und habe mich schließlich entschlossen von Jessie über Strech to Buster upzugraden. Hierbei habe ich auch ein

    Code
    sudo apt-get install rpi-update
    sudo rpi-update

    durchgeführt, dabei aber völlig übersehen, dass mein RPi damals nur durch setzen des

    Code
    vcgencmd otp_dump | grep 17:

    mit Ergebnis "17:3020000a" bootfähig für USB-Sticks gemacht habe.


    Nachdem ich am Sonntag das ganze Update durch hatte, lief der RPi mit openHABian und Raspian Buster einwandfrei (auch nach einem reboot).


    Seit gestern ist er nun aber komplett offline.


    Aktuelles Verhalten:

    1. keine Ausgabe an HDMI
    2. Hochpowern ohne SD-Karte oder USB-Stick -> rote PWR LED leuchtet für <10s und geht dann dauerhaft aus
    3. Hochpowern mit SD-Karte und aktuellem Raspberry PI OS -> rote PWR geht kurz an dann gleich wieder aus. Grüne LED ACT auf dauer blinken mit konstantem Tastverhältnis
    4. Hochpowern mit USB-Stick und aktuellem Rspberry PI OS -> rote PWR LED leuchtet für <10s und geht dann dauerhaft aus (Verhalten an allen 4 USB Ports gleich)
    5. Hochpowern mit SD-Karte und aktuellem Raspberry PI OS und mit USB-Stick und aktuellem Rspberry PI OS -> rote PWR geht kurz an dann gleich wieder aus. Grüne LED ACT auf dauer blinken mit konstantem Tastverhältnis

    Ich vermute das ganze hängt ursächlich mit dem rpi-update zusammen und der Geschichte, dass es damals erforderlich war den OTP Parameter zu setzen.


    Warum der RPi dann am Sonntag noch bis mindestens Dienstag gelaufen ist verstehe zwar nicht fakt ist er tut jetzt nicht mehr. (USB-Stick 8GB und SD-Karte 32GB sind andere als der openHABian Stick 64GB)


    Kann man aus der Beschreibung schließen, das er tatsächlich zufällig kaputt gegangen ist?
    Bzw. kann man daraus erkennen was zu tun wäre, um ihn wieder beleben zu können falls er nicht kaputt ist.



    Viele Grüße

  • sudo rpi-update

    Schein, obwohl es 'böse' ist und nur von denen verwendet werden sollte, die wissen sollten, dass sie ihren PI damit zu einem 'so nicht bootenden Gerät' befördern können, wenn nicht gar zu einem 'Brick' , immer noch verwendet.



    Übrigens, "PI B" ist kein besonders aussagekräftige Name, denn fast alle sind Typ B.

    Selber denken,
    wie kann man nur?

    • Official Post

    Hallo Seehund,


    willkommen im Forum! ;)

    rpi-update

    :no_sad: Das Problem hast Du ja erkannt, deshalb nur der Link: https://www.elektronik-kompend…/raspberry-pi/2006061.htm


    rote PWR LED leuchtet für <10s und geht dann dauerhaft aus

    Das ist imho ziemlich eindeutig ein Netzteilproblem.

  • Nachdem ich am Sonntag das ganze Update durch hatte, lief der RPi mit openHABian und Raspian Buster einwandfrei (auch nach einem reboot).

    Dann liegt es nicht am rpi-update.

    Ich vermute das ganze hängt ursächlich mit dem rpi-update zusammen und der Geschichte, dass es damals erforderlich war den OTP Parameter zu setzen.

    Kann auch nicht sein, da das eine einmalige Angelegenheit mit dem Bootflag ist.


    Prüfe mal deine SD-Karten und Sticks auf Fehler. Netzteil ist auch ne Möglichkeit.

  • Seehund

    Changed the title of the thread from “Raspberry Pi B bootet nicht mehr” to “Raspberry Pi B V1.2 bootet nicht mehr”.
  • Das ist imho ziemlich eindeutig ein Netzteilproblem.

    Ich habe jetzt mal die Spannungsversorgung auf ein anderes Netzteil gestützt und tatsächlich, wenn man keinerlei Bootmedien eingelegt hat, bleibt die rote PWR LED dauernd an und erlischt nicht mehr nach 10s.

    Damit habe ich nun wirklich nicht gerechnet, da von allen Beschreibungen ja immer von einer in regel oder unregelmässigen Abständen an und ausgehender LED gesprochen wird.


    Dann ist es wohl ein dummer Zufall gewesen, dass das Netztei mehr oder weniger gleichzeitig mit der Update Orgie (oder gerade deshalb) den Geist aufgegeben hat.


    Danke für das triggern, ich hatte das einfach ausgeschlossen, da das Netzteil wie gesagt bis Dienstag anstandslos gelaufen ist. Diesen Testpunkt habe ich deshalb einfach übersprungen.


    Ich spiele gerade das openHab Image von Sonntag auf meinen USB-Stick zurück und dann bin ich tatsächlich zuversichtlich, dass es wieder läuft.


    Danke nochmals für den entscheidenden Anstoß

  • Seehund

    Changed the title of the thread from “Raspberry Pi B V1.2 bootet nicht mehr” to “Raspberry Pi 2 B V1.2 bootet nicht mehr”.
  • Temperaturprobleme? keine Ahnung, nach Updaten von Raspbian hatte ich noch nie Probleme.