MPD Installation unter Buster Desktop

  • Hallo,


    ich habe die aktuelle Version von Buster Desktop (Raspberry Pi OS (32-bit) with desktop and recommended software).


    Dort möchte ich jetzt MPD installieren und anschließend mit dem Handy steuern.


    Der Sound soll über Klinke ausgegeben werden, das HDMI Kabel, bzw. ein Monitor ist nicht immer angeschlossen.


    Es wäre nett, wenn ihr mir bei der Installation helft, bzw. bei den Einstellungen.


    Es sollen ein paar Radiosender per URL in die Playlist hinzugefügt werden.

    Danke schon mal.

    • Official Post

    Hallo willi8,


    los gehts! ;)

    Code
    sudo apt update && sudo apt install mpd mpc


    Konfiguration vom MPD:

    sudo nano /etc/mpd.conf


    Hier eigentlich nur folgende Stelle so anpassen, dass diese folgendermaßen aussieht:

    Code
    audio_output {
            type            "alsa"
            name            "My ALSA Device"
            mixer_type      "software"
    #       device          "hw:0,0"        # optional
    #       mixer_type      "hardware"      # optional
    #       mixer_device    "default"       # optional
    #       mixer_control   "PCM"           # optional
    #       mixer_index     "0"             # optional
    }

    Speichern mit Strg+o (der Buchstabe O, nicht die Null!) nano beenden mit Strg+x.


    Nach der Änderung der mpd.conf den Daemon neu starten:

    sudo service mpd restart


    In das 'playlists' Verzeichnis Radio Liste erstellen:

    sudo nano /var/lib/mpd/playlists/Radio.m3u


    Mit diesem Inhalt:

    Code
    http://bob.hoerradar.de/mp3-radiobob
    http://mp3channels.webradio.antenne.de/rockantenne
    http://streams.rsa-sachsen.de/rsa-rockzirkus/mp3-192/mediaplayerrsa

    (Übernimm diese bitte genau so, da ich weiß, dass die funktionieren, auch wenn Dein Musikgeschmack evtl. ein völlig anderer sein könnte. :cool:)


    Danach Speichern und nano beenden.


    Dann die Liste Laden:

    mpc load Radio


    Und starten:

    mpc play 3 Die 3 steht für den dritten Eintrag in der Playliste.


    Wenn Du jetzt nichts hören solltest, was ich vermute, dann ist das nicht schlimm!


    Jetzt brauche ich erstmal zur Sicherheit die aktuelle Ausgabe, also was angezeigt wird und dann noch die Ausgaben von:

    Code
    aplay -l
    # und
    cat ~/.asoundrc 
    # und
    cat /etc/asound.conf

    ?


    Danach geht es weiter.

  • Hallo,


    schon mal danke für eure Hilfe.


    Ich habe gerade alles installiert.


    Mit HDMI Kabel kam sofort ein Sound, danach habe ich den Pi heruntergefahren, das HDMI Kabel abgezogen und ein Headset an dem 3,5mm Klinkeausgang angeschlossen.


    Nach dem Neustart kam auch dort ein Sound heraus. :)

    Aber irgendwelche Fehler scheint es trotzdem noch zu geben.


    Datei oder Verzeichnis nicht gefunden

    Hier die gewünschten Ausgaben:


    Code
    mpc play 3
    
    R.SA - Rockzirkus: Coldplay - Speed of Sound
    [playing] #3/6   0:00/0:00 (0%)
    volume:100%   repeat: off   random: off   single: off   consume: off



    Code
    cat ~/.asoundrc
    
    cat: /home/pi/.asoundrc: Datei oder Verzeichnis nicht gefunden


    Code
    cat /etc/asound.conf
    
    cat: /etc/asound.conf: Datei oder Verzeichnis nicht gefunden


    Code
    mpc status
    
    R.SA - Rockzirkus: Tom Petty - Free Fallin'
    [playing] #3/3   8:42/0:00 (0%)
    volume: 100%   repeat: off   random: off   single: off   consume: off
    • Official Post

    Aber irgendwelche Fehler scheint es trotzdem noch zu geben.

    Das ist (noch) kein Problem, solange Du den Audioausgang vom Desktop aus (Lautsprechersymbol) nicht umstellst.


    Hast Du schon eine App für das Telefon? Falls nicht, dann such mal nach 7soft und Raspiradio oder so. Das hatte ich auf Android laufen. Mein Internet ist hier grottig, sonst hätte ich das gleich selber gesucht, kann ich aber heute Abend noch nachholen.

  • Ich benutze bereits erfolgreich die M.A.L.P App.


    Ein Problem habe ich jetzt aber noch.


    Für eine andere Sache musste ich noch folgende Einstellung vornehmen.


    Mit sudo raspi-config habe ich das Configuratinos Tool aufgerufen und unter Advanced Options, Resolution, folgendes ausgewählt: DMT Mode 82 1920x1080 60Hz 16:9


    Wenn ich jetzt meinen Pi ohne HDMI-Kabel neustarte, dann kommt aus dem Headset (3,5mm) kein Sound.


    Die Ausgabe von aplay -l lautet:



    Mit HDMI-Kabel habe ich Sound, ohne HDMI-Kabel, also mit dem Headset (3,5mm) ist kein Sound vorhanden.


    Kann man das Problem noch lösen?

    • Official Post

    Ja, ich habe aber nicht im Kopf, ob die ~/.asoundrc dabei schon erstellt wurde. Übergangsweise kannst Du es mal in der mpd.conf statt mixer_type "software" mit mixer_type "Headphones" versuchen.


    Oder in per sudo raspi-config bei Audio die Klinke einstellen könnte auch funktionieren, aber sieh schon mal nach, ob die Datei ~/.asoundrc jetzt da ist.

  • Wenn ich folgenden Befehl eintippe, cat ~/.asoundrc, erscheint folgende Ausgabe:


  • In der mpd.conf - Datei habe ich den mixer_type auf "Headphones" gestellt.


    Leider kommt kein Sound, ich kann die Lautstärke nicht erhöhen.


    Hier die Ausgabe von mpc status


    Code
    R.SA - Rockzirkus: The Rolling Stones - It's Only Rock'n'Roll (But I Like It)
    [playing] #3/3   0:05/0:00 (0%)
    volume: n/a   repeat: off   random: off   single: off   consume: off


    Bei volume steht: n/a

  • Mit dem Befehl und auch einem Neustart klappt es leider auch nicht sudo service mpd restart


    Wenn du später am PC bist, wäre es nett, wenn du dich dann nochmal meldest.

    Vielen, Vielen Dank schon mal.

    Bis später.

    • Official Post

    So, bin nun am PC.


    Klicke mit der rechten Maustaste auf das Lautsprechersymbol in der Leiste auf dem Desktop und stelle sicher, dass dort der Haken auf "Analog" steht, falls nicht, dann wähle das aus!


    Dann ändere in der mpc.config wieder zurück auf:

    Code
            mixer_type      "software"


    und nun abschließend noch:

    Code
    sudo cp ~/.asoundrc /etc/asound.conf && sudo service mpd restart && mpc play

    Jetzt solltest Du wieder etwas hören.


    Zeige danach bitte nochmals mpc status!

  • Super, Vielen Dank.


    Es läuft jetzt alles so wie ich mir das vorgestellt habe.


    Hier die Ausgabe:



    Code
    mpc status
     
    RADIO BOB! BOBs Livestream: www.radiobob.de
    [playing] #1/3   0:26/0:00 (0%)
    volume: 80%   repeat: off   random: off   single: off   consume: off



    Eine Frage noch.


    Gibt es noch einen gescheiten MPD-Webplayer?


    Wenn ja, wie installiere ich den Player?

    • Official Post

    Gibt es noch einen gescheiten MPD-Webplayer?

    Ich hatte mal einen getestet, aber der hat nicht gut funktioniert. Sorry, aber da kann ich Dir leider nicht helfen.


    Ich hätte nur einen Player (Xfmpc) für den Desktop zu bieten. Falls Du den testen möchtest, der wird installiert mit:

    sudo apt install xfmpc

  • Na ich finde das schon schöner.

    Eine System, drauf spielen und schon kommt musik, man kann jederzeit nach Sendern suchen diese in die Favliste hinzufügen so müsste er jedesmal die StreamURL ermitteln, was manchmal auch nicht so top ist und dann diese in die *.m3u hinzufügen stoppen, neuladen, starten...


    aber klar geschmäcker sind zum glück verschieden und das ist top.


    Lars