phpMyAdmin auf Raspi 4 B - PHP 7.1 wird installiert obwohl PHP 7.3 bereist vorhanden, keine Anmeldung mit root in phpMyAdmin möglich

  • Hallo,


    ich habe einen Raspi 4 B.

    Darauf läuft aktuell eine Anwendung, die folgendes nutzt:

    - Apache2

    - MariaDB

    - PHP 7.3


    Nun habe ich auf Empfehlung phpMyAdmin installiert.

    Ich habe mich an diese beiden Anleitungen angelehnt:

    https://tutorials-raspberrypi.…lation-teil-4-phpmyadmin/

    https://www.raspberry-buy.de/T…P_MariaDB_phpMyAdmin.html

    Code
    sudo apt install phpmyadmin

    Danch habe ich die 3 Fenster durchgeklickt:

    ----------

    Im ersten Fenster:

    [*] apache2

    ----------

    Im zweiten Fenster:

    <Ja>

    ----------

    Im dritten Fenster muss man ein Passwort für den phpMyAdmin-Standardbenutzer festlegen:

    <Kennwort>

    ----------

    Im vierten Fenster muss man das Passwort bestätigen:

    <Kennwort>

    ----------


    Danach habe ich festgestellt, dass es nun zusätzlich PHP 7.1 gibt.

    Voher war nur PHP 7.3 vorhanden.

    Warum wird PHP 7.1 benötigt?

    Code
    ls -lh /etc/php/7.1
    ls -lh /etc/php/7.3


    Außerdem konnte ich mich mit root und dem vergebenem Kennwort nicht an der phpMyAdmin-Webseite anmelden.


    Kann jemand helfen oder gibt es eine Anleitung für Dummys, die auch funktioniert?


    Gruß

    meute

  • Sieh mal auf dieser Seite nach:

    Anleitung für Anfänger zur Installation eines Raspberry Pi 4B mit Webserver, MariaDB, Samba, Nextcloud, Letsencrypt und einem kleinen Mediaserver


    In dem PDF des 3. Punktes wird die Installation von phpMyAdmin beschrieben.

    Es funktioniert sogar.


    MfG


    Jürgen

  • Hallo,

    Sieh mal auf dieser Seite nach:

    Anleitung für Anfänger zur Installation eines Raspberry Pi 4B mit Webserver, MariaDB, Samba, Nextcloud, Letsencrypt und einem kleinen Mediaserver


    In dem PDF des 3. Punktes wird die Installation von phpMyAdmin beschrieben.

    Es funktioniert sogar.

    Ich bin in der PDF-Datei "3. Nextcloud mit Apache2, MariaDB, PhpMyAdmin und Letsencrypt 2020_06_05.pdf" folgende Punkte durchgegangen:

    1.3.0

    1.3.1

    1.3.1.1

    1.3.1.2


    Laut Punkt 1.3.1.2 muss man in die Datei

    /usr/share/phpmyadmin/config.inc.php

    das vorher erstellte temp-Verzeichnis

    $cfg['TempDir'] = '/usr/share/phpmyadmin/temp'; 

    eintragen.

    Nach dem Eintrag startet der Apache2-Service aber nicht mehr.


    Code
    Job for apache2.service failed because the control process exited with error code.
    See "systemctl status apache2.service" and "journalctl -xe" for details.



    Und nun?



    Gruß

    meute

  • Ein temp-Verzeichnis in eine Datei eintragen??


    Du sollst eine Verzeichnis erstellen mit Namen "temp"

    mkdir /usr/share/phpmyadmin/temp


    Füge in der Datei /usr/share/phpmyadmin/config.inc.php am Ende folgende Zeile ein.

    Du öffnest die Datei

    sudo nano /ur/share/phpmyadmin/config.inc.php

    scrollst bis ganz ans Ende und fügst folgenden Code ein.

    $cfg['TempDir'] = '/usr/share/phpmyadmin/temp';


    Datei speichern und schließen.


    Dann apache 2 neustarten

    systemctl restart apache2

  • Hallo,

    Ein temp-Verzeichnis in eine Datei eintragen??

    Nein, es wurde keine Datei eingetragen. Das Stand leider nicht in der Anleitung.

    Ich habe nur das temp-Verzeichnis erstellt.

    Wenn ich demnächst wieder am Raspi bin, werde ich eine leere Datei erstellen.

    Gibt es eine Vorgabe für einen bestimmten/empfohlenen Dateinamen?


    Du sollst eine Verzeichnis erstellen mit Namen "temp"

    mkdir /usr/share/phpmyadmin/temp

    Habe ich gemacht.


    Habe ich gemacht.



    Gruß

    meute

  • Wenn ich demnächst wieder am Raspi bin, werde ich eine leere Datei erstellen.

    Du sollst keine "leere Datei" erstellen

    Code
    Füge in der Datei /usr/share/phpmyadmin/config.inc.php am Ende folgende Zeile ein.
    Du öffnest die Datei
    [tt]sudo nano /ur/share/phpmyadmin/config.inc.php[/tt]
    scrollst bis ganz ans Ende und fügst folgenden Code ein.
    [tt]$cfg['TempDir'] = '/usr/share/phpmyadmin/temp';[/tt]


    Wenn du das gemacht hast und den apache2 neugestartet hat, ist der Fehler weg

  • Hallo,

    Du sollst keine "leere Datei" erstellen

    Code
    Füge in der Datei /usr/share/phpmyadmin/config.inc.php am Ende folgende Zeile ein.
    Du öffnest die Datei
    [tt]sudo nano /ur/share/phpmyadmin/config.inc.php[/tt]
    scrollst bis ganz ans Ende und fügst folgenden Code ein.
    [tt]$cfg['TempDir'] = '/usr/share/phpmyadmin/temp';[/tt]


    Wenn du das gemacht hast und den apache2 neugestartet hat, ist der Fehler weg

    Sorry, ich habe heute morgen Deine Antwort so verstanden:

    Ich soll im Ordner /usr/share/phpmyadmin/temp eine Datei erstellen.

    Aber dann vergessen wir das.


    Den Rest hatte ich aber gestern schon so gemacht:

    Ich hatte gestern die Datei /usr/share/phpmyadmin/config.inc.php erstellt.

    Ich hatte gestern am Ende der Datei $cfg['TempDir'] = '/usr/share/phpmyadmin/temp'; eingefügt.

    Aber nach dem Eintrag startet der Apache2-Service aber nicht mehr.

    Das hatte ich gestern vesucht, hier zu beschreiben.


    Welche Berechtigung braucht der Ordner /usr/share/phpmyadmin?

    Ich habe nämlich "www-data" bei User und Gruppe geändert, damit der Apache dort zugreifen darf.

    Das hatte ich in einer anderen Anleitng gelesen.

    Code
    sudo chown www-data:www-data -R /usr/share/phpmyadmin



    Gruß

    meute

  • Ich hab gerade gesehen, dass du phpmyadmin mit apt installiert hast.


    sudo apt install phpmyadmin


    phpmyadmin wird in den Repositories von Buster bzw. Raspberry Pi OS nicht mehr unterstützt und nicht mehr upgedatet. Du hast also eine mehrere Jahre alte Version installiert. Daher auch PHP 7.1.


    Deinstalliere die Version wieder. sudo apt remove --purge phpmyadmin

    und installiere es nach meiner Anleitung.

    Dann funktioniert es auch.

  • Hallo,

    Das habe ich alles gestern schon gemacht.

    sudo apt remove --purge phpmyadmin

    sudo reboot


    Danach erst habe ich nach Deiner Anleitung einstalliert.

    Es wurde die aktuelle Version 5.0.2 installiert.



    Gruß

    meute

  • Danach erst habe ich nach Deiner Anleitung einstalliert.

    Dann zeig mir bitte mal die Ausgabe von

    cat /usr/share/phpmyadmin/config.inc.php

  • Ich habe nämlich "www-data" bei User und Gruppe geändert, damit der Apache dort zugreifen darf.

    Das hatte ich in einer anderen Anleitng gelesen.

    Das habe ich in der Anleitung aber nicht vorgegeben.

    Kombiniere bitte nicht verschiedene Anleitungen miteinander!

    Ändere das wieder.

    sudo chown -R root:root /usr/share/phpmyadmin

  • Hallo,

    Das habe ich in der Anleitung aber nicht vorgegeben.

    Kombiniere bitte nicht verschiedene Anleitungen miteinander!

    Ändere das wieder.

    sudo chown -R root:root /usr/share/phpmyadmin

    Ja sorry, das mit ...chown www-data:www-data... stand halt so in einer Anleitung, die ich vor Deiner gefunden hatte.

    Der Ablauf war aber ähnlich Deiner, weshalb ich das so belassen habe.


    Wurde aber erledigt:

    sudo chown root:root -R /usr/share/phpmyadmin

    Code
    $ ls -lh /usr/share
    drwxr-xr-x 13 root root 4,0K Aug 17 18:53 phpmyadmin


    Dann zeig mir bitte mal die Ausgabe von

    cat /usr/share/phpmyadmin/config.inc.php



    Gruß

    meute

  • /**
    * You can find more configuration options in the documentation
    * in the doc/ folder or at <https://docs.phpmyadmin.net/>.
    */

    Wo ist denn da die Zeile

    $cfg['TempDir'] = '/usr/share/phpmyadmin/temp';


    Und nicht vergessen, apache 2 neuzustarten oder den Pi zu rebooten.

  • Naja, lt. gepostetem apache-Fehler

    Aug 16 17:45:20 raspi82 apachectl[1255]: AH00526: Syntax error on line 31 of /etc/apache2/conf-enabled/phpmyadmin.conf:
    Aug 16 17:45:20 raspi82 apachectl[1255]: Invalid command '$cfg['TempDir']', perhaps misspelled or defined by a module not included in the server configuration

    In Zeile 31 von /etc/apache2/conf-enabled/phpmyadmin.conf

    Menschen die keine Ironie verstehen finde ich super!

  • Wo ist denn da die Zeile

    $cfg['TempDir'] = '/usr/share/phpmyadmin/temp';


    Und nicht vergessen, apache 2 neuzustarten oder den Pi zu rebooten.

    Ich Depp :wallbash:


    Ich habe die Zeile

    $cfg['TempDir'] = '/usr/share/phpmyadmin/temp';

    in die falsche Datei

    /etc/apache2/conf-available/phpmyadmin.conf

    eingetragen, anstatt in die richtige Datei

    /usr/phpmyadmin/config.inc.php


    Danach habe ich ausgeführt:

    Code
    $ sudo a2enconf phpmyadmin
    Conf phpmyadmin already enabled
    $ sudo systemctl restart apache2.service


    Wenn ich nun aber auf

    https://192.168.x.x/phpmyadmin/

    gehe, erhalte ich im Browser immer noch den Fehler:

    Code
    Forbidden
    You don't have permission to access this resource.
    
    Apache/2.4.38 (Raspbian) Server at 192.168.23.82 Port 443


    Gruß

    meute

  • Ich hab keine Ahnung mehr, was du wo, wie und überhaupt gemacht, installiert, deinstalliert und eingetragen oder vermurkst hast.

    So kann ich dir nicht helfen.

    Man bekommt von dir ja auch kaum Informationen.

    Erst hieß es du hast phpmyadmin mit apt installiert.

    Später nach längerem bohren und einigen Beiträgen, gibst du endlich bekannt, dass du phpmyadmin wieder deinstalliert hast und nach meiner Anleitung vorgegangen bist wobei du eine andere Anleitung mit dazu genommen und beide vermischt hast, weil sie "ähnlich" sind. Änderst einfach die Rechte (Owner) des Ordners phpmyadmin.....

    Dann trägst du eine Zeile in eine falsche Datei ein.......

    Ich hab keine Ahnung, ob du die Rechte..Owner.. von /etc/apache2/conf-available/phpmyadmin.conf auch verändert hast.


    Ich kann dir nur noch einen Rat geben.

    Fang nochmal ganz von vorne an.

    Installier dir ein frisches OS und halte dich dann genau an meine Anleitung von Anfang an. Angefangen bei der Installation von PHP.


    Leider kann ich dir keinen anderen Rat mehr geben.

  • Hallo,

    Ich hab keine Ahnung mehr, was du wo, wie und überhaupt gemacht, installiert, deinstalliert und eingetragen oder vermurkst hast.

    So kann ich dir nicht helfen.

    Man bekommt von dir ja auch kaum Informationen.

    Sorry, aber dass sudo apt install phpmyadmin der falsche Weg war, hat sich ja erst im Laufe dieses Threads herausgestellt.

    Das habe ich gleich mit sudo apt remove --purge phpmyadmin korrigiert.


    Ich habe mir alle Schritte dokumentiert, die ich gemacht habe.

    Das mache ich immer so, damit es beim nächsten Mal schneller geht, wenn alle Schritte inkl. Linux-Befehle irgendwo stehen.

    Die Doku werde ich demnächst hier posten.

    Dann sollte klar zu erkennen sein, was falsch lief.


    Fang nochmal ganz von vorne an.

    Installier dir ein frisches OS und halte dich dann genau an meine Anleitung von Anfang an. Angefangen bei der Installation von PHP.

    Auf dem Raspi läuft eine Anwendung, die die Heizungsdaten protokolliert und in eine DB schreibt und die Daten anzeigt.

    Den werde ich im Moment nicht neu aufsetzen.

    Ich wollte dort nur zusätzlich phpMyAdmin haben, um komfortblaer auf die DB-Tabellen zuzugreifen.



    Gruß

    meute

  • Hallo,

    meute Was sagt apache2ctl -S ?


    Gruß

    meute