Hdmi sleep mit hdmi_blanking=1

  • Hallo zusammen,

    Ich benutze einen Raspberry um mir im Kioskmode die Webvisu meiner Wago SPS auf meinem Dell Touchmonitor (P2418HT) anzuzeigen.

    Nachdem ich mit dem Ergebnis sehr zufrieden war habe ich dann in Angriff genommen, den Touchmonitor in den Sleep-Modus zu schicken.Habe das im Raspberrydesktop unter Bildschirmschoner so eingestellt. Dann habe ich bemerkt das der Monitor aber immer noch nicht wirklich schläft (keine Ahnung wie die richtige Bezeichnung ist) Auf jeden Fall glimmte er noch recht heftig.

    Habe mir nun einige Foren durchgelesen und bin dann auf "hdmi_blanking=1" gekommen.

    Das war scheinbar für mich des Rätsels Lösung! Jetzt wird er bei nicht Benutzung ganz dunkel und ist anscheinend im Stromsparmodus und wenn man ihn antippt ist er gleich wieder munter und zeigt was er soll!

    Jetzt würde ich euch gerne um Hilfe bitten mit diesen Cronjobs/crontab.

    Ich versteh absolut nicht wie ich das eingeben soll.

    Ich hätte gerne diese "hdmi_blanking=1" sache von 20:00-07:00 und sonst nicht. Das dieses glimmen des Bildschirms quasi in der Nacht ganz weg ist, der Bildschirm ausserhalb dieser Zeit aber immer an ist.

    Könnte mir bitte jemand sagen wie ich das eingebe. Bin leider voll der Linux spasti.

    Danke sehr

    Patrick

  • Go to Best Answer
    • Best Answer
    • Official Post

    Stimmt, Du willst ja einen "Bildschirmschoner".

    Das Wichtigste zuerst: Es wäre hilfreich, wenn eine SSH-Verbindung existiert, falls was schief läuft. Dort müssen aber alle Befehle mit einem vorangesetzten DISPLAY=:0 abgesetzt werden, also für deaktivieren dann:

    Code
    DISPLAY=:0 xset -dpms

    Versuch mal folgendes im Terminal:

    Code
    xset dpms 60 60 120

    Nach 60 Sekunden in den Standby und nach 120 Sekunden abschalten. Die Zeiten kannst Du anpassen.

    und aktivieren mit

    Code
    xset +dpms

    Jetzt sollte der Monitor nach 2 Minuten ausgehen und sich durch den Touch wieder anschalten lassen.

    Den Status sieht man mit

    Code
    xset q

    Deaktivieren kann man das ganze mit

    Code
    xset -dpms

    Wenn das funktioniert, sehen wir weiter.

  • Ja, scheint zu funktionieren. Standby 60 und Suspend 60 wird bei mehrmaligen abfragen 0. -> Monitor ist on.

    und nach späterer Statusabfrage ist Standby 0 Suspend 0 Off 120 -> Monitor OFF.

    Ich nehme mal an das der Monitor wirklich off ist, weil ich bin eigentlich gar nicht vor Ort.

    Und das jetzt in einem Cronjob?

    Edit: Soll ich das hdmi_blanking=1 wieder rausnehmen?

    Edited once, last by marsmaennchen (August 25, 2020 at 7:56 PM).

  • Ich nehme mal an das der Monitor wirklich off ist, weil ich bin eigentlich gar nicht vor Ort.

    Das sind aber genau die springenden Punkte um die es geht! Ist der Moni aus und lässt der sich beim Betatschen auch wieder aktivieren bis zum nächsten Standby. ;)

    Die Cronjobs sollten dann kein Problem sein.

    Edit: Soll ich das hdmi_blanking=1 wieder rausnehmen?

    Wenn das alles funktioniert, dann ja.

  • okay,dann schau ich das morgen auf der Baustelle. Lt.VNC Viewer wird der Bildschirm schwarz und bei Mausbewegung wacht er auf!

    Vielen vielen Dank bis jetzt schon mal, du hast mir sehr geholfen.

    Ich meld mich morgen wieder!

    MfG

    Patrick

  • Ich habe mal mitgelesen, da mich das Thema interessiert, und die Befehle von hyle eingegeben. Dmps ist aktiv, der Bildschirm wird nach 60 Sekunden schwarz, aber nicht abgeschaltet; die Hintergrundbeleuchtung ist noch aktiv, der Monitor geht nicht in den Stand-by. Unter Windows 10 Pro klappt das.

    Zum Monitor: Samsung 27-Zoll Curved mit HDMI- und Displayport. Die Eingänge werden manuell umgeschaltet. Am HDMI-Port hängt ein Pi4 4GB mit aktuellem Buster.

    Bei abgeschalteten Bildschirm sagt DISPLAY=:0 xset q über ssh, dass der Monitor aus sei. Ist er aber nicht.

    Die Hintergrundbeleuchtung ist nach wie aktiv..

    Display Spoiler

    Pi4 V1.1, 4 GB, USB3-Hub, 250 GB SSD, Bullseye 64, Mate-Desktop, SD-Card Extender (ruht)
    Pi3b Pihole (Buster)
    Pi3b, 128-GB-SSD, Buster, mit 10,1" Monitor als MM (ohne Spiegel ;) )
    orangepi zero, ohne Beschäftigung
    Pi 5 4 GB im GeekPi-Gehäuse mit externer SSD (Bookworm)


    Warnung: Raspi und Co. machen süchtig! :)

    Edited once, last by Urs-1956 (August 25, 2020 at 10:09 PM).

  • Bei mir funktioniert das Abschalten des Monitors mit einem RPi 4B 4GB (Buster), aber nicht mit einem RPi 2 (Buster). Der geht zwar in den Standby, aber die Hintergrundbeleuchtung bleibt an.

  • Dann hängt es wohl auch am Zusammenspiel zwischen PI und Monitor oder dem verwendeten Kabel oder.......

    Display Spoiler

    Pi4 V1.1, 4 GB, USB3-Hub, 250 GB SSD, Bullseye 64, Mate-Desktop, SD-Card Extender (ruht)
    Pi3b Pihole (Buster)
    Pi3b, 128-GB-SSD, Buster, mit 10,1" Monitor als MM (ohne Spiegel ;) )
    orangepi zero, ohne Beschäftigung
    Pi 5 4 GB im GeekPi-Gehäuse mit externer SSD (Bookworm)


    Warnung: Raspi und Co. machen süchtig! :)

  • Bei mir stimmen die Zahlen (s.o), aber der Monitor geht trotzdem nicht in den Stand-by. Ich werde das bei Gelegenheit mit einem ChromeBook testen.

    Nebenbei: Die Standardkonfiguration scheint 600 600 1200 zu sein.

    Display Spoiler

    Pi4 V1.1, 4 GB, USB3-Hub, 250 GB SSD, Bullseye 64, Mate-Desktop, SD-Card Extender (ruht)
    Pi3b Pihole (Buster)
    Pi3b, 128-GB-SSD, Buster, mit 10,1" Monitor als MM (ohne Spiegel ;) )
    orangepi zero, ohne Beschäftigung
    Pi 5 4 GB im GeekPi-Gehäuse mit externer SSD (Bookworm)


    Warnung: Raspi und Co. machen süchtig! :)

  • Ich habe bis jetzt nur gesehen das er dunkel wird. Ob die Hintergrundbeleuchtung auch aus ist sehe ich erst in der Nacht, da fahr ich kurz auf die Baustelle und schau nach.

    Wenn die Hintergrundbeleuchtung weiter leuchtet bringt mir das wenig, weil dann ist der Raum hell beleuchtet.

    Na mal sehen.

  • Ich habe bei Deinem System eigentlich große Hoffnung, weil es mit hdmi_blanking=1 funktionierte. Lass hdmi_blanking=1 mal bitte noch aktiviert.

    hdmi_blanking

    The hdmi_blanking command controls what happens when the operating system asks for the display to be put into standby mode, using DPMS, to save power. If this option is not set or set to 0, the HDMI output is blanked but not switched off.

    Ich drücke die Daumen!

  • Für den Pi4 habe ich diese Aussage bei raspberrypi.org gefunden:

    On the Raspberry Pi 4, setting hdmi_blanking=1 will not cause the HDMI output to be switched off, since this feature has not yet been implemented.

    Quelle:

    Daher brauche ich da gar nicht weiter zu suchen =O=O=O

    Display Spoiler

    Pi4 V1.1, 4 GB, USB3-Hub, 250 GB SSD, Bullseye 64, Mate-Desktop, SD-Card Extender (ruht)
    Pi3b Pihole (Buster)
    Pi3b, 128-GB-SSD, Buster, mit 10,1" Monitor als MM (ohne Spiegel ;) )
    orangepi zero, ohne Beschäftigung
    Pi 5 4 GB im GeekPi-Gehäuse mit externer SSD (Bookworm)


    Warnung: Raspi und Co. machen süchtig! :)

  • hier ist es 4.19.75v64

    Display Spoiler

    Pi4 V1.1, 4 GB, USB3-Hub, 250 GB SSD, Bullseye 64, Mate-Desktop, SD-Card Extender (ruht)
    Pi3b Pihole (Buster)
    Pi3b, 128-GB-SSD, Buster, mit 10,1" Monitor als MM (ohne Spiegel ;) )
    orangepi zero, ohne Beschäftigung
    Pi 5 4 GB im GeekPi-Gehäuse mit externer SSD (Bookworm)


    Warnung: Raspi und Co. machen süchtig! :)

  • Urs-1956 Geh mal am Desktop auf Himbeere >> Einstellungen >> Raspberry-Pi-Konfiguration >> Display. Kannst Du dort Screen Blanking aktivieren?

    Ich hatte mal wegen eines anderen Problems(*) den xscreensaver installiert und damit kann ich dort Screen Blanking nicht verstellen, bzw. deaktivieren.


    *) VNC-Verbindung geht verloren Da hatte ich den xscreensaver installiert und danach deaktiviert. Vielleicht ist das ja der Grund, weshalb es bei meinem RPi4 funktioniert? :conf:

  • Screen-Blanking ist dort aktiviert. Teste gerade den xscreensaver

    Display Spoiler

    Pi4 V1.1, 4 GB, USB3-Hub, 250 GB SSD, Bullseye 64, Mate-Desktop, SD-Card Extender (ruht)
    Pi3b Pihole (Buster)
    Pi3b, 128-GB-SSD, Buster, mit 10,1" Monitor als MM (ohne Spiegel ;) )
    orangepi zero, ohne Beschäftigung
    Pi 5 4 GB im GeekPi-Gehäuse mit externer SSD (Bookworm)


    Warnung: Raspi und Co. machen süchtig! :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!