Peppy Player, HifiBerry miniAmp, keine Lautstärkeregelung möglich.

  • Peppy Constable-headless auf RPi Zero mit HifiBerry miniAmp installiert und einige Anpassungen vorgenommen:


    Raspi-conf: PW, Wi-fi, Locale, Timezone Keyboard eingerichtet.

    sudo api-get update, dist-upgrade


    Booten vom RPi Zero:

    .asoundrc gelöscht

    /etc/asound.conf hinzugeführt

    pcm.hifiberryMiniAmp {

    type softvol

    slave.pcm "plughw:0"

    control.name "Master"

    control.card 0 }

    pcm.!default {

    type plug

    slave.pcm "hifiberryMiniAmp" }


    /boot/config.txt

    #dtparam=audio=on

    dtoverlay=hifiberry-dacplus


    /home/pi/Peppy/config.txt

    [volume.control]

    type = amixer

    amixer.scale = linear

    amixer.control = Digital


    HifiBery miniAmp wird erkannt:

    aplay -l

    **** Liste der Hardware-Geräte (PLAYBACK) ****

    Karte 0: sndrpihifiberry [snd_rpi_hifiberry_dac], Gerät 0: HifiBerry DAC HiFi pcm5102a-hifi-0 [HifiBerry DAC HiFi pcm5102a-hifi-0]

    Sub-Geräte: 1/1

    Sub-Gerät #0: subdevice #0


    Ein Eintrag der hier geholfen hat : HIFIberry miniAmp aktivieren - Soundkarten - Deutsches Raspberry Pi Forum #11

    Peppy UI:htpp://192.168.178.50:8000/  sehr laut und nicht regelbar

    Mit alsamixer die Grundlautstärke angepasst.

    Über den Web Browser können verschiedene Sender ausgewählt werden,

    aber die Lautstärke kann nicht geregelt werden .

    Über amixer sset Master 50% kann geregelt werden! 

    Vielen Dank schon mal im Voraus für ein Denkanstoß

    Thomas

  • Nach Änderng von amixer.control = Digital >>> amixer.control = Master
    läßt sich die Lautstärke über die Web UI regeln


    /home/pi/Peppy/config.txt

    [volume.control]

    type = amixer

    amixer.scale = linear

    amixer.control = Digital

  • Kann an den Berechtigungen liegen.


    Das hier hat mir geholfen


    So I guessed that it's maybe right management stuff. So I did :


    ls -l /usr/bin/amixer

    -rwxr-xr-x 1 root root 42517 Jun 18 13:29 /usr/bin/amixer


    Berechtigung für alle setzen:

    sudo chmod a+X /usr/bin/amixer

    Benutzer zur Audio-Gruppe hinzufügen:

    usermod -a -G audio root

    usermod -a -G audio pi



    And I Edited the /etc/mpd.conf to:

    audio_output {

    type "alsa"

    name "My ALSA Device" mixer_type "software" # <--------- changed from "hardware" }

    -------------

    vi /usr/share/alsa/alsa.conf


    defaults.ctl.card 1

    defaults.pcm.card 1

    -------

    Audiokanäle Namen auflisten:

    aplay -l


    ggf:
    Changed names (e.g. Headphone) need to be updated in /etc/mpd.conf, settings/global.conf and settings/Audio_iFace_Name.