Kein Sound mehr auf Klinke nach upgrade auf Raspian 2020-08-20

  • Hallo zusammen


    Folgende Hardware:

    Raspberry Pi 4 / 4 GB RAM / 16 GB SD Karte.

    OS: Raspian 2020-08-20 Lite ohne Desktop (nur Konsole)

    Monitor: MiniHDMI zu DVI (keine Lautsprecher am Monitor)


    Wir hatten die Raspi Version Februar 2020 installiert.

    Nun das erste, was wir jeweils machen ist, update + upgrad.


    Dann hatten wir ein normales mp3 File im Crontab verlinkt welches beim Booten ausgegeben werden soll. (@rebeoot ...).

    Das Soundfile wir über das Programm mpg321 ausgegeben.

    Vor dem Update hatten wir damit keine Probleme und es hat reibungslos funktioniert.


    Beim raspi-config konnte man unter Advanced > Audio > Headphone 3,5mm einstellen.


    Nach dem Upgrade auf die neuste Version gibt es diesen Punkt "Headphone" nicht mehr.

    Beim booten bleibt der Lautsprecher still und das Soundfile wird nicht abgespielt bzw. ausgegeben. Im Syslog finde ich aber das Ausführen des Befehls und der Cronjob zu sehen.


    Spiele ich das Soundfile aber manuell ab, funktioniert es.


    Ich habe auch schon im alsa Configfile diverse Einstellungen vorgenommen, aber alles hatte nichts geholfen.

    Nur ein altes Raspian installieren.


    Kennt das jemand?

    Wir brauchen das im Geschäft unbedingt.


    Grüsse Samigasi

  • samigasi

    Changed the title of the thread from “Kein Sound mehr auf Klinke nach upgrade auf Raspi 2020-08-20” to “Kein Sound mehr auf Klinke nach upgrade auf Raspian 2020-08-20”.
  • Hi hyle


    Oh, jetzt bin ich nicht mehr sicher ob Headphones stand.

    Ich schaue am Montag nach.


    Aber diese Option hatte ich auch schon umgestellt ohne Erfolg.

    Es muss etwas mit dem Update zu tun haben, da es mit dem Raspian Oktober oder November 2019 und Februar 2020 noch ging....

    Seltsam...


    Gruss Samigasi

    • Official Post

    Es muss etwas mit dem Update zu tun haben, da es mit dem Raspian Oktober oder November 2019 und Februar 2020 noch ging


    Hat es sicher auch, denn:

    2020-05-27:

    [...]

    * Internal audio outputs enabled as separate ALSA devices


    Ist bei dem Befehl zu mpg321 evt. ein Audiodevice mit der Option -a angegeben?

  • Ach das hatte ich in den Release Notes übersehen.


    Die Option -a kannte ich noch nicht. Ich denke, das ist es.

    Leider kann ich es erst am Montagvormittag testen.


    Ich melde mich danach nochmals obs geklappt hat.


    Danke und Gruss

  • Hallo samigasi,


    ich habe das gleiche Problem mit der Tonausgabe seit "Raspian 2020-08-20".
    Falls Du was rausgefundne hast, melde dich bitte.

    Habe schon Nächte verbracht, abert nix ging.


    lg

    • Official Post