startX mit Optionen beim booten ausführen

  • Hallo,

    an meinem Raspberry 3b+ (operarating system Pi OS, Debian Buster 20/08/2020) ist das DSI 7" Touch Display angeschlossen.

    Zusätzlich noch ein Monitor an HDMI.

    Wenn ich den Raspberry in CLI starte, dann "startx -- -layout Multihead" eingebe,

    ist das DSI Display der Hauptmonitor und der HDMI Monitor erweitert daneben, so wie gewünscht.


    Welche Einstellungen muss ich vornehmen, damit "startx -- -layout Multihead" beim booten automatisch ausgeführt wird?


    Danke für euer Feedback.

  • Eigentlich sollte es reichen, wenn Du in raspi-config "bis ins Grafiksystem booten" aktivierst.

    In den GUI-Einstellungen kannst Du dann noch die Anzahl der Monitore einstellen, wenn nicht schon die beiden in der gewünschten Reihenfolge erscheinen.


    Manuell würde ein X-Host-Admin es so konfigurieren, wie es in < man startx > und den dortigen SEE ALSOs beschrieben ist.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Hallo,

    in raspi-config "bis ins Grafiksystem booten" habe ich aktiviert.

    Leider ohne Erfolg. HDMI Monitor bleibt schwarz.

    "startx -- -layout Multihead" muss ich irgendwie automatisch starten lassen.

    Habe mal weiter gegoogelt: in /etc/X11/xinit/xinitrc soll das rein. Aber hier steht nur SESSION drin.

    Keine Ahnung was da aufgerufen wird.

    Wo genau kann ich die Anzahl der Monitore einstellen? Habe einen Pi3. Denke die Einstellung mit der Anzahl der Monitore geht nur bei Pi4? Oder liege ich falsch?


    Hoffentlich bis bald.... und Danke.

  • Wenn Du nicht ins Grafiksystem automatisch booten kannst, hast Du bei der Installation vermutlich Mist gebaut. Deshalb startet das Grafiksystem vermutlich nur mit startx.


    Ein Display hängt bei Dir am Display Port (Flachbandkabel) und ein Monitor/TV am HDMI Port.


    Wie Du das konfiguriert hast, dass es nur mit startx funktioniert, weiss ich nicht.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Hallo,

    ich habe das System neu aufgesetzt. In raspi-config bei Boot: ToDesktop eingestellt, funktioniert.

    Jetzt schließe ich den HDMI Monitor an und konfiguriere, dass Display und HDMI angesteuert werden.

    Nach Neustart auf HDMI kein Bild.

    Jetzt in raspi-config bei Boot: CLI und Neustart. Nach dem hochlaufen gebe ich in der Kommandozeile "startx -- -layout Multihead" ein.

    Auf dem HDMI Monitor ist ein "erweitertes" Bild zu sehen, auch Display funktioniert!

    Mein Ziel ist es nun, dass ohne Kommandozeileneingabe "startx -- -layout Multihead" im Bootvorgang gestartet wird und

    ich auf HDMI und Display ein Bild angezeigt bekomme.

    Wenn ich auf Boot: ToDesktop stellen funktioniert HDMI nicht. D.h. ich muss irgendwo "startx -- -layout Multihead"

    anstatt von nur "startx" (wird Boot: ToDesktop ausgeführt) einstellen. Wo?


    Tschau...

  • Dann musst Du Dich durch die Videoeinstellungen in der /boot/config.txt quälen.

    documentation > configuration > config-txt

    https://www.raspberrypi.org/do…figuration/hdmi-config.md

    https://www.raspberrypi.org/do…n/configuration/arandr.md

    Auch sind unter Hardware und Usage Guide von https://www.raspberrypi.org/documentation/ Hints zur Videoeinstellung enthalten

    Ich bin auch nur Linzx Anwender und habe keinen Pi4 und kein Display. Ich kann Dir daher kein: "Bei mir funktioniert es so" liefern.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Jedes Grafikprogramm (ausser xlogin) braucht einen angemeldeten User. Den gibt es bei der Abarbeitung von rc.local noch nicht.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Habt ihr mittlerweile eine Lösung gefunden?


    Habe das gleiche Problem (zwar hab ich nen PI 4) kann wegen RDP nur den Legacy Treiber benutzen und muss beim starten den Parameter -Multihead mitgeben.


    Gruß

    Andreas