Raspberry mit NAS verbinden - wie?

  • Hallo Leute,


    bin ganz neu hier und habe keine Vorkenntnisse, dafür aber ein Problem, welches ich selbst gelöst bekomme. Google hilft mir nicht so ganz, weil ich keine Anleitung finde, die ich in meine im Netzwerk installierten Komponenten anwenden kann.


    Installierte Komponenten:

    -PPi4+ mit Raspbian als Server, TVHeadend 4.2.8 (192.168.xxx.100) - funktioniert

    -RPi3+`s mit Kodi und Libreelec als Clients mit TVheadend HTSP Client (z.B.192.168.xxx,201) - Life TV über SAT funktioniert auf allen Client`s

    -Synology DS220+ (192.168.xXx.30) soll als Medien-Server laufen für Aufnahmen (Verzeichnis "/aufnahme" ist erstellt) und Wiedergabe ("/video")


    Wenn ich im Client in Kodi auf "Nach einer neue Quelle suchen" auf "NFS" gehe, wird mir die IP vom NAS (192.168.xxx.30) angezeigt aber keine Unterverzeichnisse.

    Wie das mit Aufnahmen zu konfigurieren ist, weiß ich auch nicht.


    Was muß ich tun, damit es funktioniert?

    Bitte hiermit um Hilfe aber so, daß es auch ein Leie versteht.

    Vielen Dank im Voraus.

  • Hallo Leute,


    bin ganz neu hier und habe keine Vorkenntnisse, dafür aber ein Problem, welches ich selbst gelöst bekomme.

    Moinsen,

    Na, dann ist doch alles superduper...

    :)

    Hast du ggf die Firewall auf der synology aktiviert, falls ja, passende Regeln gesetzt?

    Sind die Ordner auf dem NAS für den raspberry client/User freigegeben (leserechte)?

    Grüßle,

    the other



    Gesund bleiben! Abstand halten! Mund-Nasen-Schutz tragen! Freundlich bleiben!

  • Hi the other,


    danke für die schnelle Antwort.

    Firewall ist aus NAS nicht aktiv. Ich habe eine Benutzergruppe raspberry mit Schreib-/Leseberechtigung und Benutzer raspberry mit den gleichen Berechtigungen für beschriebene Verzeichnisse erstellt.

  • Du musst bei den Shared Folders auf der Syno bei den nfs Permissions die IP des Clients freigeben ;)


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

    Edited 3 times, last by framp ().

  • Ist also erledigt :thumbup: Dann bitteden Thread auch noch auf erledigt setzen ;)

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • Ich habe ein Problem mit dem mounten von einem Windows Laufwerk beim Starten von Raspi.

    In der Datei /etc/fstab steht die Zeile

    sudo mount -t cifs //192.168.188.20/files /mnt/smb -o user=werne,domain=\\LAPTOP-DN1KTGM4,pass=xxxxxx


    Wenn ich "sudo mount -a" eingebe, dann kommt der Fehler "parse error at line 7".

    Das Laufwerk wird erst gemountet wenn ich in der Konsole den Befehl direkt eingebe, also:

    sudo mount -t cifs //192.168.188.20/files /mnt/smb -o user=werne,domain=\\LAPTOP-DN1KTGM4,pass=xxxxxx


    Das ganze verstehe ich nicht. Wie kann ich das Windows Laufwerk (files) denn automatisch beim Start von Raspi mounten?

    Raspi 4 mit 8GB Ram, 128GB SD-Card

    Rasbian GNU/Linux 10 (buster) mit installiertem IOBroker

  • Du solltest zunächst die Zeile in der fstab löschen, dann < man fstab > durchlesen, danach die Forensuchfunktion verwenden, und zuletzt für Dein Problem, wenn es noch existiert, einen neuen Thread eröffnen.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • ... zumal es hier im Thread nicht um samba sondern nfs und Synology geht :no_sad:

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)