Raspberry nach Stromausfall teilweise nicht mehr erreichbar

  • was anderes, die Backups vom ioBroker liegen in "/opt/iobroker/backups"

    Wie bekomme ich die da rauskopiert, bzw kann ich die SSD an einem anderen RaspPi mounten und von da aus auf die Backups zugreifen?

  • BTW: Sein PI ist so konfiguriert, dass er root-Rechte zum runterfahren braucht bzw. er hat eine SSD und keine SD-Karte.

    Mit < systemctl reboot > gehts (manchmal/meistens) auch ohne root-Rechte


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Mit < systemctl reboot > gehts (manchmal/meistens) auch ohne root-Rechte

    Das kann der TE ja mal testen.

    Hier geht es damit nicht:

    Code
    :~ $ systemctl reboot
    Failed to set wall message, ignoring: Interactive authentication required.
    Failed to reboot system via logind: Interactive authentication required.
    Failed to start reboot.target: Interactive authentication required.
    See system logs and 'systemctl status reboot.target' for details.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • BTW:


    Ich glaube, dieser lange Thread ist die allerbeste Begründung, warum ich meine 2 wichtigsten Pi mit einer PIUSV versehen habe.

    Bei Stromausfall werden diese nach 10 Minuten sauber und ohne Schaden heruntergefahren.

    Das ist es mir (meinen Nerven) und meinen beiden Pi wert.

  • So, jetzt noch was:

    Ich habe den vesucht, Raspbian neu zu installieren. Der RaspPi 4 bootet, von SD-Karte und von SSD. Da Habe ich eine 256GB m.2SATA mit einem Kontroller von Startech. Ich habe die gleichen Komponenten schon an einem RaspPi verwendet, das funktioniert hervorragend. Jetzt mein Problem: ich bekomme, wenn der RaspPi von SSD bootet keinen Zugriff per SSH. Boote ich den PaspPi von SD, klappt der SSH zugriff. Ich bin genau so vorgegangen wie immer, habe eine Datei "ssh" erstellt, also alles so, das es klappen sollte. Der RaspPi bootet auch von der SSD, aber ich erhalte keinen ZUgriff über putty. Von jedem anderen Rechner im Netz kann ich diesen RaspPi anpingen, es kommt auch sofort eine Antwort. Wo könnte das Problem liegen? Leider habe ich (noch) kein Mini-HdmI Kabel, um den RaspPi direkt am Monitor anzuschließen.

    Weniger anzeigen

    ANTWORTEN



  • Jetzt mein Problem: ich bekomme, wenn der RaspPi von SSD bootet keinen Zugriff per SSH.

    Kannst Du den (lauschenden) ssh-TCP-Port (22) erfolgreich scannen, wenn dein PI von der SSD bootet?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Also ich kann den entsprechenden RaspPi von allen anderen Rechnern (ich hab hier einen Win10 PC, ein Win10 Laptop, mehrere RaspPis) anpingen, es kommt sofort eine Rückmeldung, 0 Pakete Verlust.

    Und nein, ich erreiche den RaspPi über ssh Port 22 nicht erreichen.

  • Lade dir ein ISO für ein Linux Live System ( Knoppix o.ä. ) runter und erstelle damit eine bootbare(n) CD/DVD/USB-Stick. Damit kommst Du evtl. mit einem anderen Rechner noch an deine Daten bzw. kannst Du die Datenträger des RPi überprüfen. ( Alle anderen Maßnahmen werden vermutl. nicht funktionieren, wenn das Filesystem des RPi durch die unzeitigen Netztrennungen korrupt ist. )

  • Ich glaube, dieser lange Thread ist die allerbeste Begründung, warum ich meine 2 wichtigsten Pi mit einer PIUSV versehen habe

    Und es ist auch die allerbeste Begruendung warum man seine Raspis regelmaessig sichern sollte :shy: In solchem Falle einfach Backup einspielen und gut ist ;)


    Kein Backup - kein Mittleid


    <OT>Was fuer eine USV hast Du denn im Einsatz?</OT>

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • Lade dir ein ISO für ein Linux Live System ( Knoppix o.ä. ) runter und erstelle ...

    Es reicht auch ein Pi OS light (oder irgendei Linux-OS) auf einer anderen SD, wenn man die korrupte SD in einen USB-Cardreader am Pi steckt.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • So, da bin ich wieder.

    Hat etwas gedauert, habe an meienm Problem gearbeitet, leider mit wenig Erfolg.


    Zuerst habe ich eine SD-Karte verwendet, SanDisk Extrem 128GB, Diese habe ich unter Windows 10 mit SD-Formatter formatiert. Danach mti Etcher das RaspBian Image 2020-02-13-raspbian-buster-lite auf die SD-Karte geflasht. Dann die SD-Karte in den Raspberry (RPI4 B), das booten von der Karte funktioniert. Als nächstes habe ich nach folgender Anleitung eine bootfähige SSD erstellt:

    https://www.youtube.com/watch?v=LOGTT2dLqV8


    Bootloader Version prüfen:

    vcgencmd bootloader_version


    Updates durchführen:

    sudo apt-get update

    sudo apt-get full-upgrade -y

    sudo reboot


    USB-Geräte anzeigen:

    sudo lsblk


    FDISK | Festplatten-Informationen anzeigen lassen:

    sudo fdisk -l


    FDISK | Festplatte auswählen und löschen:

    sudo fdisk /dev/sda

    Löschen:

    Command: d

    Partitionen anzeigen:

    Command: p

    Speichern der Änderungen:

    Command: w


    Variable in der Datei epi-eeprom-update abändern:

    Öffnen der Datei:

    sudo nano /etc/default/rpi-eeprom-update

    Wert ändern auf:

    FIRMWARE_RELEASE_STATUS="stable"


    Bootloader updaten:

    cd /lib/firmware/raspberrypi/bootloader/stable/

    ls -l

    sudo rpi-eeprom-update -d -f pieeprom-[Aktuelles Datum].bin


    Clone-Script:

    Über Github herunterladen:

    git clone https://github.com/billw2/rpi-clone.git

    cd rpi-clone

    sudo cp rpi-clone rpi-clone-setup /usr/local/sbin


    Klon-Vorgang starten:

    sudo rpi-clone -l sda


    Das hat auch alles funktioniert. Als SSD verwende ich eine 250GB WB Blue SATA m.2.

    Der Kontroller ist von Startech, USB zu M.2 Converter, steck in eine USB 3 Port.


    Nach dem erstellen der SSD habe ich den RPI runter gefahren, SD-Karte entfernt, und konnte

    von der SSD booten.


    Genau ein mal konnte ich von der SSD booten, gleich nach dem erstellen der SSD.


    Da der RPI 4 einen MicroHdmi Ausgang hat und hier kein entsprechendes Kabel vorhanden war, habe ich einen Adapter bestellt, um den RPI direkt am Monitor beobachten zu können.


    Habe das gerade angeschlossen und getestet, mit dem Ergebnis, das der RPI von der neu erstellten SSD nicht mehr bootet.


    Ich habe die Ausgabe des Bootvorgangs Bilder gemacht.

    Kann es leider nur als Bild hier einstellen.



    Danach habe ich die SSD vom RPI getrennt und die SD-Karte eingesetzt, von welcher ich diese SSD erstellt, geklont, habe, Und was soll ich sagen, auch von dieser SD-Karte ist das Booten nicht möglich.




    Als nächste habe ich in diesem Zustand (Eingeschaltet mit SD-Karte als Bootmedium) die SSD an der USB-Port angeschlossen. Die SSD wurde erkannt, Ergebnis:



    RPI von Strom getrennt, als letztes dann wieder die SSD eingebaut, die bis zum Stromausfall hervorragend funktioniert hat.


    Diese SSD bootet sofort ohne Probleme, der ioBroker startet durch und funktioniert. Das einzige Problem hierbei ist, das ich der RPI nicht mehr per SSH erreichen kann, wie oben geschrieben.


    Auch hier habe ich den Monitor angeschlossen, und eine Tastatur.

    Nach dem Bootvorgang wird der LoginPrompt angezeigt, Solbad ich da den Benutzernamen eingebe und die Enter-Taste drücke um zu PW Eingabe zu gelangen, kommt sofort, ohne das ein PW eingeben wurde, Login Incorrect.


    Ich bin jetzt so ein bisschen ratlos.

    Hoffentlich habe ich mein Problem richtig dargestellt und jemand hat noch eine Idee.


    Danke


    Thomas

  • raspi-config oder datei ssh in die boot partition

    Ähm. ich verstehe jetzt nicht genau, wie du das meinst. Ich habe auf der SD-Karte, die mit Etcher geflasht wurde, natürlich eine Datei "ssh" erstellt, Ich konnte ja auch einmal von der Karte booten, mit Zugriff über SSH.

  • raspi-config oder datei ssh in die boot partition

    BTW: Lt. Beitrag #34 kann der TE sich an dem OS, wenn von SSD gebootet, nicht mehr, als den konfigurierten Benutzer (mit Bildschirm und Tastatur) anmelden:

    Quote


    Nach dem Bootvorgang wird der LoginPrompt angezeigt, Solbad ich da den Benutzernamen eingebe und die Enter-Taste drücke um zu PW Eingabe zu gelangen, kommt sofort, ohne das ein PW eingeben wurde, Login Incorrect.

    D. h., da geht erstmal kein raspi-config und auch kein direkter Eintrag in die boot-Partition. Auch wenn der sshd über Umwege gestartet werden kann bzw. gestartet werden sollte, wird der TE sich z. Zt. via ssh nicht anmelden können.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Als nächstes habe ich nach folgender Anleitung eine bootfähige SSD erstellt:

    Okay ...

    Diese habe ich unter Windows 10 mit SD-Formatter formatiert.

    Das brauchst Du nicht, wenn Du das Image einspielst wird sowieso alles wieder überschrieben.

    Du schädigst damit allerhöchstens die SD-Karte.

    Dann benutzt Du das Image RaspBian Image 2020-02-13, hat das einen Grund

    oder warum benutzt Du das Image vom 2020-08-20 nicht?


    Aber starte mal folgenden Versuch:


    Ein Image davon auf die SD-Karte flashen und ohne SSD erstmal booten.

    Ein kleines bißchen einrichten (Sprache und Tastatur) und dann erstmal ein:

    sudo apt update && sudo apt full-upgrade

    Warscheinlich ist dann erstmal ein reboot fällig.


    Dann ruftst Du folgende Seite auf:

    [Tutorial] Eine unendliche Geschichte: Raspberry 4B und USB-Boot

    Dort arbeitest Du Kapitel 2 und 4 ab und meldest Dich dann wieder.


    MfG


    Jürgen


  • OK. danke, das mache ich . Das Image 2020-02-13 habe ich verwendet, weil ich das auch für die Installation verwendet habe, die bis vor einigen Tagen (zum Stromausfall) super funktioniert hat. Aber daran hatte ich auch schon gedacht, ich werde mal das neuste Image verwenden.

    Edited once, last by hyle: Ein Beitrag von Atticus mit diesem Beitrag zusammengefügt. ().