Usb-Stick Probleme beim Einhängen mit CLI

  • Hallo,

    also irgendwie stehe ich gerade auf der Leitung!?

    Ich habe mit CLI keinen Zugriff auf den Usb-Stick,wenn ich mit Desktop boote geht das.


    Wo könnte denn da der Fehler sein?


    sudo blkid -o list -w /dev/null

    /dev/sda1 ext4 usb-stick /media/pi/usb-stick bff9e2d7-09ed-4559-bf1f-ee1c52bd1638


    Und so hab ich es dann in fstab eingetragen:

    UUID=bff9e2d7-09ed-4559-bf1f-ee1c52bd1638 /media/pi/usb-stick/ ext4 defaults,noauto,nofail 0 0



    Gruß

    Timbu

  • Go to Best Answer
  • mit CLI keinen Zugriff auf den Usb-Stick,wenn ich mit Desktop boote geht das.
    Wo könnte denn da der Fehler sein?

    Der Dateimanager im Desktop kann USB Laufwerke einhängen. Und bevor Du etwas in die fstab einträgst, versuche es doch erst einmal händisch mit mount, dann siehst Du sofort die Fehlermeldungen.


    man mount

  • $ sudo umount /media/pi/usb-stick

    sudo mount -t ext4 -o defaults /dev/sda1 /media/pi/usb-stick


    Gibt keine Fehler,jedenfalls im Desktop Betrieb...


    Und ohne Desktop,muss ich den stick aber manuell mounten und auch keine Fehler...ist der fehler also in fstab?


    Wer findet den Fehler,möchte das ungern über einen Cronjob machen.

    • Best Answer

    Und so hab ich es dann in fstab eingetragen:

    UUID=bff9e2d7-09ed-4559-bf1f-ee1c52bd1638 /media/pi/usb-stick/ ext4 defaults,noauto,nofail 0 0

    Schau mal in < man mount > im Kapitel der FILESYSTEM-INDEPENDENT MOUNT OPTIONS nach, was die Option "noauto" bewirkt.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • afaik wird nur in der grafischen Oberfläche USB-Sticks/Platten automatisch gemountet.

    Danke für deine Erkenntnis ,aber deswegen beschäftige ich mich auch mit der Datei fstab.



    Schau mal in < man mount > im Kapitel der FILESYSTEM-INDEPENDENT MOUNT OPTIONS nach, was die Option "noauto" bewirkt.

    Ja das mit noauto war mal gedacht damit es eben keine Probleme gibt...!


    Vielen Dank :bravo2: