WLAN geht beim aktuellen Raspian OS Lite (buster) nicht

  • Hallo,

    nachden Blaubarschbube in Beitrag #12 aufgegeben hat, möchte ich mehr Klarheit.


    über LAN komme ich auf den RPi 3B, über WLAN nicht.

    mit der gleichen SD-Karte war ich mit einem lange nicht verwendetem RPi Zero W im WLAN.


    Model: RPi 3B

    OS: 2020-08-20-raspios-buster-armhf-lite.zip

    Router: Fritz!Box 7390


    headless mit ssh und wpa_supplicant.conf in der boot-Partition

    Was mir als erstes auffällt: die regional domain aus der wpa_supplicant wird nicht übernommen.

    deshalb die Aufforderung: (login über LAN)

    Code
    Wi-Fi is currently blocked by rfkill.
    Use raspi-config to set the country before use.

    nachdem ich den wifi-country mit raspi-config gesetzt habe, sind die Kommentarzeilen verschwunden.

    Code: /etc/wpa_supplicant/wpa_supplicant.conf
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=DE
    
    network={
        ssid="kle 2.4GHz"
        psk=be...7c
        key_mgmt=WPA-PSK
    }

    nach einem reboot, kommt keine Aufforderung dem country zu setzen, die regional domain ist also gesichert.

    (in /usr/bin/raspi-config kann man nachschauen wie das gemacht wird)


    rpi444 in Beitrag #3 von Blaubarschbube 's Problem mit RPi Zero W) hast Du Infos angefordert,

    hier die meinen (mit RPi 3B):

    Schönen Gruß, kle


    Edit: (auf Hinweis von rpi444 in Beitrag #33) ich benutze eine Passphrase als wpa psk das ist eine "pre-encrypted 32 byte hexadecimal number", deshalb fehlen die Gänsefüßchen.

    The password can be configured either as the ASCII representation, in quotes as per the example above, or as a pre-encrypted 32 byte hexadecimal number. You can use the wpa_passphrase utility to generate an encrypted PSK.

    ...

    Code
     network={
          ssid="testing"
          #psk="testingPassword"
          psk=131e1e221f6e06e3911a2d11ff2fac9182665c004de85300f9cac208a6a80531
      }

    Edited 2 times, last by kle ().

  • über LAN komme ich auf den RPi 3B, über WLAN nicht.

    Wie sind die Ausgaben von:

    Code
    cat /etc/default/crda
    ls -la /etc/modprobe.d

    ?

    Ist die SSID in deiner FB evtl. hidden? ... bzw. versuch mal auch ohne Leerstelle und ohne Punkt in der SSID.

    Gibt es evtl. ein aktives 5.0GHz-WLAN auf deiner FB?


    EDIT:


    Benutzt Du eine "WPA PSK" oder eine "ASCII passphrase" (weil ohne "")?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Die sind immer Unterschiedliche wenn die sdcard wo anderst eingesteckt wird.

    Das kenne ich so nicht. Wie hast Du das festgestellt, dass die MAC-Adresse sich ändert?


    EDIT:


    Es gibt kein Problem mit dem aktuellen Raspbian OS lite (buster) und dem WLAN. Habe es gerade getestet.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden


  • Ist die SSID in deiner FB evtl. hidden?

    nein

    Gibt es evtl. ein aktives 5.0GHz-WLAN auf deiner FB?

    ja da hängt ein RPi 3B+ dran.

  • Das kenne ich so nicht. Wie hast Du das festgestellt, dass die MAC-Adresse sich ändert?

    Bei udev rules :) ist die udev rule für die Interface Namänderung (kali sicher), die funktinieren nicht wenn die Karte in einen Neuen Pi eingesteckt wird :)

  • ... Namänderung (kali sicher), die funktinieren nicht wenn die Karte in einen Neuen Pi eingesteckt wird :)

    Kann sein, dass das bei kali so ist. Mit Raspbian gibt es keine Probleme.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Code
    REGDOMAIN=

    Versuch mal dort mit:

    Code
    REGDOMAIN=DE

    In der wpa_supplicant.conf wird dann "country=DE" nicht benötigt. Versuch mal mit deaktiviertem "5.0GHz"-WLAN.

    Es gibt kein Problem mit dem aktuellen buster-lite und WLAN. Ich habe es soeben mit einem neu aufgesetzten Raspbian auf einem PI4/8GB getestet.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Es gibt kein Problem mit dem aktuellen buster-lite und WLAN. Ich habe es soeben mit einem neu aufgesetzten Raspbian auf einem PI4/8GB getestet.

    mein RPi 4B/4GB kommt mit dieser SD-Karte auch ins WLAN, aber der RPi 3B eben nicht,

    egal ob ich in der /etc/default/crda country DE eintrage oder nicht..


    Edit2: ob das 5 GHz WLAN eingeschaltet ist oder nicht, spielt auch keine Rolle.


    Edit: ich habe das Image der Foundation nicht aktuakisiert

    nur mit raspi-config: locale timezone und wifi-country geändert

    Edited 2 times, last by kle ().

  • ... auch ins WLAN, aber der RPi 3B eben nicht,

    Dann versuch mal vorher auf dem PI3, als nicht root, mit:

    Code
    rfkill unblock wlan


    EDIT:


    ... und persistent auf dem PI3, mit:

    Code
    sudo systemctl mask systemd-rfkill

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited 2 times, last by rpi444 ().

  • der wifi country DE wird ja erkannt, nachdem ich ihn mit raspi-config gesetzt habe, zumindest wird man nicht mehr nach dem Login aufgefordert ihn zu setzen.

    Ich werde morgen beides: rfkill... und systemctl mask..., probieren.

    Danke, kle

  • bin über LAN per ssh auf dem:

    Code
    pi@raspberrypi:~ $ sudo cat /proc/cpuinfo|egrep "^Hardware|^Revision|^Model"
    Hardware    : BCM2835
    Revision    : a02082
    Model       : Raspberry Pi 3 Model B Rev 1.2
    Code
    pi@raspberrypi:~ $ rfkill
    ID TYPE      DEVICE      SOFT      HARD
     0 wlan      phy0   unblocked unblocked
     1 bluetooth hci0   unblocked unblocked

    rfkill sagt: WLAN ist "unblocked".

    Model: RPi 3B

    OS: 2020-08-20-raspios-buster-armhf-lite.zip

    Router: Fritz!Box 7390

    Info: nur ein neues Image blockiert das WLAN (zumindest bei mir) bis ich den wifi country mit raspi-config gesetzt habe.


    Jetzt komme ich mit keinem OS mehr vom RPi 3B ins WLAN.

    Mit der SD-Karte mit dem 2020-08-20-raspios-buster-armhf-lite.zip, komme ich mit allen anderen (RPi Zero W, RPi 2B, RPi 3B+, RPi 4B/4GB) ins WLAN.

    Mein "Thema" ist irreführend.

    (ob ich gestern mal drin war, bezweifele ich inzwischen)

    folgende OS habe ich ausprobiert:

    • pipaos-buster-7.1.img.gz
    • 2020-02-13-raspbian-buster-lite.zip
    • 2020-08-20-raspios-buster-armhf-lite.zip
    • 2019*raspian Desktop/GUI

    seltsamerweise ist das WLAN-Modul nicht ganz defekt, man kann noch scannen, wenn man den wpa_supplicant nicht getötet hat. 1. Versuch

    ob das alles stimmt, ist die Frage - 2. Versuch:

    kann ich meine Probleme noch weiter eingrenzen?

    Hat jemand Vorschläge, wie ich das Thema korrigieren/beenden kann, damit spätere Leser etwas davon haben?

  • Mein "Thema" ist irreführend.

    (ob ich gestern mal drin war, bezweifele ich inzwischen)

    Wie sind die Ausgaben von:

    Code
    systemctl status systemd-rfkill
    rfkill list

    ?

    Hast Du mit einer wpa_supplicant.conf-Datei, im Verzeichnis "/boot", den PI3 gebootet?

    Wie sind jetzt die Ausgaben von:

    Code
    sudo cat /etc/wpa_supplicant/wpa_supplicant.conf
    ls -la /etc/wpa_supplicant/wpa_supplicant.conf
    dmesg | grep -iE 'wlan|brcm|cfg'
    ps aux | grep -i [w]pa

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Code
    pi@raspberrypi:~ $ rfkill list
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
    pi@raspberrypi:~ $


    Hast Du mit einer wpa_supplicant.conf-Datei, im Verzeichnis "/boot", den PI3 gebootet?

    heute noch nicht,

    RPi 3B poweroff und

    die Datei wpa_supplicant.conf auf die boot-Partition der SD-Karte vom RPi 3B geschrieben,

    dann den RPi 3B mit der geänderten SD-Karte gebootet.

  • Code
    pi@raspberrypi:~ $ systemctl status systemd-rfkill
    ● systemd-rfkill.service - Load/Save RF Kill Switch Status
       Loaded: loaded (/lib/systemd/system/systemd-rfkill.service; static; vendor preset: enabled)
       Active: inactive (dead) since Mon 2020-11-02 18:31:26 CET; 5min ago


    psk=be...7c

    Ist dieser Eintrag "psk=be...7c" im network-block richtig? D. h., ohne die ""?


    Versuch mal auch mit:

    Code
    sudo systemctl mask systemd-rfkill

    und rebooten.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ist dieser Eintrag "psk=be...7c" im network-block richtig? D. h., ohne die ""?

    ja, die sind mit wpa_passphrase generiert.

    Code
    pi@raspberrypi:~ $ sudo systemctl mask systemd-rfkill
    Created symlink /etc/systemd/system/systemd-rfkill.service → /dev/null.
    pi@raspberrypi:~ $ sudo reboot
    Connection to 192.168.104.59 closed by remote host.
    Connection to 192.168.104.59 closed.

    nach reboot (mit LAN-Kabel):

    Code
    pi@raspberrypi:~ $ systemctl status systemd-rfkill
    ● systemd-rfkill.service
       Loaded: masked (Reason: Unit systemd-rfkill.service is masked.)
       Active: inactive (dead)

    ohne LAN-Kabel kommt der RPi 3B nicht ins WLAN.

  • nach reboot (mit LAN-Kabel):

    ohne LAN-Kabel kommt der RPi 3B nicht ins WLAN.

    Wie sind jetzt die Ausgaben von:

    Code
    ps aux | grep -i [w]pa
    iwconfig

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Code
    wlan0     IEEE 802.11  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:on

    Versuch mal ohne den generierten WPA-PSK (d. h. nur die passphrase in "" in der config-Datei eintragen).

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden