Hilfe: RPI 4 Buster bootet nicht mehr: Firmware not found

  • Also ohne aktiven Hub würde ich erstmal bei USB 2.0 bleiben.

  • Vorher ging nur USB2.0, bei 3.0 hat der RPI nicht gebootet.

    Das ist der Grund, warum der Adapter unter Bad einsortiert worden ist.


    Ansonsten stimme ich @repa1971 zu, veruchs mal.


    MfG


    Jürgen

  • Ich habe jetzt alle Schritte befolgt, leider ohne Erfolg. Bootet immer noch bis zum bunten Bild.

    Als neuen Adapter bestellen😉


    Wenn ich einen neuen Adapter bestelle, dann muss ich nur die USB ID in der /boot/cmdline anpassen oder?

  • Wenn ich einen neuen Adapter bestelle, dann muss ich nur die USB ID in der /boot/cmdline anpassen oder?

    Wenn Du einen aus der Tabelle Good nimmst, kannst Du den Eintrag wieder rausnehmen.


    MfG


    Jürgen

  • Hallo,


    ich habe gestern meinen RPI mit der SSD mit einem anderen Kontroller ausprobiert. Auch meine SSD an den RPI4 von einem Kumpel. Es kamm immer nur das bunte Bild.

    Mein Kumpel hat die gleiche Konstellation: RPI4 Buster mit SSD ohne SD Karte und aktuelle Updates. Somit müsste es am RPI selber liegen oder?

  • Ich konnte noch die Daten von meinen Unifi Controller sichern, dieser läuft nun auf meinen RPI4 mit SD Karte. Die Haussteuerung läuft momentan auf einem Win10 PC.



    Jetzt würde ich den RPI4 mit SSD komplett neu aufsetzen wollten. Gibt es da eine aktuelle Anleitung, wie ich da am besten vorgehen sollte? Im Netz findet man ja leider viel veralteten Kramm...



    Grüße

  • Wenn du den 4er aktuell und einen kompatiblen Controler in deinem USB3-SATA-Adapter hast, sollte es keine Probleme geben. Vermeide auf alle Fälle JMicron.....

  • prozanko

    Alles was Du tun musst, ist Deinen Raspi von SD Karte hochfahren und wenn Du es noch nicht gemacht hast, eeprom/bootloader updaten.

    Wurde hier ja schon mehrfach erwähnt. Wenn eeprom und Bootloader aktuell und auf stable markiert sind dann kannst Du einfach an Deinem Windows PC mittels "Imager" ein aktuelles Raspberry Pi OS auf die SSD flashen. Wenn Dein Adapter für SSD kompatibel ist, einfach SSD nach dem Flashen an den Raspi hängen einschalten und dann sollte es laufen.

  • Entweder einen aktiven USB 3.0 Hub besorgen oder sich mit der USB 2.0 Geschwindigkeit zufrieden geben, kannst es Dir aussuchen.

  • Das einzige was nicht funktioniert ist das Booten vom USB3.0 Port. Am 2.0 Port funktioniert es.

    Mit welchem Adapter? Neu oder alt? USB-ID?


    MfG


    Jürgen

  • ID 152d:1561 JMicron Technology Corp. / JMicron USA Technology Corp. JMS561U two ports SATA 6Gb/s bridge

    Ist wohl immer noch dieser