wlan0 carrier lost mit Repeatern

  • Hallo zusammen,


    ich habe folgendes Setup: 2 Raspis (192.168.2.43 und 192.168.2.44). 44 ist ein RPi3 B+ mit buster, 43 ist ein Pi4 ebenfalls mit buster. Ich habe einen Telekomrouter unter 192.168.2.1 und einen Repeater im Keller, wo auch die beiden Raspis stehen. Der Repeater hängt einfach an meine SSID ein "_EXT" ran und ich verbinde beide Pis mit eben dem Repeater-Netzwerk. Meine wpa_supplicant.conf sieht folgendermaßen aus:


    Code
    country=DE
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    network={
            ssid="MeinNetzwerk_EXT"
            psk="MeinPwd"
            key_mgmt=WPA-PSK
    }

    Hin und wieder bricht aber beim 44 das Wlan weg bzw. ich bekomme die Fehlermeldung wlan0 carrier lost in syslog. Ich kann ihn dann noch von allen Rechnern pingen, aber ssh z.B. geht nicht mehr von meinem Mac (auch im gleichen 192.168.2-er Netz) aus. Komischerweise, geht ssh aber noch vom 43-er Raspi aus ohne Probleme.


    Hat jemand eine Idee?

  • Hin und wieder bricht aber beim 44 das Wlan weg bzw. ich bekomme die Fehlermeldung wlan0 carrier lost in syslog. Ich kann ihn dann noch von allen Rechnern pingen, aber ssh z.B. geht nicht mehr von meinem Mac (auch im gleichen 192.168.2-er Netz) aus. Komischerweise, geht ssh aber noch vom 43-er Raspi aus ohne Probleme.


    Hat jemand eine Idee?

    Wenn Du in der syslog, die Fehlermeldung "wlan0 carrier lost" bekommst, wie sind dann auf diesem PI (44) die Ausgaben von:

    Code
    iwconfig
    ip a
    route -n
    arp -av

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Wenn Du in der syslog, die Fehlermeldung "wlan0 carrier lost" bekommst, wie sind dann auf diesem PI (44) die Ausgaben von:

    Code
    iwconfig
    ip a
    route -n
    arp -av

    ?

    Momentan liefern die Befehle folgende Ausgaben:

    Code
    route -n:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.2.1     0.0.0.0         UG    303    0        0 wlan0
    192.168.2.0     0.0.0.0         255.255.255.0   U     303    0        0 wlan0
    Code
    arp -av:
    Galaxy-A71-von-Christian (192.168.2.113) at 9a:da:c4:ef:82:57 [ether] on wlan0
    speedport.ip (192.168.2.1) at d0:6f:82:4a:16:86 [ether] on wlan0
    Christians-iMac (192.168.2.119) at b8:09:8a:d1:e0:df [ether] on wlan0
    ? (192.168.2.126) at 9a:da:c4:d8:46:9f [ether] on wlan0
    PC192-168-2-43 (192.168.2.43) at 9a:da:c4:13:44:eb [ether] on wlan0
    Entries: 6    Skipped: 0    Found: 6

    Im Moment ist allerdings der Pi erreichbar und ich habe ihn temporär in das Nicht-Repeater-Netz geholt. Dort habe ich ebenfalls das Problem, dass er irgendwann nicht mehr erreichbar ist. Mal passiert das nach 2 Stunden, mal nach 10 Tagen

  • Ich kann ihn dann noch von allen Rechnern pingen, .... Komischerweise, geht ssh aber noch vom 43-er Raspi aus ohne Probleme.

    Wenn Ping und ssh geht, dann ist die WLAN-Verbindung nicht unterbrochen oder sie war unterbrochen und hat sich sofort wieder hergestellt.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Wenn Ping und ssh geht, dann ist die WLAN-Verbindung nicht unterbrochen oder sie war unterbrochen und hat sich sofort wieder hergestellt.

    Ping geht, aber ssh eben nicht mehr. Das tritt wie gesagt unregelmäßig auf, die Verbindung bleibt dann auch unterbrochen. Um die WLan-Verbindung wieder herzustellen, muss ich mich dann vom 43-er Rechner per ssh auf den 44-er verbinden und ein paar Mal die Wlan-Verbindung versuchen neu herzustellen mittels

    sudo wpa_cli -i wlan0 reconfigure

    oder den Pi ein paar mal rebooten. Irgendwann kann ich dann auch wieder ganz normal darauf zugreifen für die nächsten paar Stunden oder Tage

  • Schau dir mal am Router oder am Repeater oder mit einem Extra Programm wie z.B. Acrylic an, auf welchem Kanal der Repeater sendet!

    Ich hatte da z.B. bei meinem Samsung TV die Erfahrung gemacht, dass er ebenfalls kein WLAN empfängt, obwohl der Router dazu, nur max. 3m weg steht.

    Grund war das der 5GHZ Bereich auf Kanal=Auto gestellt war und 5GHZ WLAN auf Kanal 100 sendete, was wohl mein TV nicht mochte.

    Also Kanal gewechselt auf 36 und der TV hatte sofort mein WLAN erkannt.


    Trifft aber meist leider nur bei 5GHz WLAN zu.

    Bei 2.4GHz WLAN Empfehle ich z.B. mal ein Notebook und einen 2.4/5GHZ WLAN Stick, am besten einer mit Antenne, zu nehmen und mit Acrylic mal die WLAN Umgebung anzusehen.

    Dazu Acrylic ruhig eine Viertel Stunde oder länger laufen lassen.

    Vielleicht sind zu viele WLAN auf dem selben Kanal drauf und stören sich Gegenseitig.

    Wenn ich das mit Acrylic und einem WLAN-Stick mit Antenne mache, komme ich hier in der Gegend auf über 30 WLAN Netze. wovon vom PI vielleicht 5-10 erreichbar wären.

    Auch ist es Interessant, auf welchen Kanälen sich meist die Geräte tummeln, überwiegen auf 3-5 Kanälen.

    Edited once, last by Thomas H ().

  • Ping geht, aber ssh eben nicht mehr. Das tritt wie gesagt unregelmäßig auf, die Verbindung bleibt dann auch unterbrochen.

    Nein, ... wenn der Ping geht, dann kann die Verbindung nicht unterbrochen sein.

    Wenn das erneut der Fall ist, poste zusätzlich auch das Ergebnis des Pings.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden