Motion findet auf einem Raspi den Stream nicht, auf dem anderen schon

  • Hallo,

    es ist leider etwas komplexer, als in der Überschrift.


    Ich habe einen RasPi4/4GB, auf dem läuft ioBroker und MotionEye. Nun habe ich festgestellt, dass seit ich Motion installiert habe, ioBroker langsamer und instabil läuft.

    Also möchte ich mit Motion auf einen anderen RasPi umziehen. Installation usw. alles OK und aktuell.


    Aber Motion auf dem neuen RasPi findet keinen Kamerastream, obwohl der Stream auf dem anderen RasPi übertragen wird.

    In meiner verzweiflung habe ich inzwischen vom funktionierenden RasPi ein Image gezogen, das auf eine neue SD gebracht und nur die IP angepasst. Rest ist so geblieben.

    Motion funktioniert, aber der Stream läuft nicht. Obwohl die Konfiguration völlig identisch ist,


    Ich verstehe es nicht. Als wenn der Stream nur zu dem einen RasPi gelassen wird, nicht aber zu dem neuen RasPi. Der Stream funktioniert im alten TasPi und auch im VLC-Player auf meinem PC.


    Habt ihr eine Ideen, was den Stream irgendwie blockieren oder umlenken könnte?

    Viele Grüße DocAdams

    Viele Grüße
    DocAdams

    1x RaspberryPi 2, 1x RaspberryPi 3, 1x OpenELEC, 1x RaspberryPi 4 mit ioBroker ,

  • Hallo,

    ich hatte zunächst den neuen RasPi mit einem neuen System aufgesetzt und MotionEye installiert.

    Da fand Monion auch nicht den Stream.


    Als mir nichts mehr einfiel, habe ich das Image des alten Streams genommen und auf den neuen RasPi übertragen. Ich erreiche ihn via Putty usw.

    Kontrolliert Motion die MAC des eigenen Systems?


    An IP und MAC der Kamera wurde nichts geändert.


    Der RTSP-Stream lautet

    rtsp://192.168.yyy.13:554/cam/realmonitor?channel=1&subtype=0&unicast=true&proto=Onvif


    Motion auf dem alten RasPi hatte das erkannt.

    Motion auf dem neuen RasPi erkennt den Stream nicht.


    Oder dürfen 2 Motioninstallationen nicht gleichzeitig auf einen solchen Stream zugreifen?

    Viele Grüße
    DocAdams

    1x RaspberryPi 2, 1x RaspberryPi 3, 1x OpenELEC, 1x RaspberryPi 4 mit ioBroker ,

  • Was für eine Kamera?

    Kann es sein, das es an den Einstellungen der Kamera liegt?

    Als Sicherheitsmerkmal. Ohne das Du den Typ der Kamera nennst wird das auch nichts.

    Nicht umsonst wird immer wieder auf diesen Artikel hingewiesen.


    Ist nur ein Verdacht, ich selbst habe nur USB-CAMs und CAMs die an den CSI-Anschluss passen.


    MfG


    Jürgen

  • Hallo,

    sorry, es handelt sich um eine IMOU Bullat Lite 4MP


    An Kameraeinstellungen habe ich auch schon gedacht. Was aber dagegen spricht (mMn) ist, dass der Stream ja beim alten RasPi ankommt.

    Oder zumindest bei der damaligen Installation vor knapp einem Jahr durchkam und nun immer noch erkannt wird. Geändert hat sich eigentlich nur, dass ich das RasPi-OS aktualisiert habe.
    Als ich das Image des alten RasPi auf den neuen RasPi übernommen hatte (inclusive IP-Anpassung), wurde ja sogar die veraltete Motion-Version 4.2.2 und MotionEye Version 0.41 übernommen. Daran kann es also eigentlich auch nicht liegen...

    Viele Grüße
    DocAdams

    1x RaspberryPi 2, 1x RaspberryPi 3, 1x OpenELEC, 1x RaspberryPi 4 mit ioBroker ,

  • Was aber dagegen spricht (mMn) ist, dass der Stream ja beim alten RasPi ankommt.

    Aber nur da, Du willst aber es aber woanders sehen.

    Ich vermute mal, das irgendwo abgespeichert ist, welcher Rechner (IP?) das sehen darf.

    Hast Du den Zugriff auf das Menü der Kamera? Vielleicht ist ja dort ein Eintrag versteckt.


    Alternativ fällt mir dazu noch ein, das Du die IP-Adresse Deines IO-Brokers änderst

    und dem neuen Raspi die alte vom IO-Broker gibst.

    Oder kann es an den Freigaben Deines DSL-Modems liegen.

    Ich lese in den Merkbücher (Handbücher sind das ja nicht) viel über Cloud.


    Die Kamera sieht zwar gut aus, aber kaufen, würde ich sie wegen der Cloud nicht.


    MfG


    Jürgen

  • Hallo,

    meinst du soetwas wie ein IP Filter bzw. Trusted Sites?

    Das ist leider leer. Also, ist leider nicht die Lösung.


    Die Kamera arbeitet ohne Cloud, sie ist in der FritzBox hart gesperrt.

    Und als ich versuchsweise die Sperre mal aufgehoben hatte, gab es auch in piHole keinen Eintrag, dass sie raustelefonieren wollte.


    Auf dem neuen RasPi soll ja eigentlich ioBroker gar nicht mehr laufen. Eventuell ziehe ich dann auch mit piHole auf ihn um. Dann läuft auf dem einen RasPi nur ioBroker mit Phoscon und auf dem anderen Motion, piHole und (langfristig geplant) noch ein VPN-Programm. Dann sind die Aufgaben etwas verteilter. So der Plan...

    Viele Grüße
    DocAdams

    1x RaspberryPi 2, 1x RaspberryPi 3, 1x OpenELEC, 1x RaspberryPi 4 mit ioBroker ,

    Edited 2 times, last by docadams ().