Reboot/Shutdown schließt Port - danach kein aktives ssh mehr!

  • Hallo, liebes Forum!


    Wie Ihr seht, bin ich wirklich ganz neu – und mein Problem ist gerade dabei, mir meinen Raspberry-Einstieg so richtig gründlich zu vermiesen! Ich habe meinen Raspberry 4B (4 GB, Kernel: 5.4.72-v7l+, https://www.berrybase.de/raspb…computer-modell-b-4gb-ram) nämlich bisher noch gar nicht richtig zum Laufen bekommen. Ich verwende

    Als Router habe ich die Fritz!Box 7580 und auf dem Rechner Linux (Mint 20 Cinnamon). Der Raspberry hängt am LAN.


    Das Problem: Der Raspi macht (von Anfang an) keinen Reboot, sondern fährt „nur“ runter. Ergebnis: Port wird geschlossen. Ich komme anschließend mit ssh nicht mehr dran.


    Mein bisheriges Vorgehen:

    • Image auf die SD gebracht, ssh-Datei im boot-Ordner ergänzt, SD eingesetzt und mit dem Terminal gestartet (ssh pi@raspberrypi)
    • Passwort geändert, ssh aktiviert, Spracheinstellungen und andere geändert, auf <Finish> gegangen und die Frage nach „Reboot?“ bejaht.


    Seitdem passiert immer dasselbe: kein Reboot (egal, ob mit „reboot now“ oder „sudo shutdown -r 0“) – er fährt immer nur runter mit folgender Anzeige:


    „Shutdown scheduled for Sat 2020-11-21 15:44:06 CET, use 'shutdown -c' to cancel.

    pi@raspberrypi:~ $ Connection to raspberrypi closed by remote host.

    Connection to raspberrypi closed.“


    Danach komme ich nicht mehr mit dem Terminal an den Raspi dran. Er wird mir im Router dann auch als „Ungenutzte Verbindung“ angezeigt, es kommt auch kein Ping mehr an und der Portscan zeigt den (Raspi-Standard-)Port 22 bei den offenen nicht an. Ich muss dann immer erst die ssh neu ergänzen, um wieder dran zu kommen. Das kann aber doch nicht sein, oder?


    Mehrfach habe ich das Image wieder neu auf die SD gebracht. Auch eine andere SD hatte dasselbe Ergebnis. Meine Recherchen im Netz haben nichts erbracht (auch über „inurl:forum-raspberrypi.de suchbegriff“, sehr effizient übrigens ;) )– abgesehen von einem Hinweis irgendwo auf das Netzteil („Mysterium“ – 8|), aber das ist bei mir ja original und neu!


    Rpi-update habe ich nicht ausgeführt, die LEDs sind aktiv, der Raspi hat eine feste IP.


    Mit PuTTY habe ich‘s dann auch noch mal probiert – keine Änderung, aber diese Meldung:


    Daraufhin habe ich die Meldung auch intensiv gegoogelt und noch Folgendes probiert:


    Das Ergebnis war dann keine Überraschung …

    Was läuft da falsch? Muss ich irgendwelche Einstellungen am Router machen? Den Port freigeben (will ja aber erst mal noch gar nicht vom Internet zugreifen!)? Ich würde den Raspi so gerne nutzen können!

    Ich hoffe, jemand kann bitte helfen … danke!

    • Official Post

    Spracheinstellungen und andere geändert

    Welche anderen genau? :conf: Der Fehler liest sich wie System ro gemountet, bzw. OverlayFS aktiviert.


    Was ist am RPi die Ausgabe von findmnt?



    //Edit Oder verstehe ich das alles falsch und sudo reboot ist einfach der Befehl, den Du suchst?

  • eifeelove Nur um Missverständnissen vorzubeugen: Auch wenn der SSH-Server nach einem Neustart aktiv ist, die laufende SSH-Verbindung wird auf jeden Fall abgebrochen und muss danach aktiv neu aufgebaut werden. Die Meldungen von den SSH-Clients sind also in jedem Fall erwartbar.

    “The most likely way for the world to be destroyed, most experts agree, is by accident. That's where we come in; we're computer professionals. We cause accidents.” — Nathaniel Borenstein

  • Hallo hyle,


    das Ergebnis von "findemnt" sieht so aus:


    TARGET SOURCE FSTYPE OPTIONS

    / /dev/mmcblk0p2

    │ ext4 rw,noatime

    ├─/dev devtmpfs devtmpf rw,relatime,size=183386

    │ ├─/dev/shm tmpfs tmpfs rw,nosuid,nodev

    │ ├─/dev/pts devpts devpts rw,nosuid,noexec,relati

    │ └─/dev/mqueue mqueue mqueue rw,relatime

    ├─/sys sysfs sysfs rw,nosuid,nodev,noexec,

    │ ├─/sys/kernel/security securityfs securit rw,nosuid,nodev,noexec,

    │ ├─/sys/fs/cgroup tmpfs tmpfs ro,nosuid,nodev,noexec,

    │ │ ├─/sys/fs/cgroup/unified cgroup2 cgroup2 rw,nosuid,nodev,noexec,

    │ │ ├─/sys/fs/cgroup/systemd cgroup cgroup rw,nosuid,nodev,noexec,

    │ │ ├─/sys/fs/cgroup/net_cls,net_prio cgroup cgroup rw,nosuid,nodev,noexec,

    │ │ ├─/sys/fs/cgroup/perf_event cgroup cgroup rw,nosuid,nodev,noexec,

    │ │ ├─/sys/fs/cgroup/freezer cgroup cgroup rw,nosuid,nodev,noexec,

    │ │ ├─/sys/fs/cgroup/blkio cgroup cgroup rw,nosuid,nodev,noexec,

    │ │ ├─/sys/fs/cgroup/cpu,cpuacct cgroup cgroup rw,nosuid,nodev,noexec,

    │ │ ├─/sys/fs/cgroup/devices cgroup cgroup rw,nosuid,nodev,noexec,

    │ │ ├─/sys/fs/cgroup/pids cgroup cgroup rw,nosuid,nodev,noexec,

    │ │ └─/sys/fs/cgroup/cpuset cgroup cgroup rw,nosuid,nodev,noexec,

    │ ├─/sys/fs/bpf none bpf rw,nosuid,nodev,noexec,

    │ ├─/sys/kernel/debug debugfs debugfs rw,relatime

    │ └─/sys/kernel/config configfs configf rw,relatime

    ├─/proc proc proc rw,relatime

    │ └─/proc/sys/fs/binfmt_misc systemd-1 autofs rw,relatime,fd=25,pgrp=

    ├─/run tmpfs tmpfs rw,nosuid,nodev,mode=75

    │ ├─/run/lock tmpfs tmpfs rw,nosuid,nodev,noexec,

    │ ├─/run/rpc_pipefs sunrpc rpc_pip rw,relatime

    │ └─/run/user/1000 tmpfs tmpfs rw,nosuid,nodev,relatim

    └─/boot /dev/mmcblk0p1

    vfat rw,relatime,fmask=0022,


    Die "anderen" Einstellungen waren die üblichen unter "Localisation Options" (Locale, Timezone, Keyboard, WLAN Country), bei "Advanced Options" die "Expand Filesystem" und bei "Performance Options" die "GPU Memory" (hier habe ich 64 MB aber nicht verndert) - und (klar) SSh enabled unter "Interface Options" .

    • Official Post

    das Ergebnis von "findemnt" sieht so aus:

    Sieht für mich normal aus.

    Mein bisheriges Vorgehen:

    Image auf die SD gebracht, ssh-Datei im boot-Ordner ergänzt, SD eingesetzt und mit dem Terminal gestartet (ssh pi@raspberrypi)
    Passwort geändert, ssh aktiviert, Spracheinstellungen und andere geändert, auf <Finish> gegangen und die Frage nach „Reboot?“ bejaht.

    Wenn Du eine ssh-Datei im /boot hattest und dann extra noch per sudo raspi-config SSH aktivieren wolltest, hast Du den SSH-Server dann nicht versehentlich wieder deaktiviert?


    Blöde Frage ich weiß, aber Faselfehler passieren halt auch manchmal.


  • Sieht für mich normal aus.

    Wenn Du eine ssh-Datei im /boot hattest und dann extra noch per sudo raspi-config SSH aktivieren wolltest, hast Du den SSH-Server dann nicht versehentlich wieder deaktiviert?


    Blöde Frage ich weiß, aber Faselfehler passieren halt auch manchmal.

    Hm, wenn das so ist ... die letzten Male hab' ich eigentlich mit "systemctl is-enabled ssh" das Ergebnis "enabled" bekommen. Und die Befehle "sudo reboot" bzw. "shutdown -r 0" hatte ich auf meiner Suche gefunden und auch

  • eifeelove Nur um Missverständnissen vorzubeugen: Auch wenn der SSH-Server nach einem Neustart aktiv ist, die laufende SSH-Verbindung wird auf jeden Fall abgebrochen und muss danach aktiv neu aufgebaut werden. Die Meldungen von den SSH-Clients sind also in jedem Fall erwartbar.

    Okay, aber wenn ich ihm sage, dass er rebooten soll - müsste er dann die Verbindung nicht von sich aus wieder aufbauen? Und muss ich auch beim Runterfahren jedesmal erst wieder die ssh-Datei unter /boot einfügen? Wäre ja doch sehr umständlich und würde bedeuten, dass der raspi rund um die Uhr laufen müsste, wenn ich das vermeiden will :conf:.

    • Official Post

    Ok, nochmals anders ausgedrückt: Die ssh-Datei, die Du auf der Partition /boot erstellt hast aktiviert den SSH-Server. Diese Datei verschwindet dann automatisch, aber der Server bleibt aktiv. Wenn Du dann mit sudo raspi-config bei SSH die Frage

    Quote

    Would you like the SSH server to be enabled?

    mit "NEIN" beantwortest, dann ist SSH wieder deaktiviert.


    Okay, aber wenn ich ihm sage, dass er rebooten soll - müsste er dann die Verbindung nicht von sich aus wieder aufbauen?

    Die Verbindung nicht, aber SSH sollte nach einem Reboot eigentlich aktiv, bzw. der RPi erreichbar sein.

  • Ok, nochmals anders ausgedrückt: Die ssh-Datei, die Du auf der Partition /boot erstellt hast aktiviert den SSH-Server. Diese Datei verschwindet dann automatisch, aber der Server bleibt aktiv. Wenn Du dann mit sudo raspi-config bei SSH die Frage

    mit "NEIN" beantwortest, dann ist SSH wieder deaktiviert.


    Die Verbindung nicht, aber SSH sollte nach einem Reboot eigentlich aktiv, bzw. der RPi erreichbar sein.

    D. h. ich fahre ihn hoch mit der ssh auf /boot, und wenn ich ihn dann rebooten lasse, ohne irgendetwas mit der ssh im raspi-config zu machen, müsste es funktionieren?

  • Korrekt!

    Oh no - eben mit "sudo reboot now" so ausprobiert, und: zumindest bleibt die Verbindung erhalten :bravo2: !!!! So weit war ich bisher echt noch nicht! Ich bin echt happy - danke! Also eigentlich Finger weg vom ssh im raspi-config - zumindest beim (Erst-)Einrichten?


    Bleibt noch die Frage, warum er aber nicht wieder hochfährt - oder geht das nur bei der Variante mit Bildschirm und Tastatur?

  • Schade - zu früh gefreut ... eben mit "shutdown -h 0" runtergefahren, und wieder "no route to host" :wallbash:.

    Damit hast du ihn ja auch ausgeschalten.


    Einfach ssh dauerhaft aktivieren


    Code
    sudo systemctl enable ssh


    Und dann kannst Du rebooten so oft Du willst und immer wieder per ssh darauf zugreifen (ausser der Fehler liegt im Netzwerk, Namensauflösung etc. ...).

  • Wenn ein Warmstart (reboot) beim Pi versagt, deutet das auf eine Rückwärtseinspeisung von 5 V hin.

    Wenn kein fremdgespeistes Gerät verwendet wird, kann das auch noch vom Ethernet Controller kommen (HDMI Gerät ist ja keines angeschlossen ?). Ziehe probeweise einmal das Ethernetkabel nach dem reboot Befehl ab.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Namensauflösung: Wenn Du ihn bspw. mit der IP erreichen kannst, aber nicht unter dem Hostnamen.

    Huuh, wenn ich jetzt statt des Namens die IP nehme, kommt eine fette Meldung, die Ihr vermtl. alle gut kennt: WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!

    Macht es Sinn, den vorgeschlagenen ssh-keygen - Befehl auszuführen?