Raspian Desktop-Oberfläche wird nicht mehr angezeigt

  • Hallo zusammen,


    ich benötige Hilfe mit meinem Raspberry Pi 4 mit Raspian installiert. Kurz zur Anwendung: Ich nutze den Raspberry um mit iobroker meine Smarthome-Anwendungen umzusetzen. Ich habe Raspian installiert und Nutze den Browser um auf meine Visualisierung zu zugreifen.

    Jetzt hat der Raspberry regelmäßig den Monitor auf Standby geschalten. Und das wollte ich abstellen und bin auf diese Anleitung gestoßen: https://www.elektronik-kompend…/raspberry-pi/2107011.htm

    Ich habe die Lösung 2 angewendet.

    Code
    nano .config/lxsession/LXDE-pi/autostart

    Hier habe ich folgende Zeilen eingegeben

    Code
    @xset s noblank
    @xset s off
    @xset -dpms

    Nachdem Neustart geht der HDMI Ausgang zwar nicht mehr in Standby, aber ich habe keine Desktop-Oberfläche mehr. Lediglich einen schwarzen Hintergrund.

    Bei Rechtsklick erscheint noch folgendes:

    Ich kenne mich zu wenig aus um zu verstehen was ich verändert habe. Ich hoffe jemand kann mir hier weiterhelfen und erklären wie ich die normale Desktopoberfläche wieder zurück bekommen.


    Grüße Lukas

  • Go to Best Answer
  • Die einfachste Lösung ist:

    Code
    sudo apt install xfce4-power-manager

    Damit kommt jedes Kind klar :thumbup:

    Und mache Deine Änderungen wieder weg.

    • Best Answer
    Code
    nano .config/lxsession/LXDE-pi/autostart

    Hier habe ich folgende Zeilen eingegeben

    Code
    @xset s noblank
    @xset s off
    @xset -dpms

    Wenn nur noch diese drei Zeilen in der autostart Datei stehen, dann ist das die Erklärung. I.d.R. steht das so was wie folgendes:

    Code
    @lxpanel --profile LXDE-pi
    @pcmanfm --desktop --profile LXDE-pi
    @xscreensaver -no-splash
    @point-rpi

    Die erste Zeile lädt die Startleiste und die zweite Zeile lädt die Desktopumgebung. Diese beiden Zeilen brauchst du also mindestens für entspanntes Arbeiten mit der Schreibtischoberfläche. ;)

  • Vielen Dank für die schnellen Antworten.

    Ich habe wohl in der Autostartdatei versehentlich was gelöscht.

    Code
    @lxpanel --profile LXDE-pi
    @pcmanfm --desktop --profile LXDE-pi
    @xscreensaver -no-splash
    @point-rpi

    Nachdem ich die Zeilen ergänzt habe ist wieder Alles beim Alten. Dankeschön.

    • Official Post

    Ich habe wohl in der Autostartdatei versehentlich was gelöscht.

    Nein, die Datei existierte vorher nicht. Früher gab es diese dort, aber seit Stretch (glaube ich wars) liegt die Konfigurationsdatei hier: /etc/xdg/lxsession/LXDE-pi/autostart. Wenn Du nun aber zusätzlich die Datei in /home/pi/.config/lxsession/LXDE-pi/autostart erstellst, dann wird die bereits vorhandene ignoriert.